Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Май 2018, 12:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Установка диапазонов базовых цен  (Прочитано 4803 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн grohman33

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-23
  • Сайт: 
Эта функция подразумевает собой установку цены от заданного диапазона, что совсем неудобно, можно ли установить именно наценку желательно в процентном выражении на заданный диапазон?

"Управление торговлей для Украины", редакция 2.3.


Оффлайн grohman33

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-23
  • Сайт: 
помогите пжлста.. кто сталкивался уже с этим вышлите скрипт исправленной функции, оплачу в ВМЗ

Оффлайн grohman33

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-23
  • Сайт: 
было так:Выборка = ЗапросДиапазоны.Выполнить().Выбрать();

          Если Выборка.Следующий() Тогда
               РасчетнаяЦена = Выборка.Цена;
               Валюта = Выборка.Валюта;
          КонецЕсли;
     КонецЕсли;


     Возврат РасчетнаяЦена;

стало так но функция не работает продолжает устанавливать цену вместо наценки:


      Если Выборка.Следующий() Тогда
         РасчетнаяЦена = Цена*(1+Выборка.Цена/100);
         Валюта = Выборка.Валюта;
      КонецЕсли;
   КонецЕсли;


   Возврат РасчетнаяЦена;

подскажите где ошибка...

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Ошибки здесь нет,,,она хде то в другом месте!!!

Оффлайн grohman33

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-23
  • Сайт: 
а где ж ее искать где может быть ошибка еще?

Slin
  • Гость
         РасчетнаяЦена = Цена*(1+Выборка.Цена/100);
Откуда Цена взялась?


Теги:
 

Установка ориентации страницы "Ландшафт"

Автор summerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4945
Последний ответ 11 Янв 2011, 11:05
от summer
Внешняя обработка для документа "Установка цен номенклатуры"

Автор MArrРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 5465
Последний ответ 05 Апр 2015, 08:21
от blackmoon89
Установка цены продажи из документа "Поступление товаров и услуг" как?

Автор grandistokРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2016
Последний ответ 13 Май 2014, 16:34
от cska-fanat-kz
Розница 2.0 Установка способа оплаты в документе Реализация товаров и услуг

Автор Natascha1990Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2991
Последний ответ 19 Мар 2013, 14:36
от Natascha1990
Установка даты запрета редактирования, как расширить выбором конкретных документов

Автор Саша ЛибертиРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3616
Последний ответ 13 Июн 2014, 11:24
от Саша Либерти

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
152 Сообщений
oleg-x
64 Сообщений
alex0402
61 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
34 Сообщений
buketov.av buketov.av
34 Сообщений
Alter
23 Сообщений
alexandr_ll
20 Сообщений
BuhRust
20 Сообщений

* Кто онлайн

  • Точка Гостей: 896
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal