Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Июн 2018, 07:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запись данных из одного поля в другое  (Прочитано 1780 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн keramik

  • ***
  • Сообщений: 161
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-10-03
  • Сайт: 
  • Профессия: Программист 1С
Привет!
В форме есть два поля - "Модель" (заполняется вручную из списка значений) и "Наименование", которое заполняется при помощи этой процедуры:
Процедура НаименованиеНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;

ГосНомерСтр = СокрЛП(ГосНомер);
МодельСтр = СокрЛП(Модель);
ЦветСтр = СокрЛП(Цвет);
ШассиСтр = ?(ЗначениеЗаполнено(СокрЛП(VIN)),"VIN "+СокрЛП(VIN),"");

НовоеНаименование1 = СокрЛ(МодельСтр+" ") + СокрЛ(ЦветСтр+" ") + СокрЛ(ГосНомерСтр+" ") + СокрЛ(ШассиСтр);
НовоеНаименование2 = СокрЛ(ГосНомерСтр+" ") + СокрЛ(МодельСтр+" ") + СокрЛ(ЦветСтр+" ") + СокрЛ(ШассиСтр);
НовоеНаименование3 = СокрЛ(ШассиСтр+" ") + СокрЛ(МодельСтр+" ") + СокрЛ(ЦветСтр+" ") + СокрЛ(ГосНомерСтр);

СписокДляВыбора = Новый СписокЗначений;
Если ЗначениеЗаполнено(Наименование) Тогда
СписокДляВыбора.Добавить(СокрЛП(Наименование));
КонецЕсли;
Если ЗначениеЗаполнено(НовоеНаименование1) Тогда
СписокДляВыбора.Добавить(НовоеНаименование1);
СписокДляВыбора.Добавить(НовоеНаименование2);
СписокДляВыбора.Добавить(НовоеНаименование3);
КонецЕсли;

//Автозаполнение элемента формы с выбором из списка значений
Элемент.Значение = РаботаСДиалогами.глВыборЗначенияИзСпискаАвтоформирования(ЭтаФорма,Элемент,СписокДляВыбора,Истина);
КонецПроцедуры

В дальнейшем значение поля "Наименование"используется в списке элементов.
Как подправить процедуру, чтобы она в поле автоматически подставляла значения из поля "Модель"?
Просто указать тип данных "Модель" ничего не даёт, при записи появляется сообщение, что поле незаполненно, хотя оно автоматически заполняется тем же значением, что и поле модель...

Пробовал так:
	    Если ПустаяСтрока(Наименование) Тогда
        Наименование = Модель;
КонецЕсли;
Но не работает, значение не подставляется.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
в МодельПриИзменении() пишем:
Наименование = Модель.Наименование;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн keramik

  • ***
  • Сообщений: 161
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-10-03
  • Сайт: 
  • Профессия: Программист 1С
Спасибо, буду пробовать.

Ура! Заработало.
Добавлено: 27 Ноя 2014, 09:15

Возник ещё вопрос. Как добавить в этот код вывод строки с гос.номером авто?
Пробую так:
МодельПриИзменении()
Если ЭтоНовый() Тогда
Наименование = ГосНомер+Модель.Наименование;
КонецЕсли;
Но всё равно передаётся только название модели...
Добавлено: 27 Ноя 2014, 11:39

Продолжаю искать решение, такой вариант тоже не выдаёт гос номер и марку, а только марку:
Наименование = Новый СписокЗначений;
Если НЕ ЗачениеЗаполнено(Наименование) Тогда
Наименование = ГосНомер+Модель.Наименование;
КонецЕсли;
Какая команда или оператор позволяет объединить значение двух полей в одном?

Последний раз редактировалось: keramik; 27 Ноя 2014, 11:39. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
"+" и позволяет!
ГосНомер - тоже поле на форме?
Тогда в ГосномерПриИзменении() пишем
Наименование = ""+Госномер+Марка.Наименование;

то же в МаркаПриИзменении()
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн keramik

  • ***
  • Сообщений: 161
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-10-03
  • Сайт: 
  • Профессия: Программист 1С
Да, это поле на форме. Сейчас попробую.

Получилось!
Спасибо за помощь. Что-то я не подумал, что надо ещё и процедуру вызова ГосНомера править.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Что-то я не подумал, что надо ещё и процедуру вызова ГосНомера править.

ну если вы наименование из двух частей собираете, то логично что надо в двух местах и прописывать...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8182
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4204
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2705
Последний ответ 26 Апр 2018, 06:45
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 8645
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7800
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
138 Сообщений
AIFrame AIFrame
130 Сообщений
alexandr_ll
65 Сообщений
pavl_vs
48 Сообщений
alex0402
44 Сообщений
buketov.av buketov.av
37 Сообщений
ilyay ilyay
36 Сообщений
trialex3
22 Сообщений
magnifico61
21 Сообщений
wise wise
18 Сообщений

* Кто онлайн

  • Точка Гостей: 306
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal