Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 20:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Движение остатков ТМЦ в УТ 11  (Прочитано 6139 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Migel86

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-27
  • Сайт: 
Доброго времени форумчане!
Есть документ которым создается движение ТМЦ, на остатках в складах все отображается, но при продаже ТМЦ товар ОТСУТСТВУЕТ и соответственно не может быть продан.
Вот код движения этого документа
// регистр ТоварыНаСкладах Приход
Движения.ТоварыНаСкладах.Записывать = Истина;
Для Каждого ТекСтрокаПрокат Из Прокат Цикл
Движение = Движения.ТоварыНаСкладах.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаПрокат.Номенклатура;
Движение.Характеристика = ТекСтрокаПрокат.ХарактеристикаНоменклатуры;
Движение.Склад = СкладПолучатель;
Движение.Серия = ТекСтрокаПрокат.Серия;
Движение.ВНаличии = ТекСтрокаПрокат.Вес;
КонецЦикла;

// регистр ТоварыНаСкладах Расход
Движения.ТоварыНаСкладах.Записывать = Истина;
Для Каждого ТекСтрокаЛом Из Лом Цикл
Движение = Движения.ТоварыНаСкладах.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаЛом.Лом;
Движение.Склад = СкладОтправитель;
Движение.ВНаличии = ТекСтрокаЛом.Вес;
КонецЦикла;

// регистр ТоварыОрганизаций Приход
Движения.ТоварыОрганизаций.Записывать = Истина;
Для Каждого ТекСтрокаПрокат Из Прокат Цикл
Движение = Движения.ТоварыОрганизаций.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаПрокат.Номенклатура;
Движение.Характеристика = ТекСтрокаПрокат.ХарактеристикаНоменклатуры;
Движение.Склад = СкладПолучатель;
Движение.Организация = Организация;
Движение.ВидЗапасов = ВидЗапасов;
Движение.Количество = ТекСтрокаПрокат.Вес;
Движение.ОрганизацияОтгрузки = Организация;
Движение.ДокументРеализации = ДокументОснование;
КонецЦикла;

// регистр ТоварыОрганизаций Расход
Движения.ТоварыОрганизаций.Записывать = Истина;
Для Каждого ТекСтрокаЛом Из Лом Цикл
Движение = Движения.ТоварыОрганизаций.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаЛом.Лом;
Движение.Склад = СкладОтправитель;
Движение.Организация = Организация;
Движение.ВидЗапасов = ВидЗапасов;
Движение.Количество = ТекСтрокаЛом.Вес;
Движение.ОрганизацияОтгрузки = Организация;
Движение.ДокументРеализации = ДокументОснование;
КонецЦикла;

// регистр ГрафикДвиженияТоваров Приход
Движения.ГрафикДвиженияТоваров.Записывать = Истина;
Для Каждого ТекСтрокаПрокат Из Прокат Цикл
Движение = Движения.ГрафикДвиженияТоваров.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаПрокат.Номенклатура;
Движение.Характеристика = ТекСтрокаПрокат.ХарактеристикаНоменклатуры;
Движение.Склад = СкладПолучатель;
Движение.ДатаСобытия = Дата;
Движение.Количество = ТекСтрокаПрокат.Вес;
КонецЦикла;

// регистр ГрафикДвиженияТоваров Расход
Движения.ГрафикДвиженияТоваров.Записывать = Истина;
Для Каждого ТекСтрокаЛом Из Лом Цикл
Движение = Движения.ГрафикДвиженияТоваров.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаЛом.Лом;
Движение.Склад = СкладОтправитель;
Движение.ДатаСобытия = Дата;
Движение.Количество = ТекСтрокаЛом.Вес;
КонецЦикла;

// регистр СвободныеОстатки Приход
Движения.СвободныеОстатки.Записывать = Истина;
Для Каждого ТекСтрокаПрокат Из Прокат Цикл
Движение = Движения.СвободныеОстатки.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаПрокат.Номенклатура;
Движение.Характеристика = ТекСтрокаПрокат.ХарактеристикаНоменклатуры;
Движение.Склад = СкладПолучатель;
Движение.Серия = ТекСтрокаПрокат.Серия;
Движение.ВНаличии = ТекСтрокаПрокат.Вес;
Движение.СрокПоставки = Дата;
КонецЦикла;

// регистр СвободныеОстатки Расход
Движения.СвободныеОстатки.Записывать = Истина;
Для Каждого ТекСтрокаЛом Из Лом Цикл
Движение = Движения.СвободныеОстатки.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаЛом.Лом;
Движение.Склад = СкладОтправитель;
Движение.ВНаличии = ТекСтрокаЛом.Вес;
Движение.СрокПоставки = Дата;
КонецЦикла;

ХЕЛП!!!!


Оффлайн sertak

  • ****
  • Сообщений: 274
  • РЕПУТАЦИЯ: 74
  • КПД: 27%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: www.sertakov.ru
  • Профессия: Программист 1С
Есть документ которым создается движение ТМЦ, на остатках в складах все отображается, но при продаже ТМЦ товар ОТСУТСТВУЕТ и соответственно не может быть продан.
Ключевое слово "При продаже". Каким документом осуществляется продажа, в какой момент (при подборе, при проведении и т.п.) и что пишет?
Сверьте дату прихода товара ТМЦ с датой, на которую проверяет остатки документ продажи.
Если ты знаешь свой путь, то удачи и неудачи равно продвигают тебя вперед

Последний раз редактировалось: sertak; 25 Ноя 2014, 09:55

Оффлайн Migel86

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-27
  • Сайт: 
чекККМ, реализация товаров и услуг. остатки и документы день в день

Оффлайн sertak

  • ****
  • Сообщений: 274
  • РЕПУТАЦИЯ: 74
  • КПД: 27%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: www.sertakov.ru
  • Профессия: Программист 1С
Надо пройтись отладчиком в документе продажи. В частности, проверить, на какое именно время снимаются остатки. Не раньше ли оно времени прихода.
Если ты знаешь свой путь, то удачи и неудачи равно продвигают тебя вперед

Оффлайн Migel86

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-27
  • Сайт: 
Надо пройтись отладчиком в документе продажи. В частности, проверить, на какое именно время снимаются остатки. Не раньше ли оно времени прихода.
Остатки на текущий момент.
Может кто скажет на каком регистре сведений это лежит в реализации

Оффлайн sertak

  • ****
  • Сообщений: 274
  • РЕПУТАЦИЯ: 74
  • КПД: 27%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: www.sertakov.ru
  • Профессия: Программист 1С
Может кто скажет на каком регистре сведений это лежит в реализации
Поясните вопрос.
Если ты знаешь свой путь, то удачи и неудачи равно продвигают тебя вперед

Оффлайн Migel86

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-27
  • Сайт: 
Поясните вопрос.
Остатки на складах появляются после движения документа по регистрам, приход на склад есть, значит должен быть и расход.
по приходу они у меня двигаются по: ТоварыНаСкладах,ТоварыОрганизации,
а вот как они двигаются при реализации понять не могу


Оффлайн sertak

  • ****
  • Сообщений: 274
  • РЕПУТАЦИЯ: 74
  • КПД: 27%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: www.sertakov.ru
  • Профессия: Программист 1С
Так же. Они как Инь и Янь.
Насчет времени я имел в виду, что проверка доступности ТМЦ должна осуществляться на дату/время более позднюю, чем дата/время прихода. Поэтому если день прихода и расхода совпадает, стоит проверить, на какое именно время проверяются остатки ТМЦ при продаже. Например, если на начало суток, тогда остатки не будут видны.
Приведите пример сообщения, которое выводится документом продажи. Часто там фигурирует имя регистра, по которому не были найдены остатки.
Если ты знаешь свой путь, то удачи и неудачи равно продвигают тебя вперед

Оффлайн Migel86

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-27
  • Сайт: 
1. Реализация превышает остаток товара организации ... по налогооблажению ...
2.Номенклатура:.... на складе .... недостаточно 2 кг
Добавлено: 25 Ноя 2014, 10:52

1. Реализация превышает остаток товара организации ... по налогооблажению ...
2.Номенклатура:.... на складе .... недостаточно 2 кг
и такие проблемы только с товарами которые пришли на склад документами одного вида

Последний раз редактировалось: Migel86; 25 Ноя 2014, 10:52. Причина: Объединение сообщений

Оффлайн sertak

  • ****
  • Сообщений: 274
  • РЕПУТАЦИЯ: 74
  • КПД: 27%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: www.sertakov.ru
  • Профессия: Программист 1С
Сделайте скрин движений документа прихода по регистру ТоварыОрганизаций.
Добавлено: 25 Ноя 2014, 11:21

Может, какая-то аналитика некорректна.
Если ты знаешь свой путь, то удачи и неудачи равно продвигают тебя вперед


Теги:
 

Отчеты "Ведомость ОС, НМА" и "Ведомость остатков материалов"

Автор OlegatorOGРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2608
Последний ответ 04 Апр 2015, 06:15
от OlegatorOG
«Единица для отчетов» и «Единица хранения остатков»

Автор tranceferРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 7565
Последний ответ 14 Фев 2012, 02:29
от Dethmontt
В чем отличие регистра оборотов и регистра остатков

Автор Dmitry QweРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 338
Последний ответ 20 Сен 2017, 11:03
от ilyay
Просмотр остатков из документа "Заказ Покупателя"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2853
Последний ответ 24 Авг 2011, 20:29
от Eugeneer
Отображение остатков брак. товара в "Рабочем месте менеджера по продажам"

Автор LittleHedgehogРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2901
Последний ответ 16 Фев 2010, 11:15
от LittleHedgehog

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
48 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 210
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal