Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Фев 2018, 05:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание печатной формы  (Прочитано 3473 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ppkmlite

  • **
  • Сообщений: 78
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Создаю печатную форму(акт). На макете должен выбираться контрагент, договор(либо иное основание возникновения обязательств) и в табличной части
все документы оказания услуг, товаров , работ по этому договору.
Я сделала так
Процедура АктНажатие(Элемент)
    ТабДок = ПечатьАкта(ТабДок);
    ТабДок.ТолькоПросмотр = Истина;
КонецПроцедуры

Функция ПечатьАкта(ТабДок);
      //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

    Макет = Справочники.Договоры.ПолучитьМакет("Макет1");
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    МЗ_Покупка.Материалы.(
        |        Ссылка КАК Материал,
        |        ПРЕДСТАВЛЕНИЕ(МЗ_Покупка.Материалы.Ссылка),
        |        Количество,
        |        ЕдиницаИзмерения,
        |        ПРЕДСТАВЛЕНИЕ(МЗ_Покупка.Материалы.ЕдиницаИзмерения),
        |        Сумма
        |    ),
|ИЗ
        |    Документ.МЗ_ПокупкаКАК МЗ_Покупка,
Результат = Запрос.Выполнить();

    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
    ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
    ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
    МатериалыОбластьШапкаТаблицы = Макет.ПолучитьОбласть("МатериалыШапкаТаблицы");
    МатериалыОбластьПодвалТаблицы = Макет.ПолучитьОбласть("МатериалыПодвалТаблицы");
    МатериалыОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("МатериалыДетали");
    ТабДок.Очистить();
    ТабДок.Вывести(ОбластьЗаголовок);
    ТабДок.Вывести(ОбластьШапкаТаблицы);
    ТабДок.НачатьАвтогруппировкуСтрок();

    ВыборкаДетальныеЗаписи = Результат.Выбрать();

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
        ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());

        ТабДок.НачатьГруппуСтрок();
        ТабДок.Вывести(МатериалыОбластьШапкаТаблицы);
        ТабДок.НачатьАвтогруппировкуСтрок();

        МатериалыВыборкаДетальныеЗаписи = ВыборкаДетальныеЗаписи.Материалы.Выбрать();

        Пока МатериалыВыборкаДетальныеЗаписи.Следующий() Цикл
            МатериалыОбластьДетальныхЗаписей.Параметры.Заполнить(МатериалыВыборкаДетальныеЗаписи);
            ТабДок.Вывести(МатериалыОбластьДетальныхЗаписей, МатериалыВыборкаДетальныеЗаписи.Уровень());
        КонецЦикла;

        ТабДок.ЗакончитьАвтогруппировкуСтрок();
        ТабДок.Вывести(МатериалыОбластьПодвалТаблицы);
        ТабДок.Вывести(КапвложенияОбластьШапкаТаблицы);
        ТабДок.НачатьАвтогруппировкуСтрок();
Как мне в запросе прописать, что нужно отбирать только документы по выбранному договору в шапке?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
На макете должен выбираться контрагент, договор

макет служит только для формирования отчета, ничего в нем не выбирается. может "на форме"?

это печатная форма к чему? к документу М3_Покупка? к справочнику Договоры?

все документы оказания услуг, товаров , работ по этому договору

"все документы" - это несколько видов? пока запрос идет только к одному...

И вообще... заведите такой объект как КритерийОтбора и свяжите договор с вашими документами. Список документов по договору начнете получать ДАЖЕ БЕЗ ПРОГРАММИРОВАНИЯ.

Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ppkmlite

  • **
  • Сообщений: 78
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо.
Вообще на на элементе справочника договоры (то есть когда я захожу в список договоров, потом в конкретный договор)кнопка должна быть(акты), при нажатии на ней печатная форма всех покупок мз, оказанных услуг только по договору, на форме которого мы находимся. Я сделала как то так, но меня ошибка выходит.
Процедура АктНажатие(Элемент)
   ТабДок = ПечатьАкта(ТабДок);
   ТабДок.ТолькоПросмотр = Истина;
КонецПроцедуры
Функция ПечатьАкта(ТабДок) Экспорт
     //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

   Макет = Справочники.Договоры.ПолучитьМакет("Макет1");
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   УслугиСтороннихОрганизаций.Услуги.(
      |      Ссылка КАК Услуга,
      |      ПРЕДСТАВЛЕНИЕ(УслугиСтороннихОрганизаций.Услуги.Ссылка),
      |      Количество,
      |      Сумма,
      |      ЕдиницаИзмерения,
      |      ПРЕДСТАВЛЕНИЕ(УслугиСтороннихОрганизаций.Услуги.ЕдиницаИзмерения)
      |   ),
      |   ОС_Покупка.Капвложения.(
      |      Ссылка КАК ОсновноеСредство,
      |      ПРЕДСТАВЛЕНИЕ(ОС_Покупка.Капвложения.Ссылка),
      |      Сумма,
      |      Количество
      |   ),
      |   МЗ_Покупка.СубконтоСчетКредита3 КАК МЗ_Договор,
      |   МЗ_Покупка.Материалы.(
      |      Ссылка,
      |      ЕдиницаИзмерения,
      |      Количество,
      |      Сумма
      |   ),
      |   ОС_Покупка.СубконтоСчетКредита3 КАК ОС_Договор,
      |   УслугиСтороннихОрганизаций.Договор
      |ИЗ
      |   Документ.УслугиСтороннихОрганизаций КАК УслугиСтороннихОрганизаций,
      |   Документ.ОС_Покупка КАК ОС_Покупка,
      |   Документ.МЗ_Покупка КАК МЗ_Покупка
      |ГДЕ
      |   МЗ_Покупка.СубконтоСчетКредита3 = &СубконтоСчетКредита3
      |   И ОС_Покупка.СубконтоСчетКредита3 = &СубконтоСчетКредита3
      |   И УслугиСтороннихОрганизаций.Договор = &Договор";\\это все один договор должен быть\\
   Запрос.УстановитьПараметр("СубконтоСчетКредита3",Ссылка);
    Запрос.УстановитьПараметр("Договор",ссылка);
   //Запрос.УстановитьПараметр(""
   Результат = Запрос.Выполнить().Выбрать();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
   ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
   ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
   ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
   МатериалыОбластьШапкаТаблицы = Макет.ПолучитьОбласть("МатериалыШапкаТаблицы");
   МатериалыОбластьПодвалТаблицы = Макет.ПолучитьОбласть("МатериалыПодвалТаблицы");
   МатериалыОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("МатериалыДетали");
   КапвложенияОбластьШапкаТаблицы = Макет.ПолучитьОбласть("КапвложенияШапкаТаблицы");
   КапвложенияОбластьПодвалТаблицы = Макет.ПолучитьОбласть("КапвложенияПодвалТаблицы");
   КапвложенияОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("КапвложенияДетали");
   УслугиОбластьШапкаТаблицы = Макет.ПолучитьОбласть("УслугиШапкаТаблицы");
   УслугиОбластьПодвалТаблицы = Макет.ПолучитьОбласть("УслугиПодвалТаблицы");
   УслугиОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("УслугиДетали");

   ТабДок.Очистить();
   ТабДок.Вывести(ОбластьЗаголовок);
   ТабДок.Вывести(ОбластьШапкаТаблицы);
   ТабДок.НачатьАвтогруппировкуСтрок();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
      ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());

      ТабДок.НачатьГруппуСтрок();
      ТабДок.Вывести(МатериалыОбластьШапкаТаблицы);
      ТабДок.НачатьАвтогруппировкуСтрок();

      МатериалыВыборкаДетальныеЗаписи = ВыборкаДетальныеЗаписи.Материалы.Выбрать();

      Пока МатериалыВыборкаДетальныеЗаписи.Следующий() Цикл
         МатериалыОбластьДетальныхЗаписей.Параметры.Заполнить(МатериалыВыборкаДетальныеЗаписи);
         ТабДок.Вывести(МатериалыОбластьДетальныхЗаписей, МатериалыВыборкаДетальныеЗаписи.Уровень());
      КонецЦикла;

      ТабДок.ЗакончитьАвтогруппировкуСтрок();
      ТабДок.Вывести(МатериалыОбластьПодвалТаблицы);
      ТабДок.Вывести(КапвложенияОбластьШапкаТаблицы);
      ТабДок.НачатьАвтогруппировкуСтрок();

      КапвложенияВыборкаДетальныеЗаписи = ВыборкаДетальныеЗаписи.Капвложения.Выбрать();

      Пока КапвложенияВыборкаДетальныеЗаписи.Следующий() Цикл
         КапвложенияОбластьДетальныхЗаписей.Параметры.Заполнить(КапвложенияВыборкаДетальныеЗаписи);
         ТабДок.Вывести(КапвложенияОбластьДетальныхЗаписей, КапвложенияВыборкаДетальныеЗаписи.Уровень());
      КонецЦикла;

      ТабДок.ЗакончитьАвтогруппировкуСтрок();
      ТабДок.Вывести(КапвложенияОбластьПодвалТаблицы);
      ТабДок.Вывести(УслугиОбластьШапкаТаблицы);
      ТабДок.НачатьАвтогруппировкуСтрок();

      УслугиВыборкаДетальныеЗаписи = ВыборкаДетальныеЗаписи.Услуги.Выбрать();

      Пока УслугиВыборкаДетальныеЗаписи.Следующий() Цикл
         УслугиОбластьДетальныхЗаписей.Параметры.Заполнить(УслугиВыборкаДетальныеЗаписи);
         ТабДок.Вывести(УслугиОбластьДетальныхЗаписей, УслугиВыборкаДетальныеЗаписи.Уровень());
      КонецЦикла;

      ТабДок.ЗакончитьАвтогруппировкуСтрок();
      ТабДок.Вывести(УслугиОбластьПодвалТаблицы);
      ТабДок.ЗакончитьГруппуСтрок();
   КонецЦикла;

   ТабДок.ЗакончитьАвтогруппировкуСтрок();
   ТабДок.Вывести(ОбластьПодвалТаблицы);
   ТабДок.Вывести(ОбластьПодвал);

   //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    Возврат ТабДок;
КонецФункции

Ошибка

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
перед
ТабДок.Очистить();

надо
ТабДок = Новый ТабличныйДокумент;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ppkmlite

  • **
  • Сообщений: 78
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-06
  • Сайт: 
  • Профессия: Ученик 1С
не помогает
Добавлено: 22 Ноя 2014, 19:06

Ну эту ошибку я просмотрю, а вот правильно ли я обращаюсь к параметрам? Ну в смысле как мне по договору отобрать доки, не создавая критерии отбора??
Добавлено: 22 Ноя 2014, 21:38

Ошибку исправила, не работает кнопка!
Процедура АктНажатие(Элемент)
ТабДок = Новый ТабличныйДокумент;
ТабДок = ПечатьАкта(ТабДок);
ТабДок.ТолькоПросмотр = Истина;
КонецПроцедуры
Функция ПечатьАкта(ТабДок) Экспорт
//{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
Макет = Справочники.Договоры.ПолучитьМакет("Макет");
 
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|   УслугиСтороннихОрганизаций.Услуги.(
|   Ссылка КАК Услуга,
|   ПРЕДСТАВЛЕНИЕ(УслугиСтороннихОрганизаций.Услуги.Ссылка),
|   Количество,
|   Сумма,
|   ЕдиницаИзмерения,
|   ПРЕДСТАВЛЕНИЕ(УслугиСтороннихОрганизаций.Услуги.ЕдиницаИзмерения)
|   ),
|   ОС_Покупка.Капвложения.(
|   Ссылка КАК ОсновноеСредство,
|   ПРЕДСТАВЛЕНИЕ(ОС_Покупка.Капвложения.Ссылка),
|   Сумма,
|   Количество
|   ),
|   МЗ_Покупка.СубконтоСчетКредита3 КАК МЗ_Договор,
|   МЗ_Покупка.Материалы.(
|   Ссылка,
|   ЕдиницаИзмерения,
|   Количество,
|   Сумма
|   ),
|   ОС_Покупка.СубконтоСчетКредита3 КАК ОС_Договор,
|   УслугиСтороннихОрганизаций.Договор
|ИЗ
|   Документ.УслугиСтороннихОрганизаций КАК УслугиСтороннихОрганизаций,
|   Документ.ОС_Покупка КАК ОС_Покупка,
|   Документ.МЗ_Покупка КАК МЗ_Покупка
|ГДЕ
|   МЗ_Покупка.СубконтоСчетКредита3 = &СубконтоСчетКредита3
|   И ОС_Покупка.СубконтоСчетКредита3 = &СубконтоСчетКредита3
|   И УслугиСтороннихОрганизаций.Договор = &Договор";
Запрос.УстановитьПараметр("СубконтоСчетКредита3",Ссылка);
Запрос.УстановитьПараметр("Договор",ссылка);
Запрос.УстановитьПараметр("СубконтоСчетКредита3",Ссылка);
РезультатЗапроса = Запрос.Выполнить();
 
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ШапкаТаблиц");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();
 
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
 
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
КонецЦикла;
ТабДок.НачатьГруппуСтрок();
ТабДок.НачатьАвтогруппировкуСтрок();
 
ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();
 
Возврат ТабДок;
КонецФункции

Добавлено: 23 Ноя 2014, 09:58

ТабДок.Показать();
Спасибо, cska-fanat-kz, что откликнулись

Добавлено: 23 Ноя 2014, 12:17

Иду потихоньку дальше
Макет выводится,но без данных(параметры не заполняются). Ни шапка не заполняется, ни табличная часть.
<_<:dfbsdfbsdf:
Я в макете указываю поставщика как параметр .Он должен выводится из контрагента, выбранного на форме элемента справрчника договоры. А как привязать его к запросу, ну чтобы в печатной форме выводился контрагент, ну и название самого договора и в табличной части документы покупка Юуслуги только по этому договору?
Код выше

Добавлено: 23 Ноя 2014, 12:19

Помогите разобраться,пожалуйста

Последний раз редактировалось: ppkmlite; 23 Ноя 2014, 12:19. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. Сперва отладьте запрос в консоли
2. Запрос переделайте. Должен строиться в ключе:
Запрос по таблице ТЧ Услуги документа УслугиСтороннихОрганизаций
ОБЪЕДИНИТЬ
Запрос по таблице ТЧ Капвложения документа ОС_Покупка
ОБЪЕДИНИТЬ
Запрос по таблице ТЧ Материалы документа МЗ_Покупка

Причем должна браться не таблица документа, а таблица его ТЧ.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ppkmlite

  • **
  • Сообщений: 78
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Скажите, а справочник Договоры я тоже должна в запросе указывать, ну то есть мне же нужно документы в отборе по договору вывести?
Добавлено: 23 Ноя 2014, 21:18

1. Сперва отладьте запрос в консоли

2. Запрос переделайте. Должен строиться в ключе:
Запрос по таблице ТЧ Услуги документа УслугиСтороннихОрганизаций
ОБЪЕДИНИТЬ
Запрос по таблице ТЧ Капвложения документа ОС_Покупка
ОБЪЕДИНИТЬ
Запрос по таблице ТЧ Материалы документа МЗ_Покупка

Причем должна браться не таблица документа, а таблица его ТЧ.
Делаю как Вы посоветовали,в консоли вывела данные, запрос по табл части, только у меня получилось
ОБЪЕДИНИТЬ ВСЕ  в запросах.
Мне выходят все наименования, а как сделать отбор по договору, который выбран как параметр в заголовке макета?
Добавлено: 23 Ноя 2014, 21:25

Собственно,что получилось на тек момент
Функция ПечатьАкта(ТабДок) Экспорт
     //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
         Макет = Справочники.Договоры.ПолучитьМакет("Макет");

   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
   |УслугиОказанныеУслуги.Номенклатура,
   |УслугиОказанныеУслуги.ЕдиницаИзмерения,
   |УслугиОказанныеУслуги.Количество,
   |УслугиОказанныеУслуги.Сумма,
   |NULL КАК ВнеоборотныйАктив
|ИЗ
   |Документ.УслугиОказанные.Услуги КАК УслугиОказанныеУслуги
|ГДЕ
   |УслугиОказанныеУслуги.СубконтоСчетКредита3 = УслугиОказанныеУслуги.СубконтоСчетКредита3

|ОБЪЕДИНИТЬ ВСЕ

|ВЫБРАТЬ
   |МЗ_ПокупкаМатериалы.Номенклатура,
   |МЗ_ПокупкаМатериалы.ЕдиницаИзмерения,
   |МЗ_ПокупкаМатериалы.Количество,
   |МЗ_ПокупкаМатериалы.Сумма,
   |NULL
|ИЗ
   |Документ.МЗ_Покупка.Материалы КАК МЗ_ПокупкаМатериалы
|ГДЕ
   |МЗ_ПокупкаМатериалы.Ссылка.СубконтоСчетКредита3 = МЗ_ПокупкаМатериалы.Ссылка.СубконтоСчетКредита3

|ОБЪЕДИНИТЬ ВСЕ

|ВЫБРАТЬ
   |NULL,
   |NULL,
   |ОС_ПокупкаКапвложения.Количество,
   |ОС_ПокупкаКапвложения.Сумма,
   |ОС_ПокупкаКапвложения.ВнеоборотныйАктив
|ИЗ
   |Документ.ОС_Покупка.Капвложения КАК ОС_ПокупкаКапвложения
|ГДЕ
   |ОС_ПокупкаКапвложения.Ссылка.СубконтоСчетКредита3 = ОС_ПокупкаКапвложения.Ссылка.СубконтоСчетКредита3 ";
   Запрос.УстановитьПараметр("СубконтоСчетКредита3",Ссылка);
    Запрос.УстановитьПараметр("СубконтоСчетКредита3",ссылка);
   Запрос.УстановитьПараметр("СубконтоСчетКредита3",Ссылка);
   //Запрос.УстановитьПараметр("ДоговорСпр",ссылка);

   Результат = Запрос.Выполнить();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
      ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
   ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
   ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");     
   ТабДок.Очистить();
   ТабДок.Вывести(ОбластьЗаголовок);
   ТабДок.Вывести(ОбластьШапкаТаблицы);
     ТабДок.НачатьАвтогруппировкуСтрок();
     ТабДок.НачатьГруппуСтрок();
   ВыборкаДетальныеЗаписи = Результат.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
      ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
      ТабДок.Вывести(ОбластьПодвал);
        //ТабДок.НачатьАвтогруппировкуСтрок();

      //ТабДок.Вывести(ОбластьДетальныхЗаписей);
      //ОбластьЗаголовок.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
      //ТабДок.Вывести(ОбластьШапкаТаблицы);
          КонецЦикла;
      
      ТабДок.ЗакончитьАвтогруппировкуСтрок();
      Возврат ТабДок;
КонецФункции

Последний раз редактировалось: ppkmlite; 23 Ноя 2014, 21:25. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
" Запрос.УстановитьПараметр("СубконтоСчетКредита3",Ссылка);
    Запрос.УстановитьПараметр("СубконтоСчетКредита3",ссылка);
   Запрос.УстановитьПараметр("СубконтоСчетКредита3",Ссылка);
   //Запрос.УстановитьПараметр("ДоговорСпр",ссылка);"
Из четырех параметров надо оставить один - он же один и тот же!
Далее в каждом запросе в секции ГДЕ условие должно выглядеть примерно так:
УслугиОказанныеУслуги.СубконтоСчетКредита3 = &Договор
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн notaSS

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-22
  • Сайт: 
  • Профессия: Ученик 1С

У меня тоже такая проблема
Не выводит результат запроса, нужно иполльзовать вложенный запрос

Оффлайн ppkmlite

  • **
  • Сообщений: 78
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-06
  • Сайт: 
  • Профессия: Ученик 1С
" Запрос.УстановитьПараметр("СубконтоСчетКредита3",Ссылка);
    Запрос.УстановитьПараметр("СубконтоСчетКредита3",ссылка);
   Запрос.УстановитьПараметр("СубконтоСчетКредита3",Ссылка);
   //Запрос.УстановитьПараметр("ДоговорСпр",ссылка);"
Из четырех параметров надо оставить один - он же один и тот же!
Далее в каждом запросе в секции ГДЕ условие должно выглядеть примерно так:
УслугиОказанныеУслуги.СубконтоСчетКредита3 = &Договор
Спасибо, с этим разлбралась.Договор выводится, контрагент тоже.
У меня теперь результиат запроса не выводится! у меня теперь 3 поля наименование документа, его дата,номер.Ну и должен быть отбор по контрагенту
Что я только не перепробывала, не получается
Последн результат

ВЫБРАТЬ
   |   ЕСТЬNULL(МЗ_Покупка.Номер, ЕСТЬNULL(ОС_Покупка.Номер, ЕСТЬNULL(УслугиОказанные.Номер, ОперацияБух.Номер))) КАК Поле1,
   |   ЕСТЬNULL(МЗ_Покупка.Ссылка, ЕСТЬNULL(ОС_Покупка.Ссылка, ЕСТЬNULL(УслугиОказанные.Ссылка, ОперацияБух.Ссылка))) КАК Поле2,
   |   ЕСТЬNULL(МЗ_Покупка.Дата, ЕСТЬNULL(ОС_Покупка.Дата, ЕСТЬNULL(УслугиОказанные.Дата, ОперацияБух.Дата))) КАК Поле3
   |ИЗ
   |   Документ.УслугиОказанные КАК УслугиОказанные
   |      ПОЛНОЕ СОЕДИНЕНИЕ Документ.МЗ_Покупка КАК МЗ_Покупка
   |      ПО УслугиОказанные.Договор = МЗ_Покупка.СубконтоСчетКредита3
   |      ПОЛНОЕ СОЕДИНЕНИЕ Документ.ОперацияБух КАК ОперацияБух
   |      ПО УслугиОказанные.Договор = ОперацияБух.ТиповаяОперация.ББУ.СубконтоКт3
   |      ПОЛНОЕ СОЕДИНЕНИЕ Документ.ОС_Покупка КАК ОС_Покупка
   |      ПО УслугиОказанные.Договор = ОС_Покупка.СубконтоСчетКредита3";
Самое главное  вконсоли без отбора выводит доки,\ ставлю отбор по дгоговору не выводит!!


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 444
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5030
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3589
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5315
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 703
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
189 Сообщений
AIFrame AIFrame
81 Сообщений
alexandr_ll
41 Сообщений
BuhRust
29 Сообщений
wise wise
27 Сообщений
oleg-x
26 Сообщений
MuI_I_Ika MuI_I_Ika
25 Сообщений
pavl_vs
22 Сообщений
Кейли Кейли
21 Сообщений
andron81_81
20 Сообщений

* Кто онлайн

  • Точка Гостей: 155
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal