Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подчиненный справочник  (Прочитано 2276 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн k281092

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-15
  • Сайт: 
  • Профессия: Ученик 1С
Очень нужен совет! Есть справочник "Бюджет за месяц" и подчиненный ему справочник "Статьи расхода". Необходима проверка, чтоб несколько раз не повторялась одна и та же статья! Создала процедуру проверки, но она не работает - Могу одну строку повторять бесконечно и программа не ругается! Прогоняю пошагово и понимаю, что при добавлении нового элементата в подчиненный справочник у него изначально не назначается Владелец. Когда пересохраняю элемент владелец выводится! Подскажите в чем ошибка, пожалуйста! Заранее спасибо!


Процедура Проверка()
Стат=СоздатьОбъект("Справочник.СтатьиРасхода");
Стат.ИспользоватьВладельца(ТекущийЭлемент().Владелец);

Стат.ВыбратьЭлементы();           
Пока Стат.ПолучитьЭлемент()<>0 Цикл
Если Стат.Наименование=Наим Тогда //Наим - поле ввода на форме
Предупреждение ("Данная статья уже прописана");
СтатусВозврата(0);
Прервать;
КонецЕсли;
КонецЦикла;
КонецПроцедуры


Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
думается в этом проблема:

Цитировать
Стат.ИспользоватьВладельца(ТекущийЭлемент().Владелец);

Получается что вы используете владельца владельца...

  Стат.ИспользоватьВладельца(ТекущийЭлемент());

Оффлайн k281092

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-15
  • Сайт: 
  • Профессия: Ученик 1С
Нет, проблема не в этом(

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Нет, проблема не в этом(

в любом случае параметр "ТекущийЭлемент().Владелец" был неправильный.

если я правильно понял - у вас в цикле добавляются подчиненные элементы и вы их же пытаетесь проверить?

ну это наверное логично... хотя это надо проверить.
Методы ИспользоватьВладельца()/ВыбратьЭлементы() - скорее всего открывают выборку на момент выполнения
этих методов, и добавленные новые элементы в эту выборку не попадают..



Добавлено: 21 Ноя 2014, 11:35

Стат.Наименование=Наим

и это проверку я бы проверял бы так:
нРег(сокрЛП(Стат.Наименование))= нРег(сокрЛП(Наим ))



Оффлайн k281092

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-15
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо большое, я попробую!

Оффлайн k281092

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-15
  • Сайт: 
  • Профессия: Ученик 1С
В справочник-Владельце процедура
Процедура Статьи()
Перем КонтСтат;
КонтСтат=ТекущийЭлемент();
ОткрытьФорму("Справочник.Статьи расхода",КонтСтат);
КонецПроцедуры //Статьи()


А в подчиненном справочнике процедура
Процедура ПриОткрытии()
Парам=Форма.Параметр;
Если ПустоеЗначение(Парам)=0 Тогда
ИспользоватьВладельца(Парам);
КонецЕсли;
КонецПроцедуры

Но параметр не передается( Кто подскажет почему???

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
k281092, подчиненный справочник открывается? попробуйте что нибудь другое
передать, число например, и в отладчике гляньте передается или нет.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 260
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal