Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Сен 2019, 22:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально  (Прочитано 12282 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ppkmlite

  • **
  • Сообщений: 86
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, подскажите, пожалйста!
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально.
Создаю новый документ "Заявка на кассовый расход", записываю и выходит сообщение  "Значение 9 поля "номер" не уникально. Именно 9!! То есть номер до этого редактировался, и даже если я скопирую другой документ, выходит опять та же ошибка. Делала перенумерацию, перенумеровывает, создаю новый докумнт, та же ошибка, именно с номером 9!!


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1102
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
отлаживайте подписку на событие ПриУстановкеНовогоНомера
или где у вас номер устанавливается...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ppkmlite

  • **
  • Сообщений: 86
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Дело в том., что база типовая без настроек, закрыта для редактирования,настроек нет, то есть стандартные настройки.
Дело в том, что провожу перенумерацию, создаю документ, провожу, не проводит, редактирую номер вручную, провожу, проводит. Создаю еще один документ, провожу, опять не проводит, номер 9 не уникален. А если редактирую номер, и ставлю буквенный символ вначале, проводит!!! Но мне нужен чсисловой номер!!!

Оффлайн stillenough

  • ***
  • Сообщений: 117
  • РЕПУТАЦИЯ: 7
  • КПД: 6%
  • Регистрация: 2014-11-13
  • Сайт: 
  • Профессия: Программист 1С
ситуация достаточно типовая. У вас слетела нумерация в документах. Получилось так, что пользователь ввел номер руками и автоматический отчет пошел от этого значения. Выход - программно обработать документы и восстановить нумерацию (если номера документов не нужно сохранять, например "Реализация товаров и услуг", для отчетности нельзя менять номера документов.) Если номер требуется сохранить - читайте ниже.

В свое время решал проблему следующими шагами:
1 - увеличить количество знаков в поле номер - решит проблемы, но через определенное время она опять всплывет.
2 - написать обработку, которая будет проверять и менять номера исключая незначащие 0
Ниже часть моей обработки по исправлению реализаций (прошу прощения, не нашел спойлер)
если (сред(строка.номер,0,2) = "ОТ") тогда
если кодСимвола(сред(строка.номер,ЭлементыФормы.ПолеВвода3.Значение,1)) = 32 тогда
если энд = ЛОЖЬ тогда
бу = сред(строка.номер,4,10);
от = "ОТ000000" + бу;

Попытка
серый = строка.ссылка.получитьобъект();
серый.номер = от;
серый.записать();
сообщить(строка.номер + " успешно в " + от);
энд = ИСТИНА;
исключение
сообщить(строка.номер + " не удалось преобразовать в " + от);
КонецПопытки;
КонецЕсли;

если энд = ЛОЖЬ тогда
бу = сред(строка.номер,4,10);
от = "ОТ00000" + бу;

Попытка
серый = строка.ссылка.получитьобъект();
серый.номер = от;
серый.записать();
сообщить(строка.номер + " успешно в " + от);
энд = ИСТИНА
исключение
сообщить(строка.номер + " не удалось преобразовать в " + от);
КонецПопытки;
КонецЕсли;

если энд = ЛОЖЬ тогда
бу = сред(строка.номер,4,10);
от = "ОТ0000" + бу;

Попытка
серый = строка.ссылка.получитьобъект();
серый.номер = от;
серый.записать();
сообщить(строка.номер + " успешно в " + от);
энд = ИСТИНА
исключение
сообщить(строка.номер + " не удалось преобразовать в " + от);
КонецПопытки;
КонецЕсли;

если энд = ЛОЖЬ тогда
бу = сред(строка.номер,4,10);
от = "ОТ000" + бу;

Попытка
серый = строка.ссылка.получитьобъект();
серый.номер = от;
серый.записать();
сообщить(строка.номер + " успешно в " + от);
энд = ИСТИНА
исключение
сообщить(строка.номер + " не удалось преобразовать в " + от);
КонецПопытки;
КонецЕсли;

если энд = ЛОЖЬ тогда
бу = сред(строка.номер,4,10);
от = "ОТ00" + бу;

Попытка
серый = строка.ссылка.получитьобъект();
серый.номер = от;
серый.записать();
сообщить(строка.номер + " успешно в " + от);
энд = ИСТИНА
исключение
сообщить(строка.номер + " не удалось преобразовать в " + от);
КонецПопытки;
КонецЕсли;
КонецЕсли;
КонецЕсли;

Оффлайн ppkmlite

  • **
  • Сообщений: 86
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо за ответы. Буду пробывать создать свою обработку по перенумерации.
Сначала хочу вывести список документов "Заявок на кр".
Создаю форму обработки,на ней кнопку. Создаю табл часть.
Пишу
Процедура НайтиДокументыНажатие(Элемент)
   новаяпеременная = Доки.Добавить();
   новаяпеременная.Заявки = Документы.ЗаявкаНаКассовыйРасход.ПолучитьФормуСписка();
КонецПроцедуры
Запускаю. Не выводит!! Что опять не так?

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 328
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
 новаяпеременная.Заявки = Документы.ЗаявкаНаКассовыйРасход.ПолучитьФормуСписка();
А это что вы делаете?
Добавлено: 19 Ноя 2014, 21:43

Кстати даже интеернсо , а что там будет то.. новые веянья
делайте чтото типа:
Дк = Документы.ЗаявканаРасх.Выбрать();
Пока Дк.Следующий() Цикл
ст = Доки.Добавить();
ст.Заявка = Дк.Ссылка;
КонецЦикла;

Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн ppkmlite

  • **
  • Сообщений: 86
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-06
  • Сайт: 
  • Профессия: Ученик 1С
А вот так не пойдет?
ВЫБРАТЬ
   ЗаявкаНаКассовыйРасход.Ссылка КАК Документ,
   ЗаявкаНаКассовыйРасход.Номер,
   ЗаявкаНаКассовыйРасход.Дата
ИЗ
   Документ.ЗаявкаНаКассовыйРасход КАК ЗаявкаНаКассовыйРасход
ГДЕ
   ЗаявкаНаКассовыйРасход.Номер = &Номер

УПОРЯДОЧИТЬ ПО
   Документ
Как мне здесь добавить условие на вывод докумннта с номером 9?

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 328
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
ЗаявкаНаКассовыйРасход.Номер = &Номер
Ну вот оно, условие

Потом, надо - Запрос.Установитьпараметр("Номер","9");

Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн ls600

  • ****
  • Сообщений: 335
  • РЕПУТАЦИЯ: 25
  • КПД: 7%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
есть обработка УниверсальныеПодборИОбработкаОбъектов. ей перенумеруйте весь список документов. после если база типовая то в ней есть обработка Определение стратегии редактирования номеров(кодов) объектов. у меня она находится в меню Сервис - Служебные. эта обработка восстановит нумерацию, недавно себе исправлял такую же ситуацию. 

Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
ЗаявкаНаКассовыйРасход.Номер ПОДОБНО &Номер
..
Запрос.Установитьпараметр("Номер","%9%");


Теги:
 

Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 19714
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2546
Последний ответ 10 Май 2017, 20:44
от ilnur75
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2632
Последний ответ 25 Май 2016, 19:38
от marshalbratsk
Создание диалога(Да/Нет) и создание документа с проведением

Автор kolkinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8703
Последний ответ 17 Дек 2014, 07:59
от has
Закрытие месеца, ошибка при закрытие 26сч

Автор GendelfРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 5055
Последний ответ 26 Июл 2013, 11:00
от Gendelf

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
89 Сообщений
LexaK
54 Сообщений
Yamuna
37 Сообщений
alexandr_ll
24 Сообщений
Funt432286
23 Сообщений
antoneus antoneus
22 Сообщений
DmitriyF DmitriyF
21 Сообщений
alex0402 alex0402
18 Сообщений
Eugeneer Eugeneer
17 Сообщений
Chgdz
16 Сообщений

* Кто онлайн

  • Точка Гостей: 221
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal