Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 20:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как описать условие  (Прочитано 2091 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lkatl

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-14
  • Сайт: 
Всем доброе времч суток.У меня такой,новичковый вопрос:
у меня есть функция:

Функция ПКоличество()
Если (СОКРЛП(Действие.Наименование)="Печать")И(Тираж<500)
Тогда Количество = 500;
Иначе Количество = Тираж;
КонецЕсли;
возврат  Количество;
КонецФункции

и чтобы посчитать количество. нужны ещё эти условия:
Если (СОКРЛП(Действие.Родитель.Наименование)="Материалы типографии")И (СОКРЛП(Форм.Наименование)="А7") И (СОКРЛП(БумагаПл.Наименование)="офсетная")Тогда] Количество =Тираж:64:100*4;   
   
Если (СОКРЛП(Действие.Родитель.Наименование)="Материалы типографии")И(СОКРЛП(Форм.Наименование)="А7") И (СОКРЛП(БумагаПл.Наименование)="газетная")Тогда Количество =Тираж:64:100*2.5 ;    
      
Если (СОКРЛП(Действие.Родитель.Наименование)="Материалы типографии")И(СОКРЛП(Форм.Наименование)="А6") И (СОКРЛП(БумагаПл.Наименование)="офсетная")   Тогда Количество =Тираж:32:100*4 ;   
   
Если (СОКРЛП(Действие.Родитель.Наименование)="Материалы типографии")И(СОКРЛП(Форм.Наименование)="А6") И (СОКРЛП(БумагаПл.Наименование)="газетная")Тогда Количество =Тираж:32:100*2.5 ;

Если (СОКРЛП(Действие.Родитель.Наименование)="Материалы типографии")И(СОКРЛП(Форм.Наименование)="А5") И (СОКРЛП(БумагаПл.Наименование)="офсетная")   Тогда Количество =Тираж:16:100*4 ;   
   
Если (СОКРЛП(Действие.Родитель.Наименование)="Материалы типографии")И(СОКРЛП(Форм.Наименование)="А5") И (СОКРЛП(БумагаПл.Наименование)="газетная")   Тогда Количество =Тираж:16:100*2.5 ;   
   
Если (СОКРЛП(Действие.Родитель.Наименование)="Материалы типографии")И (СОКРЛП(Форм.Наименование)="А4") И (СОКРЛП(БумагаПл.Наименование)="офсетная")Тогда Количество =Тираж:8:100*4 ;   
   
Если (СОКРЛП(Действие.Родитель.Наименование)="Материалы типографии")И (СОКРЛП(Форм.Наименование)="А4")И (СОКРЛП(БумагаПл.Наименование)="газетная")Тогда Количество =Тираж:8:100*2.5 ;   
   
Если (СОКРЛП(Действие.Родитель.Наименование)="Материалы типографии")И (СОКРЛП(Форм.Наименование)="А3") И (СОКРЛП(БумагаПл.Наименование)="офсетная")Тогда Количество =Тираж:4:100*4 ;   
   
Если (СОКРЛП(Действие.Родитель.Наименование)="Материалы типографии")И (СОКРЛП(Форм.Наименование)="А3")И (СОКРЛП(БумагаПл.Наименование)="газетная")Тогда Количество =Тираж:4:100*2.5 ;   
   
(СОКРЛП(Действие.Родитель.Наименование)="Материалы типографии")И(СОКРЛП(Форм.Наименование)="А2") И (СОКРЛП(БумагаПл.Наименование)="офсетная")Тогда Количество =Тираж:2:100*4 ;   
   
Если (СОКРЛП(Действие.Родитель.Наименование)="Материалы типографии")И (СОКРЛП(Форм.Наименование)="А2")  И (СОКРЛП(БумагаПл.Наименование)="газетная")Тогда Количество = Тираж:2:100*2.5 ;

// форматы и бумагуПл я ввела в соответствующие справочники. Тираж вводится пользователем,это любое число.


Оффлайн Tatitutu

в чем вопрос то ?
ну во первых можно сделать так же отдельной функцией с тремя входящими
во вторых во всех условиях у тебя первый параметр одинаков ="Материалы типографии"

Выноси его
В третьех Действие.Родитель.Наименование
замени на
ВыбранныйРодитель=Действие.Родитель;
И проверяй

Если СокрЛП(ВыбранныйРодитель.Наименование)="Материалы типографии" Тогда
Если (СОКРЛП(Форм.Наименование)="А7") И (СОКРЛП(БумагаПл.Наименование)="офсетная")Тогда
 Количество =Тираж:64:100*4;   
ИначеЕсли .....
КонецЕсли;
КонецЕсли;

*  MAGAZKA - лучшая программа для розничного магазина (с) *

Оффлайн lkatl

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-14
  • Сайт: 
ага,уже сделала.всё поняла.только вопросик один: как выносить одинаковый параметр

Оффлайн Tatitutu

??? я же написал

*  MAGAZKA - лучшая программа для розничного магазина (с) *

Оффлайн lkatl

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-14
  • Сайт: 
всё,вижу


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 343
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal