Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 06:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отбор в колонке ТЧ  (Прочитано 1357 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tulker

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-15
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Учусь программировать в 1с. Такой вопрос.
У справочника "Номенклатура" есть подчинённый справочник "Единица Измерения". Есть документ "Поступление ТиУ" в табличной части которого нужно при выборе номенклатуры, чтобы в поле "Ед. Измерения" вываливались только те единицы измерения, которые соответствуют выбранной номенклатуре.
В модуле формы документа написал следующее:

Цитировать
&НаКлиенте
Процедура ТоварыЕдиницаИзмеренияНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   
   СтандартнаяОбработка = Ложь;   
   ДанныеВыбора = ДанныеССервера(Элементы.Товары.ТекущиеДанные.Товар);   
           
КонецПроцедуры




&НаСервере

Функция ДанныеССервера (Переменная)

   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ЕдиницаИзмерения.КоличествоШтук,
      |   ЕдиницаИзмерения.Наименование,
      |   ЕдиницаИзмерения.Владелец.Наименование
      |ИЗ
      |   Справочник.ЕдиницаИзмерения КАК ЕдиницаИзмерения
      |ГДЕ
      |   ЕдиницаИзмерения.Владелец.Ссылка = &СсылкаНаТовар";

   Запрос.УстановитьПараметр("СсылкаНаТовар", Переменная);

   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();

   
    Список = Новый СписокЗначений();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      
      
      Список.Добавить(ВыборкаДетальныеЗаписи.Наименование, ,Истина);
      
      
   КонецЦикла;

      
   
    Возврат Список;
   
   
 КонецФункции


Код отрабатывает, в колонке "Единица измерения" можно выбрать только те единицы , которые относятся к данной номенклатуре, но если выбрать другое поле, то значение исчезает. Не могу понять в чём причина, пожалуйста помогите.


Оффлайн sertak

  • ****
  • Сообщений: 323
  • РЕПУТАЦИЯ: 92
  • КПД: 28%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: infostart.ru
Для реквизита ЕдиницаИзмерения  настройте свойство Связи параметров выбора, чтобы владелец был равен номенклатуре, тогда будет открываться  только  список подчиненных  единиц измерения.

Оффлайн tulker

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-15
  • Сайт: 
  • Профессия: Ученик 1С
Для реквизита ЕдиницаИзмерения  настройте свойство Связи параметров выбора, чтобы владелец был равен номенклатуре, тогда будет открываться  только  список подчиненных  единиц измерения.
спасибо большое! помогло!


Теги:
 

Программный отбор в "Документы"

Автор SeolkinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4558
Последний ответ 06 Окт 2012, 18:08
от Seolkin
Отбор при "быстром выборе"

Автор Gregory78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3722
Последний ответ 15 Фев 2015, 12:13
от Gregory78
Дин.список отбор данных - не работает код при тех же данных

Автор Аля ТинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 368
Последний ответ 15 Дек 2017, 14:36
от alex0402
Отбор по номенклатуре в отчете "ВЕдомость выдачи мц"

Автор notaSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2924
Последний ответ 08 Авг 2015, 15:40
от ppkmlite
Отбор по дате проведения документа в обработке "Универсальные подбор и обработка объектов"

Автор rooflessРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2849
Последний ответ 25 Июн 2014, 15:30
от roofless

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 172
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal