Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 04:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отбор в колонке ТЧ  (Прочитано 1073 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tulker

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-15
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Учусь программировать в 1с. Такой вопрос.
У справочника "Номенклатура" есть подчинённый справочник "Единица Измерения". Есть документ "Поступление ТиУ" в табличной части которого нужно при выборе номенклатуры, чтобы в поле "Ед. Измерения" вываливались только те единицы измерения, которые соответствуют выбранной номенклатуре.
В модуле формы документа написал следующее:

Цитировать
&НаКлиенте
Процедура ТоварыЕдиницаИзмеренияНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   
   СтандартнаяОбработка = Ложь;   
   ДанныеВыбора = ДанныеССервера(Элементы.Товары.ТекущиеДанные.Товар);   
           
КонецПроцедуры




&НаСервере

Функция ДанныеССервера (Переменная)

   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ЕдиницаИзмерения.КоличествоШтук,
      |   ЕдиницаИзмерения.Наименование,
      |   ЕдиницаИзмерения.Владелец.Наименование
      |ИЗ
      |   Справочник.ЕдиницаИзмерения КАК ЕдиницаИзмерения
      |ГДЕ
      |   ЕдиницаИзмерения.Владелец.Ссылка = &СсылкаНаТовар";

   Запрос.УстановитьПараметр("СсылкаНаТовар", Переменная);

   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();

   
    Список = Новый СписокЗначений();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      
      
      Список.Добавить(ВыборкаДетальныеЗаписи.Наименование, ,Истина);
      
      
   КонецЦикла;

      
   
    Возврат Список;
   
   
 КонецФункции


Код отрабатывает, в колонке "Единица измерения" можно выбрать только те единицы , которые относятся к данной номенклатуре, но если выбрать другое поле, то значение исчезает. Не могу понять в чём причина, пожалуйста помогите.


Оффлайн sertak

  • ****
  • Сообщений: 274
  • РЕПУТАЦИЯ: 74
  • КПД: 27%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: www.sertakov.ru
  • Профессия: Программист 1С
Для реквизита ЕдиницаИзмерения  настройте свойство Связи параметров выбора, чтобы владелец был равен номенклатуре, тогда будет открываться  только  список подчиненных  единиц измерения.
Если ты знаешь свой путь, то удачи и неудачи равно продвигают тебя вперед

Оффлайн tulker

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-15
  • Сайт: 
  • Профессия: Ученик 1С
Для реквизита ЕдиницаИзмерения  настройте свойство Связи параметров выбора, чтобы владелец был равен номенклатуре, тогда будет открываться  только  список подчиненных  единиц измерения.
спасибо большое! помогло!


Теги:
 

Программный отбор в "Документы"

Автор SeolkinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4248
Последний ответ 06 Окт 2012, 18:08
от Seolkin
Отбор при "быстром выборе"

Автор Gregory78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3103
Последний ответ 15 Фев 2015, 12:13
от Gregory78
Дин.список отбор данных - не работает код при тех же данных

Автор Аля ТинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 119
Последний ответ 15 Дек 2017, 14:36
от alex0402
Отбор по номенклатуре в отчете "ВЕдомость выдачи мц"

Автор notaSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2340
Последний ответ 08 Авг 2015, 15:40
от ppkmlite
Отбор по дате проведения документа в обработке "Универсальные подбор и обработка объектов"

Автор rooflessРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2574
Последний ответ 25 Июн 2014, 15:30
от roofless

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 126
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal