Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 20:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод результата запроса на форму в виде надписи  (Прочитано 3942 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ppkmlite

  • **
  • Сообщений: 78
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Помогите, пожалуйста, разобраться. На форме поле выбора кассы, при выборе кассы нужно, чтобы на форме выводился конечный остаток по ней в виде надписи.Сделала процедуру и функцию.Не выводит результат.?! подскажите, что я делаю не так
Сначала у меня процедура, она для поля ввода кассы

Процедура Касса1НачалоВыбора(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка=Ложь;
   
    Форма=Справочники.Кассы.ПолучитьФормуВыбора(,Элемент,);
    Форма.Отбор.Владелец.Установить(ОрганизацияОт, Истина);
    Форма.ЗакрыватьПриВыборе = Истина;
   
    Если ЗначениеЗаполнено(Элемент.Значение) Тогда
       
        Форма.ПараметрТекущаяСтрока=Элемент.Значение;
       
    КонецЕсли;
   
    Форма.РежимВыбора=Истина;
   
    Форма.Открыть();
        //Будем выводить остаток по кассе

    Надпись1 = ОстатокПоКассе(Надпись1);
   
КонецПроцедуры


После функция, она для возврата отрицательного остатка по кассе, ну хотя вообще остатка, все равно не выводит.

Функция  ОстатокПоКассе(Надпись1)  Экспорт
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    ДенежныеСредстваОстатки.СуммаОстаток
    |ИЗ
    |    РегистрНакопления.ДенежныеСредства.Остатки(&Период, ) КАК ДенежныеСредстваОстатки";
   
    Запрос.УстановитьПараметр("Период", Период);
   
    РезультатЗапроса = Запрос.Выполнить();
   
    Надпись1 = 0; ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
Если ВыборкаДетальныеЗаписи.Следующий() Тогда
    Надпись1 = ВыборкаДетальныеЗаписи.СуммаОстаток;
КонецЕсли;
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

Возврат Надпись1
КонецФункции



Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
ЭлементыФормы.Надпись1.Заголовок =  ОстатокПоКассе();
и в остатке по кассе сумму возвращайте просто
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
наверно остаток по кассе надо получать, поэтому в функцию надо передать Кассу, возвращать функция будет Число - Сумму остатка или 0

Процедура Касса1НачалоВыбора(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка=Ложь;
    //другая часть вашего кода ...

    //я бы это перенес в событие при изменении поля Касса
    Надпись1.Заголовок = "Остаток по Кассе: " + ОстатокПоКассе(Элемент.Значение);
   
КонецПроцедуры


Функция  ОстатокПоКассе(Касса)  Экспорт
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    Рег.СуммаОстаток
    |ИЗ
    |    РегистрНакопления.ДенежныеСредства.Остатки(,БанковскийСчетКасса = &Касса ) КАК Рег
    |";
   
    Запрос.УстановитьПараметр("Касса", Касса );
   
    РезультатЗапроса = Запрос.Выполнить().Выбрать();
    Если РезультатЗапроса.Следующий() Тогда
        Возврат РезультатЗапроса.СуммаОстаток;
    Иначе
        Возврат "0"; //вообще правильнее число 0 возвращать, но только для вас, можно и так
    КонецЕсли;

КонецФункции
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн ppkmlite

  • **
  • Сообщений: 78
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Разобралась, добавила процедуру Обработка Выбора.
Добавлено: 09 Ноя 2014, 09:56

Спасибо всем, кто откликнулся


Теги:
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 12227
Последний ответ 14 Июн 2012, 17:44
от Alex1111
Вывод комментария в документ "Расходная накладная" из документа "Заказ покупателя"

Автор ОльгаПлРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 206
Последний ответ 07 Окт 2017, 19:03
от Norfolk
Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1356
Последний ответ 18 Янв 2017, 12:32
от sertak
"ПОДОБНО" в условие связи запроса

Автор Станиславъ ЗверевъРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 3260
Последний ответ 11 Май 2016, 15:29
от LexaK
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 730
Последний ответ 15 Июн 2017, 07:53
от mvk843

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 313
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal