Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 03:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка:Значение не является значением объектного типа  (Прочитано 2440 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MGF

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-07
  • Сайт: 
  • Профессия: Программист 1С
Всем привет. Решил поработать с конфигурацией Управление ИТ-отделом, в ней обнаружил довольно полезную обработку "ЗагрузкаДанныхИзEverest", сделал отчет из Эвереста в формате .ini, загрузил его, нажимаю "обновить данные" и тут вылетает ошибка:

{ОбщийМодуль.РаботаСИниФайлами.Модуль(11)}: Значение не является значением объектного типа (Количество)
   Для НомерРаздела = 1 По ИниФайл.Количество()  Цикл

Текст процедуры:

// Получает текст секции ИниФайла
Функция ПолучитьСекциюИниФайла(ИниФайл, ИмяСекции) Экспорт
   Для НомерРаздела = 1 По ИниФайл.Количество()  Цикл
      Если ИниФайл.Получить(НомерРаздела).Представление = ИмяСекции Тогда
         Возврат ИниФайл.Получить(НомерРаздела).Значение;
      КонецЕсли;
   КонецЦикла;
   
   Возврат Ложь;   
КонецФункции

Подскажите, что не так?


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Функция ПолучитьСекциюИниФайла(ИниФайл, ИмяСекции) Экспорт

Надо смотреть место откуда жто вызывается, и чему равно - ИниФайл
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Luzer1C

  • ****
  • Сообщений: 455
  • РЕПУТАЦИЯ: 56
  • КПД: 12%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Может надо прописать так: ИниФайл.КоличествоСтрок() ?
Халамбалам.

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
НУ короче в отладчике надо глянуть, что есть ИниФайл, и там уже соответственно принимать решение.
Помог? Нажми - Спасибо :)
skype: Soprov1C


 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5087
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6808
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4864
Последний ответ 28 Апр 2014, 15:53
от maskito
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 9313
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Синтаксическая ошибка "ИЗ"

Автор kulkriseРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5136
Последний ответ 26 Янв 2014, 19:33
от kulkrise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 78
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal