Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 22:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Серийные номера номенклатуры в печатную форму накладной  (Прочитано 2051 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Киселева Анастасия

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-15
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Помогите, пожалуйста, нубу =)

УТ 10.3 старого релиза, платформа 8.3
Делаю вывод серийных номеров номенклатуры в печатной форме УПД (УПД на половину самописный, т.к. конфа не обновляется). Нужно чтобы список всех серийных номеров для этой номенклатуры по этому документу выводился в строчку с наименованием товара.

Собираю запросом все серийники с номенклатурой из реализации.
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Док", ДокОснование);

Запрос.Текст =
"ВЫБРАТЬ
| РеализацияТоваровУслугСерийныеНомера.КлючСвязи,
| РеализацияТоваровУслугСерийныеНомера.СерийныйНомер КАК СерийныйНомер,
| РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура
|ИЗ
| Документ.РеализацияТоваровУслуг.СерийныеНомера КАК РеализацияТоваровУслугСерийныеНомера
| ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
| ПО РеализацияТоваровУслугСерийныеНомера.КлючСвязи = РеализацияТоваровУслугТовары.КлючСвязи
|ГДЕ
| РеализацияТоваровУслугСерийныеНомера.Ссылка = &Док";

ВыборкаСерийныеНомера = Запрос.Выполнить().Выбрать();

Но похоже у меня косяк в цикле, т.к. выводит серийные номера только для первой строчки.

Пока ВыборкаСтрокТовары.Следующий() = 1 Цикл
Строчка = Товары.Добавить();

Строчка.Товар               = ВыборкаСтрокТовары.Товар;
Номер = "";
Пока ВыборкаСерийныеНомера.Следующий() Цикл
Если Строчка.Товар = ВыборкаСерийныеНомера.Номенклатура тогда

Номер = Номер + " " + ВыборкаСерийныеНомера.СерийныйНомер;
КонецЕсли;
КонецЦикла;


Строчка.ТоварНаименование   = СокрЛП(ВыборкаСтрокТовары.ТоварНаименование) + ФормированиеПечатныхФорм.ПредставлениеСерий(ВыборкаСтрокТовары) + " " + Номер;
....заполнение других строк....
КонецЦикла;
    ДанныеДляПечати.Вставить("ТабличнаяЧасть", Товары);

Возврат ДанныеДляПечати;

Направьте, пожалуйста на путь истины!


Оффлайн Киселева Анастасия

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-15
  • Сайт: 
  • Профессия: Ученик 1С
Проблему решила запихнув запрос в сам цикл и добавив в него условие по номенклатуре.

Но я по прежнему не понимаю, почему в первом случае записывалась только первая строка.


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 292
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal