Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 06:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрос с условием, внешняя печатная форма  (Прочитано 1966 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн d_liliya

  • **
  • Сообщений: 73
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-02
  • Сайт: 
  • Профессия: Ученик 1С
Разрабатываю внешнюю печатную форму, к документу Реализация. Нужно из регистра сведений КонтактнаяИнформация "достать" адрес конкретного контрагента,который лежит в Представление и вывести в ячейку. Для этого нужно сделать запрос и как-то условием задать выбор по контрагенту. (Код неправильный)
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| КонтактнаяИнформация.Представление,
| Реализация.Контрагент
|ИЗ
| РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
| ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.Реализация КАК Реализация
| ПО (Реализация.Контрагент = КонтактнаяИнформация.Объект.Ссылка)";

ЗапросАдрес = Запрос.Выполнить().Выгрузить();
ОбластьМакета.Параметры.Адрес = ЗапросАдрес;

Подскажите, как это сделать?


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
если конфа типовая, например УТ11 , то в ней есть общий модуль ФормированиеПечатныхФорм, там есть много чего интересного, в т.ч. функция ПолучитьАдресИзКонтактнойИнформации(Объект, ТипАдреса = ""), на вход передается Объект - ссылка, ТипАдрес - Фактический, Регистрации или Юридический,
в ващем случае это будет выглядеть так:
Адрес = ФормированиеПечатныхФорм.ПолучитьАдресИзКонтактнойИнформации(Ссылка, "Юридический"); //Ссылка - СправочникСсылка.Контрагенты

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Загляните в код печати счет-фактуры.
Там есть готовая функция получения данных по контрагенту, включая и адрес...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн d_liliya

  • **
  • Сообщений: 73
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-02
  • Сайт: 
  • Профессия: Ученик 1С
если конфа типовая, например УТ11 , то в ней есть общий модуль ФормированиеПечатныхФорм, там есть много чего интересного, в т.ч. функция ПолучитьАдресИзКонтактнойИнформации(Объект, ТипАдреса = ""), на вход передается Объект - ссылка, ТипАдрес - Фактический, Регистрации или Юридический,
в ващем случае это будет выглядеть так:
Адрес = ФормированиеПечатныхФорм.ПолучитьАдресИзКонтактнойИнформации(Ссылка, "Юридический"); //Ссылка - СправочникСсылка.Контрагенты

В общем модуле формированиеПечатныхФорм есть только функция ОписаниеОрганизации с таким кодом:
Функция ОписаниеОрганизации(СписокСведений, Список = "", СПрефиксом = Истина) Экспорт

Если ПустаяСтрока(Список) Тогда
Список = "ПолноеНаименование,ИНН,Свидетельство,ЮридическийАдрес,Телефоны,НомерСчета,Банк,БИК,КоррСчет";
КонецЕсли;

Результат = "";

СоответствиеПараметров = Новый Соответствие();
СоответствиеПараметров.Вставить("ПолноеНаименование", " ");
СоответствиеПараметров.Вставить("ИНН", " ИНН ");
СоответствиеПараметров.Вставить("КПП", " КПП ");
СоответствиеПараметров.Вставить("Свидетельство", " ");
СоответствиеПараметров.Вставить("СвидетельствоДатаВыдачи", " от ");
СоответствиеПараметров.Вставить("ЮридическийАдрес", " ");
СоответствиеПараметров.Вставить("ФактическийАдрес", " ");
СоответствиеПараметров.Вставить("Телефоны", " тел.: ");
СоответствиеПараметров.Вставить("НомерСчета", " р/с ");
СоответствиеПараметров.Вставить("Банк", " в банке ");
СоответствиеПараметров.Вставить("БИК", " БИК ");
СоответствиеПараметров.Вставить("КоррСчет", " к/с ");
СоответствиеПараметров.Вставить("КодПоОКПО", " Код по ОКПО ");

Список = Список + ?(Прав(Список, 1) = ",", "", ",");
ЧислоПараметров = СтрЧислоВхождений(Список, ",");

Для Счетчик = 1 По ЧислоПараметров Цикл

ПозЗапятой = Найти(Список, ",");

Если ПозЗапятой > 0 Тогда
ИмяПараметра = Лев(Список, ПозЗапятой - 1);
Список = Сред(Список, ПозЗапятой + 1, СтрДлина(Список));

Попытка
СтрокаДополнения = "";
СписокСведений.Свойство(ИмяПараметра, СтрокаДополнения);

Если ПустаяСтрока(СтрокаДополнения) Тогда
Продолжить;
КонецЕсли;

Префикс = СоответствиеПараметров[ИмяПараметра];
Если НЕ ПустаяСтрока(Результат) Тогда
Результат = Результат + ",";
КонецЕсли;

Результат = Результат + ?(СПрефиксом = Истина, Префикс, "") + СтрокаДополнения;
Исключение
Сообщить("Не удалось определить значение параметра организации: " + ИмяПараметра, СтатусСообщения.Внимание);
КонецПопытки;

КонецЕсли;
КонецЦикла;
Возврат СокрЛП(Результат);

КонецФункции // ОписаниеОрганизации()

Как отсюда достать Юридический адрес?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Глобальным поиском ищите где она вызывается и увидите пример
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9361
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Запрос Параметры для "ИЗ"

Автор БерезинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2999
Последний ответ 15 Май 2013, 23:27
от Березин
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 985
Последний ответ 11 Июл 2016, 09:00
от vitasw
Запрос по обработке "Согласование заявок"

Автор DenielAkreedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 689
Последний ответ 29 Сен 2016, 02:39
от DenielAkreed
Форма "Взнос наличными в банк" где она :)

Автор lefantiy_94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4661
Последний ответ 30 Июн 2015, 03:50
от lefantiy_94

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 124
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal