Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 05:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печать макета внешней обработки в 1С 8.2  (Прочитано 3668 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн МаксБУХ

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2014-10-24
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Прошу помощи в наисложнейшем для меня вопросе. Я написал простейшую обработку для 1С 8.2, добавил в нее макет, но никак не могу этот макет заполнить по тем данным, которые у меня выбраны при реализации процедуры обработки. Уверен, что дело это простое и даже может показаться примитивным для опытных программистов, но я сам реально не могу никак понять механизм работы языка 1С. Поэтому помогите, пожалуйста, если кто сможет и/или захочет. Заранее благодарю. Обработку прилагаю.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Как то так...
Процедура КнопкаПечатьНажатие(Кнопка)
      ТабличныйДокумент=Новый ТабличныйДокумент;
      Макет = ПолучитьМакет("Макет");
      Для каждого СтрокаТЧ Из ТаблицаСумм Цикл
           ОбластьСумма=Макет.ПолучитьОбласть("Сумма");
          ОбластьСумма.Параметры.СуммаДокумента = СтрокаТЧ.Сумма;
           ТабличныйДокумент.Вывести(ОбластьСУмма);
      КонецЦикла;
      ТабличныйДокумент.Показать();
      КонецПроцедуры
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Если программирование не профильное ваше занятие, то не мучайте себя, а лучше вызывайте спецов и дайте им заработать.
В противном случае книжку (или онлайн-курс) в зубы и учиться...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн МаксБУХ

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2014-10-24
  • Сайт: 
  • Профессия: Ученик 1С
Как то так...
Процедура КнопкаПечатьНажатие(Кнопка)
      ТабличныйДокумент=Новый ТабличныйДокумент;
      Макет = ПолучитьМакет("Макет");
      Для каждого СтрокаТЧ Из ТаблицаСумм Цикл
           ОбластьСумма=Макет.ПолучитьОбласть("Сумма");
          ОбластьСумма.Параметры.СуммаДокумента = СтрокаТЧ.Сумма;
           ТабличныйДокумент.Вывести(ОбластьСУмма);
      КонецЦикла;
      ТабличныйДокумент.Показать();
      КонецПроцедуры

Огромное СПАСИБО!!!!!!! Да. Вы правы, надо звать профессионалов, но не для решения такой вот простецкой задачи. Это она для меня апория, а Вам вот сразу поддалась. Еще раз спасибо!!!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
39 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 282
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal