Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 10:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод итого по колонке ( выводится только последняя строчка )  (Прочитано 1823 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лерик

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-23
  • Сайт: 
  • Профессия: Ученик 1С
Все выходило отлично , пока не добралась до итогов.
И тут началась моя борьба с форумами , книгами , и т.д.
Голова уже пухнет но так ни чего и не выходит .

Процедура ГруппаЗдоровья()
   
   Тз = СоздатьОбъект("ТаблицаЗначений");
   Тз.НоваяКолонка("Сад");
   Тз.НоваяКолонка("ГрЗдоровья1");
   Тз.НоваяКолонка("ГрЗдоровья2");
   Тз.НоваяКолонка("ГрЗдоровья3");
   Тз.НоваяКолонка("ГрЗдоровья4");
   Тз.НоваяКолонка("ГрЗдоровья5");
   
   
   //Тз2=СоздатьОбъект("ТаблицаЗначений");   //таблица строк печатной формы
   //Тз2.НоваяКолонка("Сад","Число");///
   ////
   //Справ=СоздатьОбъект("Справочник.Сады");
   //Справ.ВыбратьЭлементы();
   //Пока Справ.ПолучитьЭлемент()=1 Цикл
   //   Если Справ.ЭтоГруппа()=1 тогда
   //      Продолжить;
   //   КонецЕсли;
   //   Если Справ.ПометкаУдаления()=1 тогда
   //      Продолжить;
   //   КонецЕсли;
   //   Тз.НоваяСтрока();
   //   Тз.Сад=Справ.Код;
   ////   Тз2.Сортировать("Сад");
   //КонецЦикла;         
         
   Док=СоздатьОбъект("Документ.ЗаболеваемостьХроническая"); 
   Док.Выбратьдокументы(НачГода(ДатаДок),КонГода(ДатаДок)); 
   н=0;
   Пока Док.ПолучитьДокумент()=1 Цикл
      Если Док.Проведен()=0 тогда
         Продолжить;
      КонецЕсли;
      Если Док.ПометкаУдаления()=1 тогда
         Продолжить;
      КонецЕсли;
      //н=н+1;
      //Сообщить ( н,н); 
      
      //Тз2.НоваяСтрока();
      //Тз2.Сад = Док.Сад.код;
      
      Тз.НоваяСтрока();
      Тз.ГрЗдоровья1 = Док.ГрЗд1;
      Тз.ГрЗдоровья2 = Док.ГрЗд2;
      Тз.ГрЗдоровья3 = Док.ГрЗд3;
      Тз.ГрЗдоровья4 = Док.ГрЗд4;
      Тз.ГрЗдоровья5 = Док.ГрЗд5;
      Тз.Сад = Док.Сад.Код;
      КонецЦикла;
   Тз.Свернуть("Сад","ГрЗдоровья1,ГрЗдоровья2,ГрЗдоровья3,ГрЗдоровья4,ГрЗдоровья5");
   Тз.Сортировать("Сад");
   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("ГрЗдоровья");                     
   Таб.Очистить();
   Таб.ВывестиСекцию("Шапка");
   Тз.ВыбратьСтроки();
   ном=0;
   ИтогоПроц1 = 0;
   Пока Тз.ПолучитьСтроку() = 1 Цикл
      ном=ном+1;
      ВсегоДетей = Тз.ГрЗдоровья1 +Тз.ГрЗдоровья2+Тз.ГрЗдоровья3+Тз.ГрЗдоровья4+Тз.ГрЗдоровья5;
      Проц1 = Окр(Тз.ГрЗдоровья1*100/ВсегоДетей,0,1);
      Проц2 = Окр(Тз.ГрЗдоровья2*100/ВсегоДетей,0,1);
      Проц3 = Окр(Тз.ГрЗдоровья3*100/ВсегоДетей,0,1);
      Проц4 = Окр(Тз.ГрЗдоровья4*100/ВсегоДетей,0,1);
      Проц5 = Окр(Тз.ГрЗдоровья5*100/ВсегоДетей,0,1);
      Таб.ВывестиСекцию("Строка");   
   КонецЦикла;
    ИтогоПроц1 = ИтогоПроц1+Проц1;
   Таб.ВывестиСекцию("Итого");
Таб.ПараметрыСтраницы(1,,,0,0,0,0,,,1,,);     
Таб.Защита(1);
Таб.Показать();   
КонецПроцедуры


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
не
КонецЦикла;
ИтогоПроц1 = ИтогоПроц1+Проц1;

а
ИтогоПроц1 = ИтогоПроц1+Проц1;
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
отругать бы вас за 7.7ый код в ветке 8ки ;))
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Лерик

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-23
  • Сайт: 
  • Профессия: Ученик 1С
Огромная благодарность, и простите , не разобралась сразу где и что , впредь буду внимательнее.

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
0 и 1 это как я понял ложь и истина?)
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Вывод комментария в документ "Расходная накладная" из документа "Заказ покупателя"

Автор ОльгаПлРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 209
Последний ответ 07 Окт 2017, 19:03
от Norfolk
как в отчете "Главная книга" отображать для счетов столбцы не только "С кредита", но и "На дебет"

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1130
Последний ответ 13 Мар 2016, 00:55
от дфтын
Вывод результата запроса через условие другого запроса

Автор jonik_jokerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2905
Последний ответ 16 Окт 2013, 15:08
от jonik_joker
Вывод линейной таблицы посредством СКД в виде "шахматки"

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 10736
Последний ответ 19 Апр 2011, 11:12
от Klyacksa
Вывод набора данных "объединение" скд в дерево значений

Автор Gae4kaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1554
Последний ответ 02 Июн 2015, 12:19
от Gae4ka

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 257
  • Точка Скрытых: 1
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal