Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 08:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Доступность ячейки в табличном поле документа.  (Прочитано 2329 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Доброго времени суток!
Сразу скажу конфигурация не типовая, обычное приложение.
Создал документ в нем есть табличная часть. В табличной части есть колонка ДатаЗавершения.
Написал процедуру которая проверяет доступность ячейки на заполнение 

Процедура ТабличнаяЧастьПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
   Если Не РольДоступна("ПолныеПрава") Тогда
      ОформлениеСтроки.Ячейки.ДатаЗавершения.ТолькоПросмотр = Ложь;
      Если  ЗначениеЗаполнено(ДанныеСтроки.ДатаЗавершения) Тогда
         ОформлениеСтроки.Ячейки.ДатаЗавершения.ТолькоПросмотр = Истина;
      Иначе
         ОформлениеСтроки.Ячейки.ДатаЗавершения.ТолькоПросмотр = Ложь;
      КонецЕсли;
   КонецЕсли;
КонецПроцедуры


Из кода видно что если ячейка пустая то ее заполнить можно иначе нет.
Возможно ли сделать так что доступность ячейки будет только после записи документа, а то пользователь не ту дату поставит и придется звонить другому пользователю у которого есть доступ на изменение ячейки.?!



Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Ну проверяйте на ЭтоНовый() и Модифицированность() еще наверно

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
по подробнее, если не затруднит?

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Ну как-то так наверно
Процедура ТабличнаяЧастьПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
   Если Не РольДоступна("ПолныеПрава") Тогда
      Если ЭтоНовый() ИЛИ ЭтотОбъект.Модифицированность() Тогда
          ОформлениеСтроки.Ячейки.ДатаЗавершения.ТолькоПросмотр = Ложь;
      Иначе
          Если  ЗначениеЗаполнено(ДанныеСтроки.ДатаЗавершения) Тогда
             ОформлениеСтроки.Ячейки.ДатаЗавершения.ТолькоПросмотр = Истина;
          Иначе
             ОформлениеСтроки.Ячейки.ДатаЗавершения.ТолькоПросмотр = Ложь;
          КонецЕсли;
      КонецЕсли;
   КонецЕсли;
КонецПроцедуры

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Ну как-то так наверно
Работает, благодарю!!!!!
:ooifh:




Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15910
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4197
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 620
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7739
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 523
  • Точка Скрытых: 1
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal