Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 05:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печатная форма документа  (Прочитано 729 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ly_Alena

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-23
  • Сайт: 
  • Профессия: Ученик 1С
Доброе утро! Столкнулась с непонятной ошибкой. Вывожу на печать документ:

ОбластьМакета = Макет.ПолучитьОбласть("ШапкаТаблицы");
   ОбластьМакета.Параметры.ПроцентНакладные = Шапка.ПроцентНакладные;
   ТабДокумент.Вывести(ОбластьМакета);
   
   
   Запрос = Новый Запрос;
   Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);
   Запрос.Текст ="ВЫБРАТЬ
                 |   ЗаказПокупателяТовары.ЗапрашиваемоеНаименование,
                 |   ЗаказПокупателяТовары.Номенклатура,
                 |   ЗаказПокупателяТовары.Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдИзм,
                 |   СУММА(ЗаказПокупателяТовары.Количество) КАК Количество,
                 |   СРЕДНЕЕ(ЗаказПокупателяТовары.ПлановаяСебестоимость) КАК ПлановаяСебестоимость,
                 |   СРЕДНЕЕ(ЗаказПокупателяТовары.ЦенаБезНДС) КАК ЦенаБезНДС,
                 |   СУММА(ЗаказПокупателяТовары.СуммаБезНДС) КАК СуммаБезНДС,
                 |   СРЕДНЕЕ(ЗаказПокупателяТовары.Цена) КАК Цена,
                 |   СУММА(ЗаказПокупателяТовары.Сумма) КАК Сумма,
                 |   СУММА(ЗаказПокупателяТовары.Транспортные) КАК Транспортные,
                 |   СУММА(ЗаказПокупателяТовары.Накладные) КАК Накладные,
                 |   СУММА(ЗаказПокупателяТовары.УслПостоянные) КАК УслПостоянные,
                 |   СУММА(ЗаказПокупателяТовары.Прибыль) КАК Прибыль,
                 |   СРЕДНЕЕ(ЗаказПокупателяТовары.Рентабельность) КАК Рентабельность,
                 |   ЗаказПокупателяТовары.НовоеНаименование,
                 |   СУММА(ЗаказПокупателяТовары.СуммаПлановойСебестоимости) КАК СуммаСебестоимости,
                 |   ЗаказПокупателяТовары.НомерЛота КАК НомерЛота,
                 |   ЗаказПокупателяТовары.КоличествоВПроизводство
                 |ИЗ
                 |   Документ.ЗаказПокупателя.Товары КАК ЗаказПокупателяТовары
                 |ГДЕ
                 |   ЗаказПокупателяТовары.Ссылка = &ТекущийДокумент
                 |
                 |СГРУППИРОВАТЬ ПО
                 |   ЗаказПокупателяТовары.ЗапрашиваемоеНаименование,
                 |   ЗаказПокупателяТовары.Номенклатура,
                 |   ЗаказПокупателяТовары.НовоеНаименование,
                 |   ЗаказПокупателяТовары.Номенклатура.БазоваяЕдиницаИзмерения,
                 |   ЗаказПокупателяТовары.НомерЛота,
                 |   ЗаказПокупателяТовары.КоличествоВПроизводство
                 |
                 |УПОРЯДОЧИТЬ ПО
                 |   НомерЛота";

   РезультатЗапросаТовары = Запрос.Выполнить();
   Если НЕ РезультатЗапросаТовары.Пустой() Тогда
   
      Индекс = 0;
      Область = Макет.ПолучитьОбласть("Товары");
      Обход = РезультатЗапросаТовары.Выбрать();
      ОбходТовары = РезультатЗапросаТовары.Выбрать();
      Пока Обход.Следующий() Цикл
      
         Если Обход.Количество = 0 Тогда
            Продолжить;
         КонецЕсли;
            
         Если Не ЗначениеЗаполнено(Обход.Номенклатура) Тогда
            Сообщить("В одной из строк не заполнено значение номенклатуры - строка при печати пропущена.", СтатусСообщения.Важное);
            Продолжить;
         КонецЕсли;
         
         Индекс = Индекс + 1;
         Область.Параметры.НомерСтроки = Индекс;
         //Область.Параметры.НомерЛота = Обход.НомерЛота;
         Область.Параметры.ЗапрашиваемоеНаименование = Обход.ЗапрашиваемоеНаименование;
         Если ЗначениеЗаполнено(Обход.НовоеНаименование) Тогда
         Область.Параметры.НовоеНаименование = Обход.НовоеНаименование;
         Иначе Область.Параметры.НовоеНаименование = Обход.Номенклатура;
         КонецЕсли;
         Область.Параметры.Номенклатура = Обход.Номенклатура;
         Область.Параметры.ЕдИзм = Обход.ЕдИзм;
         Область.Параметры.Количество = Обход.КоличествоВПроизводство;
         Область.Параметры.Себестоимость = Обход.ПлановаяСебестоимость;
         Область.Параметры.СуммаСебестоимости = Обход.СуммаСебестоимости;
         Область.Параметры.ЦенаБезНДС = Обход.ЦенаБезНДС;
         Область.Параметры.СуммаБезНДС = Обход.СуммаБезНДС;
         Область.Параметры.Цена = Обход.Цена;
         Область.Параметры.Сумма = Обход.Сумма;
         Область.Параметры.Транспортные = Обход.Транспортные;
         Область.Параметры.Накладные = Обход.Накладные;
         Область.Параметры.УслПостоянные = Обход.УслПостоянные;
         Область.Параметры.Прибыль = Обход.Прибыль;
         Область.Параметры.Рентабельность = Обход.Рентабельность;
         
         ТабДокумент.Вывести(Область);
         
      КонецЦикла;
   КонецЕсли;   

Выдает что не знает поле НомерЛота


Оффлайн Ly_Alena

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-23
  • Сайт: 
  • Профессия: Ученик 1С
Уже разобралась


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4586
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 16197
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4303
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 739
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7858
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 211
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal