Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 10:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Элементы управления  (Прочитано 2290 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rogaz

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-17
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, подскажите пожалуйста как мне реализовать следующий функционал:
Имеется внешняя обработка, запускается в режиме простого приложения.
Мне нужно отметить на форме элементы(через флажок, или может быть есть способ лучше), которые после нажатия кнопки(неважно какой) должны быть занесены в СписокЗначений. Как я понял для этого нужна обработка ПриИзменении флажка, но как получить элемент свойство Заголовок и занести его в список(Список должен быть глобальным?).


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
На форме обработки создаем ТЧ. 2 реквизита: 1 - типа булево, 1 - типа строка. Реквизит типа булево отображаем в виде флажка.
Далее размещаем на форме кнопку "не важно какую" (:bleh:).
Обходим по нажатии строки ТЧ и если реквизит типа булево = ИСТИНА, то
         СписокЗначений.Добавить(СтрокаТЧ.РеквизитТипаСтрока);
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн rogaz

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-17
  • Сайт: 
  • Профессия: Ученик 1С
На форме обработки создаем ТЧ. 2 реквизита: 1 - типа булево, 1 - типа строка. Реквизит типа булево отображаем в виде флажка.
Далее размещаем на форме кнопку "не важно какую" (:bleh:).
Обходим по нажатии строки ТЧ и если реквизит типа булево = ИСТИНА, то
         СписокЗначений.Добавить(СтрокаТЧ.РеквизитТипаСтрока);

1.ТЧ - это табличная часть? то есть элемент табличное поле, у которого реквизиты Колонка1, Колонка2 и т.д.?
2.А как отобразить его в виде флажка, подскажите, пожалуйста.
3.Можно ли в 1с обращаться к объекту, вызывающему  обработку (как self в делфи, например).
Заранее спасибо за помощь!


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. да
2. вот как то так
3. есть ЭтаФорма... есть владелец формы, вызвавший форму обработки...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн rogaz

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-17
  • Сайт: 
  • Профессия: Ученик 1С
1. да
2. вот как то так
3. есть ЭтаФорма... есть владелец формы, вызвавший форму обработки...

Большое спасибо! а не подскажете, как получить доступ к массиву элементов справочника(например у меня справочник экзамены, с реквизитом название и оценка) И мне нужно получить коллекцию всех названий или коллекцию всех оценок. Из синтакс-помощника не очень понятно

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ВыборкаСпр = Справочники.Экзамены.Выбрать();
Пока ВыборкаСпр.Следующий() Цикл
Сообщить(ВыборкаСпр.Наименование);
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн rogaz

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-17
  • Сайт: 
  • Профессия: Ученик 1С
ВыборкаСпр = Справочники.Экзамены.Выбрать();
Пока ВыборкаСпр.Следующий() Цикл
Сообщить(ВыборкаСпр.Наименование);
КонецЦикла;

Большие Спасибо!а есть ли возможность выделить из этих реквизитов разные уровни иерархии для построения дерева?

И как можно получить просто список реквизитов (без конкретных значений) стандартных и пользовательских?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. .ВыбратьИерархически()

2. Работа с метаданными
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн rogaz

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-17
  • Сайт: 
  • Профессия: Ученик 1С
1. .ВыбратьИерархически()

2. Работа с метаданными

Не могли бы вы пояснить? Мне нужно получить коллекцию сперва стандартных реквизитов справочника, т.е. чтобы в ней просто были названия(Родитель, Владелец, НАименование, Этогруппа и т.д.) а затем и коллекцию остальных, но ещё и так, чтобы я мог определить какие из них иерархические.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
вот фрагмент одной обработки...

Процедура КнопкаВыполнитьНажатие(Кнопка)

ОписаниеТиповСтрока = Новый ОписаниеТипов("Строка");

Для каждого ТекЭлСписка Из СписокСправочников Цикл

Если НЕ ТекЭлСписка.Пометка Тогда

Продолжить;

КонецЕсли;

ТекСпр = Метаданные.Справочники[ТекЭлСписка.Значение];

Сообщить("Обработка справочника: "+ТекСпр.Синоним);

СписокРеквизитов = Новый СписокЗначений;

Если (ТекСпр.ТипКода = Метаданные.СвойстваОбъектов.ТипКодаСправочника.Строка)
   И (ТекСпр.ДлинаКода <> 0)Тогда

СписокРеквизитов.Добавить("Код",2);

КонецЕсли;

Если ТекСпр.ДлинаНаименования <> 0 Тогда

СписокРеквизитов.Добавить("Наименование",2);

КонецЕсли;

Для каждого ТекРеквизит Из ТекСпр.Реквизиты Цикл

Если Найти(Строка(ТекРеквизит.Тип), "Строка") <> 0 Тогда

Если ТекРеквизит.Использование = Метаданные.СвойстваОбъектов.ИспользованиеРеквизита.ДляЭлемента Тогда

ИспользованиеРек = 1;

ИначеЕсли ТекРеквизит.Использование = Метаданные.СвойстваОбъектов.ИспользованиеРеквизита.ДляГруппыИЭлемента Тогда

ИспользованиеРек = 2;

ИначеЕсли ТекРеквизит.Использование = Метаданные.СвойстваОбъектов.ИспользованиеРеквизита.ДляГруппы Тогда

ИспользованиеРек = 3;

КонецЕсли;

СписокРеквизитов.Добавить(ТекРеквизит.Имя,ИспользованиеРек);

КонецЕсли;

КонецЦикла;

Если СписокРеквизитов.Количество() <> 0 Тогда

Выборка = Справочники[ТекСпр.Имя].Выбрать();
Пока Выборка.Следующий() Цикл

Состояние("Обработка элемента справочника: "+Выборка.Ссылка);

СправочникОбъект = Выборка.ПолучитьОбъект();
Для каждого НайденныйРеквизит Из СписокРеквизитов Цикл

Если СправочникОбъект.ЭтоГруппа И Число(НайденныйРеквизит.Представление)<2 Тогда

Продолжить;

КонецЕсли;

СправочникОбъект[НайденныйРеквизит.Значение] = СокрЛП(СправочникОбъект[НайденныйРеквизит.Значение]);

КонецЦикла;

Попытка
СправочникОбъект.Записать();
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;

КонецЦикла;

КонецЕсли;

КонецЦикла;

Предупреждение("Обработка справочников завершена");

КонецПроцедуры

Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

При обновлении на последние релизы в документе "Начисление зарплаты" не работают элементы формы

Автор Ольга166Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 1136
Последний ответ 12 Июн 2017, 00:43
от дфтын
Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2411
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Элементы Формы (Программное создание таблицы на форме и ручное заполнение)

Автор SpiriTMan777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 8175
Последний ответ 02 Авг 2011, 13:41
от sergejK74
Как найти элементы справочника в которых не указан строковый реквизит?

Автор СтафРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2064
Последний ответ 28 Ноя 2009, 12:42
от Никитина
Можно ли добавлять элементы в справочник, используя форму списка? 8.2

Автор maxkovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2494
Последний ответ 11 Дек 2011, 13:48
от maxkov

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal