Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 05:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 8.2 Частичная группировка данных таблицы значений  (Прочитано 6988 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
УПП 8.2 ред 1.3
Есть ТЗ: Таблица.Свернуть("Номенклатура, ХарактеристикаНоменклатуры", "Количество1, Количество2)
Пример заполнения:
Ручка1, Цвет-Синий, 5, 0
Ручка1, Цвет-Красный, 1, 8

Ручка1, Страна-Китай, 1,2
Ручка1, страна-Германия, 2,0

Вопрос такой- Хотелось бы свернуть до Номенклатуры, те позиции где характеристика Цвет, а остальные позиции оставить свернутыми до характеристики. КАК это можно сделать?
Ручка1, //--//, 6, 8
Ручка1, Страна-Китай, 1,2
Ручка1, страна-Германия, 2,0


Оффлайн pyrkin_vanya

  • **
  • Сообщений: 69
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-12-20
  • Сайт: 
Только если это будут разные таблицы значений.

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
С помощью стандартного метода Свернуть() думаю никак... Придется тебе писать самодельное сворачивание в цикле
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Напишите свою процедуру сворачивания таблицы и будет так как вы хотите.

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
С помощью стандартного метода Свернуть() думаю никак... Придется тебе писать самодельное сворачивание в цикле
начала делать так:
пробую разделить на две ТЗ, с Характеристикой Цвет и все остальные(без учета характеристик + с другими характеристиками отличными от Цвет).
так как я пишу что, при условии Если в ТЗ попадают все Номенклатуры без характеристик, а в ИНАЧЕ с характеристиками(в том числе и отличными от Цвет). Что я не так делаю, как правильно написать условие?
ТаблицаРезультатаСХар = Новый ТаблицаЗначений;
ТаблицаРезультатаСХар.Колонки.Добавить("Номенклатура");
ТаблицаРезультатаСХар.Колонки.Добавить("ХарактеристикаНоменклатуры");
ТаблицаРезультатаСХар.Колонки.Добавить("Количество1");
ТаблицаРезультатаСХар.Колонки.Добавить("Количество2");

ТаблицаРезультатаБезХар = Новый ТаблицаЗначений;
ТаблицаРезультатаБезХар.Колонки.Добавить("Номенклатура");
ТаблицаРезультатаБезХар.Колонки.Добавить("ХарактеристикаНоменклатуры");
ТаблицаРезультатаБезХар.Колонки.Добавить("Количество1");
ТаблицаРезультатаБезХар.Колонки.Добавить("Количество2");

Для Каждого Стр ИЗ Таблица ЦИКЛ
Если Стр.ХарактеристикаНоменклатуры=Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию("Цвет")Тогда

НоваяСтрока = ТаблицаРезультатаСХар.Добавить();
НоваяСтрока.Номенклатура = стр.Номенклатура;
НоваяСтрока.ХарактеристикаНоменклатуры = Стр.ХарактеристикаНоменклатуры;
НоваяСтрока.Количество1 = Стр.Количество1;
НоваяСтрока.Количество2 = Стр.Количество2;

Иначе
НоваяСтрока = ТаблицаРезультатаБезХар.Добавить();
НоваяСтрока.Номенклатура = стр.Номенклатура;
НоваяСтрока.ХарактеристикаНоменклатуры = Стр.ХарактеристикаНоменклатуры;
НоваяСтрока.Количество1 = Стр.Количество1;
НоваяСтрока.Количество2 = Стр.Количество2;
КонецЕсли;

КонецЦикла;


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Цитировать
Если Стр.ХарактеристикаНоменклатуры=Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию("Цвет")Тогда
У вас в справочнике точно есть Цвет? Найдите по коду!
Помогли, отблагодари!

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
В принципе код написали правильно, но смущает эта строчка:
Стр.ХарактеристикаНоменклатуры=Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию("Цвет")
Вы не думали что будет, если сменится наименование?
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
Если Стр.ХарактеристикаНоменклатуры=Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию("Цвет")Тогда
У вас в справочнике точно есть Цвет? Найдите по коду!
Цвет точно есть и по коду искала...результат тот же

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Как то все написано много:
ТаблицаРезультатаСХар = Таблица.СкопироватьКолонки();

ТаблицаРезультатаБезХар = Таблица.СкопироватьКолонки();
       
Для Каждого Стр ИЗ Таблица ЦИКЛ
Если Найти(Стр.ХарактеристикаНоменклатуры.Наименование,"Цвет")>0Тогда
               
НоваяСтрока = ТаблицаРезультатаСХар.Добавить();
ЗаполнитьЗначениеСвойств(НоваяСтрока,Стр);
           
Иначе
НоваяСтрока = ТаблицаРезультатаБезХар.Добавить();
ЗаполнитьЗначениеСвойств(НоваяСтрока,Стр);
КонецЕсли;
   
КонецЦикла;

Можно так написать!
Добавлено: 21 Окт 2014, 10:52

Как я понял цвет у вас указан в наименовании!
Помогли, отблагодари!

Оффлайн 1cka

  • ***
  • Сообщений: 154
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2014-01-04
  • Сайт: 
  • Профессия: Ученик 1С
В принципе код написали правильно, но смущает эта строчка:
Стр.ХарактеристикаНоменклатуры=Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию("Цвет")
Вы не думали что будет, если сменится наименование?

меня тоже смущает эта строчка((((
В самом справочнике ХарактеристикиНоменклатуры хранятся все значения характеристик (красный, синий, зеленый)для всех номенклатур, т.е. там хранятся Значения некого свойства Цвет.т.е. наименования как Цвет там нет!
Код Свойства Цвет нашла в ПланыВидовХарактеристик.СвойстваОбъектов... но как это применить не понимаю(((


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7439
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3885
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2114
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7338
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6958
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 227
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal