Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подписка на события "ПриЗаписи", как достать измененные категории  (Прочитано 3675 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн blackbeard

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-03-06
  • Сайт: 
  • Профессия: Программист 1С
Чет совсем не врубаюсь... В УПП у справочника Контрагенты есть три подписки которые нашел "ОбработкаПроверкиЗаполнения", "ПередЗаписью", и "ПриЗаписи", из входящих данных только Источник и у 1 еще есть ПроверяемыеРеквизиты, но они тоже не важны. Дак вот ... У контрагента пользователь добавляет категорию, мне надо в зависимости от этого обрабатывать данные, но категории как я понял записываются после записи контрагента. ибо когда в подписке "ПриЗаписи" я отлавливал записанные категории, запрос мне вернул только старые, я понимаю Подписка "ПриЗаписи" происходит ПОСЛЕ события "ПриЗаписи", получается данные должны были записаться или все же нет?? И как можно отловить те категории которые были изменены пользователем перед нажатием на кнопку Запись. Возможно ли форму объекта как-то достать? там просто на форме есть реквизит "категории". кот связан с обработкой Категории, вот может как то так попробовать... Кто-ниб подскажите куда копать то?


Оффлайн SitnovaMarina

  • Помогла? Скажи "Спасибо"!
  • ****
  • Сообщений: 358
  • РЕПУТАЦИЯ: 71
  • КПД: 20%
  • E-mail: Marishka0604@yandex.ru
  • Регистрация: 2014-09-12
    • Skype: Marishka0604991
  • Сайт: vk.com
  • Профессия: Программист 1С
Попробуйте проверить на модифицированность объект при записи и сравнивать значения Категории
Народная мудрость: Программу встречают по интерфейсу

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
в упп (у меня версия 1.2) Категрии контрагентов лежат в регистре сведений КатегорииОбъектов,
в процедуре при записи, есть такой код, там и копайте.

Категории.ОбъектОтбораКатегорий = Ссылка;
Если Категории.ЗначенияКатегорийМодифицированы() Тогда
Категории.ЗаписатьКатегорииОбъекта();   
ОбновитьКатегории();
КонецЕсли;

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн blackbeard

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-03-06
  • Сайт: 
  • Профессия: Программист 1С
в упп (у меня версия 1.2) Категрии контрагентов лежат в регистре сведений КатегорииОбъектов,
в процедуре при записи, есть такой код, там и копайте.
Негде копать УПП ver 1.3.54.2 в регистре сведений КатегорииОбъектов пусто, нет там ничего. Есть обработка "КатегорииОбъектов", в ней - Функция ЗаписатьКатегорииОбъекта(). причем Экспортная, но как до нее добраться, этож обработка, на нее подписок нет нормальных
Добавлено: 17 Окт 2014, 09:43

Чет я совсем запутался ХЕЛП! подписался (конечно же!!! озарило блин :zebzdr:) на процедуру "ПриЗаписи" регистра сведений КатегорииОбъектов, а там .... в источнике данных в отборах есть Объект. Объект = "ОООКонтрагент", а 2 измерение (категории) пустое. КАК ТАК? Непонятно
Добавлено: 17 Окт 2014, 12:16

все ок, только не знаю с точки зрения оптимальности не очень

Для Каждого Запись из Источник Цикл
    Если Запись.Категория = ИскКат Тогда
   ОбКонтрагент = Запись.Объект.ПолучитьОбъект();
   ОбКонтрагент.Парам1 = Парам1;
   ОбКонтрагент.Парам2 = Парам2;
        //Блаблабла
   Обконтрагент.Записать();
        //Вот тут не нравится, по идее справочник уже был записан, а я его еще раз перезап
    КонецЕсли;
КонецЦикла;

Последний раз редактировалось: blackbeard; 17 Окт 2014, 12:16. Причина: Объединение сообщений


Теги:
 

Какие ответственные лица могут быть указаны в регистре сведений "Ответственные л

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4306
Последний ответ 25 Ноя 2008, 11:07
от DDD
Бесплатная конференция «Отчетность за I полугодие: актуальные вопросы подготовки и требования законодательства"

Автор mixqnРаздел Мероприятия

Ответов: 0
Просмотров: 1601
Последний ответ 15 Июн 2014, 18:16
от mixqn
Какие преимущества получит менеджмент компании, сменив программу "1С:Торговля и

Автор БоняРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3307
Последний ответ 25 Июл 2008, 09:35
от Боня
Для контрагента в договоре установлен вариант ведения взаиморасчетов "По заказам

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3912
Последний ответ 25 Ноя 2008, 10:33
от DDD
Не получается сделать пример из книги "1С Предприятие Эффективное программирова

Автор v.k.l.chr.byРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2996
Последний ответ 02 Ноя 2011, 15:16
от has

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 214
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal