Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 03:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Загрузка из документа (Внешняя обработка)  (Прочитано 1253 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vladimir19901

  • Все просто!!!)
  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-10
  • Сайт: 
  • Профессия: Программист 1С
Создал внешнюю Обработку которая проверяет все документы Заказы Покупателям и выводит нужный мне список.
Хочу в эти документы табличную часть(Товары) заполнить в этом же документе в табличную часть (Исходный заказ) грубо говоря продублировать.
Вот собственно код:
Процедура КнопкаВыполнитьНажатие(Кнопка)     Ссылка = Документы.ЗаказПокупателя.ПолучитьСсылку();     Запрос = Новый Запрос;     Запрос.Текст =         "ВЫБРАТЬ РАЗЛИЧНЫЕ         |    ЗаказПокупателя.Ссылка,         |    ЗаказПокупателяТовары.НомерСтроки,         |    ЗаказПокупателяТовары.ЕдиницаИзмерения,         |    ЗаказПокупателяТовары.ЕдиницаИзмеренияМест,         |    ЗаказПокупателяТовары.Количество,         |    ЗаказПокупателяТовары.КоличествоМест,         |    ЗаказПокупателяТовары.Коэффициент,         |    ЗаказПокупателяТовары.Номенклатура,         |    ЗаказПокупателяТовары.СтавкаНДС,         |    ЗаказПокупателяТовары.Сумма,         |    ЗаказПокупателяТовары.СуммаНДС,         |    ЗаказПокупателяТовары.ХарактеристикаНоменклатуры,         |    ЗаказПокупателяТовары.Цена,         |    ЗаказПокупателяТовары.ПроцентАвтоматическихСкидок,         |    ЗаказПокупателяТовары.УсловиеАвтоматическойСкидки,         |    ЗаказПокупателяТовары.ЗначениеУсловияАвтоматическойСкидки,         |    ЗаказПокупателяТовары.Спецификация,         |    ЗаказПокупателяТовары.СерияНоменклатуры         |ИЗ         |    Документ.ЗаказПокупателя КАК ЗаказПокупателя         |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказПокупателя.ИсходныйЗаказ КАК ЗаказПокупателяИсходныйЗаказ         |        ПО ЗаказПокупателя.Ссылка <> ЗаказПокупателяИсходныйЗаказ.Ссылка         |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказПокупателя.Товары КАК ЗаказПокупателяТовары         |        ПО ЗаказПокупателя.Ссылка = ЗаказПокупателяТовары.Ссылка         |ГДЕ         |    ЗаказПокупателя.Дата МЕЖДУ &ДатаC И &ДатаПо";     Запрос.УстановитьПараметр("ДатаC", ДатаНачала);     Запрос.УстановитьПараметр("ДатаПо", ДатаОкончания);                                  Результат = Запрос.Выполнить();     ВыборкаДетальныеЗаписи = Результат.Выбрать();     Пока ВыборкаДетальныеЗаписи.Следующий() Цикл         Ссылка = ВыборкаДетальныеЗаписи.Ссылка;         Для Каждого Ссылка Из ВыборкаДетальныеЗаписи Цикл                 НоваяСтрока                                      = Ссылка.ИсходныйЗаказ.Добавить();                 НоваяСтрока.НомерСтроки                          = ВыборкаДетальныеЗаписи.НомерСтроки;                 НоваяСтрока.ЕдиницаИзмерения                     = ВыборкаДетальныеЗаписи.ЕдиницаИзмерения;                 НоваяСтрока.ЕдиницаИзмеренияМест                 = ВыборкаДетальныеЗаписи.ЕдиницаИзмеренияМест;                 НоваяСтрока.Количество                            = ВыборкаДетальныеЗаписи.Количество;                 НоваяСтрока.КоличествоМест                        = ВыборкаДетальныеЗаписи.КоличествоМест;                 НоваяСтрока.Коэффициент                             = ВыборкаДетальныеЗаписи.Коэффициент;                 НоваяСтрока.Номенклатура                         = ВыборкаДетальныеЗаписи.Номенклатура;                 НоваяСтрока.СтавкаНДС                            = ВыборкаДетальныеЗаписи.СтавкаНДС;                 НоваяСтрока.Сумма                                 = ВыборкаДетальныеЗаписи.Сумма;                 НоваяСтрока.СуммаНДС                            = ВыборкаДетальныеЗаписи.СуммаНДС;                 НоваяСтрока.ХарактеристикаНоменклатуры          = ВыборкаДетальныеЗаписи.ХарактеристикаНоменклатуры;                 НоваяСтрока.Цена                                  = ВыборкаДетальныеЗаписи.Цена;                 НоваяСтрока.ПроцентАвтоматическихСкидок          = ВыборкаДетальныеЗаписи.ПроцентАвтоматическихСкидок;                 НоваяСтрока.УсловиеАвтоматическойСкидки          = ВыборкаДетальныеЗаписи.УсловиеАвтоматическойСкидки;                 НоваяСтрока.ЗначениеУсловияАвтоматическойСкидки = ВыборкаДетальныеЗаписи.ЗначениеУсловияАвтоматическойСкидки;                 НоваяСтрока.Спецификация                         = ВыборкаДетальныеЗаписи.Спецификация;                 НоваяСтрока.СерияНоменклатуры                    = ВыборкаДетальныеЗаписи.СерияНоменклатуры;             КонецЦикла;         КонецЦикла;      КонецПроцедуры
Выдает ошибку на Для Каждого Ссылка Из ВыборкаДетальныеЗаписи Цикл Прошу подсказать как лучше продублировать данные?


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Дак загружайте в таблицу через загрузить,а то что нужно загружать через выгрузить
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Vladimir19901, код отформатируйте, в одну строку - ваще жесть! (((
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
А я через taptalk смотрю у меня тут вообще по другому)
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл         
    Ссылка = ВыборкаДетальныеЗаписи.Ссылка;       
    Для Каждого Ссылка Из ВыборкаДетальныеЗаписи Цикл 
    .................
    КонецЦикла;
КонецЦикла;
Вы тут сами не запутались?
Два цикла по одному запросу!!!
Притом первый цикл, для работы с выборкой, правильный, второй цикл используется для табличных частей (Для Каждого Х Из Табл Цикл) - он вам не нужен.
если хотите оставить второй цикл, то запрос.Выполнить().Выгрузить() - выгружается таблица значений;
В общем перемудри!!!
Добавлено: 17 Окт 2014, 09:00

Ошибка из-за того, с запроса вы получили Выборку, а второй цикл для ТаблициЗначений
Помогли, отблагодари!


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4474
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15932
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 629
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7745
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 172
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal