Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 21:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Итератор для значения не определен  (Прочитано 9845 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sasha_Mur

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-05
  • Сайт: 
Здравствуйте.
Конфигурация: 1С:Медицина. Зарплата и кадры бюджетного учреждения, редакция 1.0
Платформа:1С:Предприятие 8.2 (8.2.19.102)

Вылетает следующая ошибка:
Итератор для значения не определен
   
Для Каждого ЭлМассива из СтруктураКолонок Цикл
Функция, в которой ошибка:
Функция ПрочитатьКлассификаторМедРаботниковXML(ИмяФайла, ПолучитьТаблицой = Ложь) Экспорт	
СтруктураКолонокТаблиц = ПолучитьСтруктуруТаблицКлассификаторов();       
ТаблицаРезультат = Новый ТаблицаЗначений;
        Чтение = Новый ЧтениеXML;
        Чтение.ОткрытьФайл(ИмяФайла);
Чтение.Прочитать();
СтруктураКолонок = СтруктураКолонокТаблиц[Чтение.Имя];
    Для Каждого ЭлМассива из СтруктураКолонок Цикл
   ТаблицаРезультат.Колонки.Добавить(ЭлМассива.Ключ,ЭлМассива.Значение);
    КонецЦикла;
КонецФункции

ПолучитьСтруктуруТаблицКлассификаторов() выглядит следующим образом:
Функция ПолучитьСтруктуруТаблицКлассификаторов();
СтруктураКолонокБезИерархии = Новый Структура;
СтруктураКолонокБезИерархии.Вставить("ID",ОбщегоНазначенияЗК.ПолучитьОписаниеТиповЧисла(10));
СтруктураКолонокБезИерархии.Вставить("Name",ОбщегоНазначенияЗК.ПолучитьОписаниеТиповСтроки(254));

        СтруктураКолонокТаблиц = Новый Соответствие;
        СтруктураКолонокТаблиц.Вставить("ArrayOfCitizenship",СтруктураКолонокБезИерархии);

        Возврат СтруктураКолонокТаблиц;
КонецФункции;

Не могу понять что не так.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Какого типа у вас переменная СтруктураКолонок на момент исполнения цикла?
Предполагается что структура, но видимо это не так.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Sasha_Mur

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-05
  • Сайт: 
Структура колонок с типом "Неопределено". Хотя Чтение.Имя имеет строковое значение "ArrayOfСitizenship".

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Так у вас же здесь соответствие, а не структура!
 СтруктураКолонокТаблиц = Новый Соответствие;
        СтруктураКолонокТаблиц.Вставить("ArrayOfCitizenship",СтруктураКолонокБезИерархии);

Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн Sasha_Mur

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-05
  • Сайт: 
Так у вас же здесь соответствие, а не структура!
 СтруктураКолонокТаблиц = Новый Соответствие;
        СтруктураКолонокТаблиц.Вставить("ArrayOfCitizenship",СтруктураКолонокБезИерархии);

Может я чего-то не понимаю. В данной конструкции СтруктураКолонокБезИерархии - это структура. Далее в коде, я делаю поиск по ключу, т.о. у меня получается переменная типа Структура. Что вас смущает?

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
А почему вы сразу не передадите структуру?
 
 Функция ПолучитьСтруктуруТаблицКлассификаторов() 
СтруктураКолонокБезИерархии = Новый Структура;   
    СтруктураКолонокБезИерархии.Вставить("ID",ОбщегоНазначенияЗК.ПолучитьОписаниеТиповЧисла(10));
    СтруктураКолонокБезИерархии.Вставить("Name",ОбщегоНазначенияЗК.ПолучитьОписаниеТиповСтроки(254));


        Возврат СтруктураКолонокБезИерархии;
КонецФункции;
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
проверьте чему равно 'СтруктураКолонокТаблиц["ArrayOfCitizenship"]'
то есть явно указать эту строку...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Sasha_Mur

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-05
  • Сайт: 
проверьте чему равно 'СтруктураКолонокТаблиц["ArrayOfCitizenship"]'
то есть явно указать эту строку...

Если явно указать, то все нормально. Значение с типом структура.
Добавлено: 14 Окт 2014, 16:16

А сразу не передать структуру, потому что в зависимости от значения ключа будет возвращаться своя структура.

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Попробуйте вместо
СтруктураКолонок = СтруктураКолонокТаблиц[Чтение.Имя];
вот так
СтруктураКолонок = СтруктураКолонокТаблиц.Получить(Чтение.Имя);
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
а вот так:
СтруктураКолонок = СтруктураКолонокТаблиц[Строка(Чтение.Имя)];

?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Значения некоторых колонок являются суммами некоторых колонок, которые в свою очередь так же являются суммами других. Как упорядочить?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 278
Последний ответ 26 Июн 2017, 14:32
от AsadRoman
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 980
Последний ответ 11 Июл 2016, 09:00
от vitasw
Как сложить значения Столбца "Объем"

Автор anton.kislovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 19
Просмотров: 13506
Последний ответ 04 Май 2017, 10:48
от ospov11789
Нужна помощь в формировании отчета "Преобразование значения к типу Дата не может быть выполнено"

Автор STLuka1337Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2090
Последний ответ 14 Ноя 2014, 13:24
от cska-fanat-kz
Конвертация данных, ошибка "Преобразование значения к типу Число не может быть выполнено"

Автор CerebrinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1949
Последний ответ 10 Май 2015, 21:51
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 329
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal