Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 01:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Приходит пустой запрос  (Прочитано 1017 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kolya123

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-25
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, всегда приходит пустой запрос.
ИмеющийсяТоварОстатки.Фильм тип Справочник, также имеет свою табличную часть.
Регистры накопления (Приход,Расход) заполняются все верно.
Подскажите пожалуйста, что  я не учел?


Процедура ОбработкаПроведения(Отказ, Режим)
      Движения.ПрокатТовара.Записывать = Истина;
   Для Каждого ТекСтрокаЗаказ Из Заказ Цикл
      Движение = Движения.ПрокатТовара.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
      Движение.Период = Дата;
      Движение.Фильм = ТекСтрокаЗаказ.Фильм;
      Движение.Срок = ТекСтрокаЗаказ.Срок;
      Движение.Количество = ТекСтрокаЗаказ.Количество;
      Движение.Сумма = ТекСтрокаЗаказ.Сумма;
   КонецЦикла;
     Движения.Записать();
   
    Если Режим = РежимПроведенияДокумента.Оперативный Тогда
      
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ИмеющийсяТоварОстатки.Фильм,
      |   ИмеющийсяТоварОстатки.КоличествоОстаток КАК Количество
      |ИЗ
      |   РегистрНакопления.ИмеющийсяТовар.Остатки(
      |         ,
      |         Фильм В
      |            (ВЫБРАТЬ
      |               РеализацияЗаказ.Фильм
      |            ИЗ
      |               Документ.Реализация.Заказ КАК РеализацияЗаказ
      |            ГДЕ
      |               РеализацияЗаказ.Ссылка = &Ссылка)) КАК ИмеющийсяТоварОстатки
      |ГДЕ
      |   ИмеющийсяТоварОстатки.КоличествоОстаток < 0";

   Запрос.УстановитьПараметр("Ссылка",Ссылка);   
   РезультатЗапроса = Запрос.Выполнить();
   
   Если НЕ РезультатЗапроса.Пустой() Тогда
   Отказ = Истина;
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
   Сообщить("Недостаточно товара с фильмом"+ВыборкаДетальныеЗаписи.Фильм+"в количестве"+ВыборкаДетальныеЗаписи.Количество);   
   КонецЦикла;
   КонецЕсли;
КонецЕсли;
   

   
КонецПроцедуры


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
    |ГДЕ
      |   ИмеющийсяТоварОстатки.КоличествоОстаток < 0

ну видимо меньше нуля нету товара, оно и не выдает
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Kolya123

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-25
  • Сайт: 
  • Профессия: Ученик 1С
    |ГДЕ
      |   ИмеющийсяТоварОстатки.КоличествоОстаток < 0

ну видимо меньше нуля нету товара, оно и не выдает
Нет, я специально в Документе Реализации указывал большее количество товара, чем поступило

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Ну так а запрос у вас выбирает то остатки из регистра, т.е.он ищет в регистре отрицательные остатки, а не в документе
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Kolya123

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-25
  • Сайт: 
  • Профессия: Ученик 1С
Ну так а запрос у вас выбирает то остатки из регистра, т.е.он ищет в регистре отрицательные остатки, а не в документе
Да, Вы правы, а как мне это исправить?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
смотрим в книгу - видим фигу ui;;t;
перед запросом необходимо сформировать и записать движения по регистру ИмеющиесяТовары.
внимательно перечитайте тут:
http://1c.chistov.pro/2010/06/1-82.html
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9355
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Запрос Параметры для "ИЗ"

Автор БерезинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2998
Последний ответ 15 Май 2013, 23:27
от Березин
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 985
Последний ответ 11 Июл 2016, 09:00
от vitasw
Запрос по обработке "Согласование заявок"

Автор DenielAkreedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 686
Последний ответ 29 Сен 2016, 02:39
от DenielAkreed
8.2 Бух. Запрос с условием "комментарий содержит текст"

Автор bolobolРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 16543
Последний ответ 02 Сен 2011, 01:14
от bolobol

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 162
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal