Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 21:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Нажатие кнопки (внешняя обработка)  (Прочитано 4239 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Firepwnz

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-11
  • Сайт: 
  • Профессия: Ученик 1С
Есть внешняя обработка с созданной кнопкой.  Надо написать процедуру, чтобы по нажатию кнопки из общего модуля была выполнена процедура по созданию задач.

Процедура КнопкаВыполнитьНажатие(Кнопка)
ОбъектЗадача = ОбщиеМодули.ПолучитьОбъект();
ОбъектЗадача.СозданиеЗадачАО();
КонецПроцедуры

При нажатие ничего не происходит


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
ОбщиеМодули.СозданиеЗадачиАО();
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Firepwnz

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-11
  • Сайт: 
  • Профессия: Ученик 1С
Процедура Команда1(Команда)
ОбъектЗадача = ОбщиеМодули.СозданиеЗадачАО();
ОбъектЗадача.СозданиеЗадачАО();
КонецПроцедуры

{Форма.Форма.Форма(4,17)}: Переменная не определена (ОбщиеМодули)
   ОбъектЗадача = <<?>>ОбщиеМодули.СозданиеЗадачАО(); (Проверка: Тонкий клиент)
Модуль и Процедура называются СозданиеЗадачАО

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
ну значит СозданиеЗадачАО.СозданиеЗадачАО()
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Firepwnz

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-11
  • Сайт: 
  • Профессия: Ученик 1С
Процедура Команда1(Команда)
    ОбъектЗадача = СозданиеЗадачАО.СозданиеЗадачАО();
КонецПроцедуры

Получается так код должен выглядеть?

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
НУ если у вас процедура СозданиеЗадачАО() возвращает объект, то да. что врядле. но если она функция то да.
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Firepwnz

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-11
  • Сайт: 
  • Профессия: Ученик 1С
{Форма.Форма.Форма(4,17)}: Переменная не определена (СозданиеЗадачАО)
   ОбъектЗадача = <<?>>СозданиеЗадачАО.СозданиеЗадачАО(); (Проверка: Тонкий клиент)

Вот сам код, если это чем-то поможет
&НаСервер
Процедура СозданиеЗадачАО () Экспорт

Запрос = Новый Запрос;
Запрос.Текст =  "ВЫБРАТЬ
                | ТехническиеПроекты.ОписаниеАО,
                | ТехническиеПроекты.СуммаАО
                |ИЗ
                | Справочник.ТехническиеПроекты КАК ТехническиеПроекты
                |ГДЕ
                | ТехническиеПроекты.АбонентскоеСопровождение";
Выборка = Запрос.Выполнить();
Выборка = Результат.Выбрать();
СотрудникПоУмолчанию = Константы.СотрудникПоУмолчанию.Получить();
Задача.Ответственный = СотрудникПоУмолчанию;
Задача.СотрудникСоздания = СотрудникПоУмолчанию;
ТекДата = ТекущаяДата();
ТекущийМесяцИГод = Формат(ТекДата, "ДФ=MM.yyyy");
Пока Выборка.Следующий() Цикл
Задача = Справочники.Задачи.СоздатьЭлемент();
Задача.Наименование = "Услуги по договору за " + ТекущийМесяцИГод;
Задача.ОписаниеЗадачи = Выборка.ОписаниеАО ;
Задача.Сумма = Выборка.СуммаАО;
Задача.Цена = Выборка.СуммаАО;
Задача.Трудоемкость = 1;
Задача.Записать();
КонецЦикла;
КонецПроцедуры

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Мне поможет?
1С:Предприятие 8.2. Практическое пособие разработчика (М.Г.Радченко, Е.Ю.Хрусталева)
Хорошая книга, вам поможет:)
Добавлено: 11 Окт 2014, 18:06

по коду вам просто нужно вызвать эту процедуры и все. она ничего не возвращает. а просто каждый раз на весь справочник создает задачи. зачем оно вам так? ну ваше дело
Добавлено: 11 Окт 2014, 18:08

да и не будет процедура работать.  у вас она написано человеком который не вкурсе, что такое 1С
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Firepwnz

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-10-11
  • Сайт: 
  • Профессия: Ученик 1С
Не отрицаю что плохо, возможно даже отвратительно разбираюсь в 1с, вызвать я её хочу, т.к по словам друга во внешней обработке смогу понять почему она не работает, и вот уже целый день я пытаюсь это сотворить. При запуске процедуры 1с тупо виснет наглухо, и через минуту вылетает

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
ага. с ошибкой, что задача не определена. у вас алгоритм написан не очень хорошо, он работать не будет.  нужно вам вызывать специалиста. хотите помогу. а так, вам нужно прочитать, что такое запросы и что такое создание объектов.
Помог? Нажми - Спасибо :)
skype: Soprov1C


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 449
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal