Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 20:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Связь Параметров  (Прочитано 1060 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Artjomrgv

  • ***
  • Сообщений: 131
  • РЕПУТАЦИЯ: 12
  • КПД: 9%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Помогите с параметрами. 1С 8.2, БП 2.0. Смысл следующий  программно задать соответствие между организацией и контрагентом. Возможно ли такое


Процедура ОрганизацияПриИзменении(Элемент)
ПараметрОрганизация = КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Организация");
ПараметрОрганизация.Использование = Истина;
ПараметрОрганизация.Значение  = Организация;

КонецПроцедуры

   
Процедура КонтрагентВХПриИзменении(Элемент)
ПараметрКонтрагентВХ = КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонтрагентВХ");
ПараметрКонтрагентВХ.Использование = Истина
ПараметрКонтрагентВХ.Значение  = КонтрагентВХ;

КонтрагентВХ=Выбор КОГДА ПараметрОрганизация="ОПЕР" ТОГДА Справочники.Контрагенты.НайтиПоНаименованию("Сод") ИНАЧЕ Справочники.Контрагенты.НайтиПоНаименованию("ТОР")КОНЕЦ   
                           
КонецПроцедуры

Заранее спасибо


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Связь Параметров
« Ответ #1: 11 Окт 2014, 04:52 »
то же самое только с использованием оператора ?(,,)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Artjomrgv

  • ***
  • Сообщений: 131
  • РЕПУТАЦИЯ: 12
  • КПД: 9%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Re: Связь Параметров
« Ответ #2: 11 Окт 2014, 17:32 »
то же самое только с использованием оператора ?(,,)


Маленько упростил.

Настройки=КомпоновщикНастроек.Настройки;
Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Организация", Справочники.Организации.НайтиПоНаименованию("ОПЕР"));
Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Контрагент", Справочники.Контрагенты.НайтиПоНаименованию("СУД"));
                                                               
Если Организация=Справочники.Организации.НайтиПоНаименованию("ОПЕР")
Тогда                                                                                                         
Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("КонтрагентВХ", Справочники.Контрагенты.НайтиПоНаименованию("ДОР"))
Иначе   Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("КонтрагентВХ", Справочники.Контрагенты.НайтиПоНаименованию("СОН"))
КонецЕсли

Как обратиться именно к значению параметра Организация

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Связь Параметров
« Ответ #3: 11 Окт 2014, 17:50 »
Настройки=КомпоновщикНастроек.Настройки;
мОрганизация = Справочники.Организации.НайтиПоНаименованию("ОПЕР");
Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Организация", мОрганизация);
Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Контрагент", Справочники.Контрагенты.НайтиПоНаименованию("СУД"));
                                                               
Если Организация=мОрганизация Тогда                                                                                                         
Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("КонтрагентВХ", Справочники.Контрагенты.НайтиПоНаименованию("ДОР"))
Иначе   Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("КонтрагентВХ", Справочники.Контрагенты.НайтиПоНаименованию("СОН"))
КонецЕсли
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Artjomrgv

  • ***
  • Сообщений: 131
  • РЕПУТАЦИЯ: 12
  • КПД: 9%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Re: Связь Параметров
« Ответ #4: 11 Окт 2014, 19:58 »
Настройки=КомпоновщикНастроек.Настройки;
мОрганизация = Справочники.Организации.НайтиПоНаименованию("ОПЕР");

Спасибо но маленько не так. Пользователь будет выбирать значение параметра Организация и в зависимости от значения параметра Организация будет устанавливаться параметр КонтрагентВХ

мОрганизация = Справочники.Организации.НайтиПоНаименованию("ОПЕР");
Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Организация", мОрганизация);

                                                               
Если Значение параметра организация=мОрганизация Тогда                                                                                                         
Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("КонтрагентВХ", Справочники.Контрагенты.НайтиПоНаименованию("ДОР"))
Иначе   Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("КонтрагентВХ", Справочники.Контрагенты.НайтиПоНаименованию("СОН"))
КонецЕсли

Не могу разобраться как сравнить мОрганизация именно со значением параметра организация.
Добавлено: 11 Окт 2014, 20:45

Спасибо большое все оказалось просто. Впрочем как и всегда.
Процедура КонтрагентПриИзменении(Элемент)
      ПараметрКонтрагент = КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Контрагент");
       ПараметрКонтрагент.Использование = Истина;
       ПараметрКонтрагент.Значение  = Контрагент;
      Настройки=КомпоновщикНастроек.Настройки;
      Если Контрагент=Справочники.Контрагенты.НайтиПоНаименованию("ОПЕР") Тогда                                                                                                         
       Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("ОрганизацияВХ", Справочники.Организации.НайтиПоНаименованию("ОПЕР))  КонецЕсли;
      

Процедура ОрганизацияПриИзменении(Элемент)
      ПараметрОрганизация = КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Организация");
       ПараметрОрганизация.Использование = Истина;
       ПараметрОрганизация.Значение  = Организация;
      Настройки=КомпоновщикНастроек.Настройки;
      Если Организация=Справочники.Организации.НайтиПоНаименованию("СОД") Тогда                                                                                                         
       Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("КонтрагентВХ", Справочники.Контрагенты.НайтиПоНаименованию("СОД"))  КонецЕсли;
    
  КонецПроцедуры

Последний раз редактировалось: Artjomrgv; 11 Окт 2014, 20:45. Причина: Объединение сообщений


Теги:
 

Свойство "Связи параметров выбора"

Автор analitik777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6017
Последний ответ 05 Фев 2014, 15:04
от analitik777
Передача параметров из ячейки поля табличного документа в форму создания нового документа 1с 8.3

Автор Анна БахановичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 3026
Последний ответ 18 Фев 2016, 12:50
от Анна Баханович
Как программно отменить настройку в свойстве "Связи параметров выбора"?

Автор ArchanurikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 10079
Последний ответ 19 Авг 2011, 16:06
от has
Часть третья: переход на «1С ЗУП» версии «3.0». Адрес в программе «Параметров учета» и настройки состава удержаний и начислений

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 5842
Последний ответ 20 Мар 2015, 12:54
от 1cwiki
Сдвинулись поля ввода параметров виртуальной таблицы в конструкторе запроса(8.2)

Автор HakenРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4294
Последний ответ 14 Ноя 2010, 13:42
от progmikon

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
48 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 231
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal