Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 03:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод итогов после запроса  (Прочитано 4894 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн

  • *
  • Сообщений: 34
  • РЕПУТАЦИЯ: 2
  • КПД: 6%
  • Регистрация: 2014-10-01
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет! У меня возник наилегчайший вопрос по выводу итогов, подскажите пожалуйста. Существует запрос:

Запрос.Текст="ВЫБРАТЬ РАЗЛИЧНЫЕ
             | ЕСТЬNULL(ТиповойОстаткиИОбороты.СуммаКонечныйОстатокДт, 0) КАК СумКон,
             | ЕСТЬNULL(ТиповойОстаткиИОбороты.СуммаКонечныйРазвернутыйОстатокДт, 0) КАК СумРаз,
             | ЕСТЬNULL(ТиповойОстаткиИОбороты.СуммаКонечныйОстатокДт, 0) КАК КонСум,
             | СУММА(ЕСТЬNULL(ТиповойОстаткиИОбороты.СуммаКонечныйОстатокДт, 0)) КАК СумСум,
             | ТиповойОстаткиИОбороты.Валюта КАК Валюта,
             | ТиповойОстаткиИОбороты.СуммаКонечныйОстатокДт КАК СуммаКонечныйОстатокДт,
             | ТиповойОстаткиИОбороты.СуммаКонечныйРазвернутыйОстатокДт КАК СуммаКонечныйРазвернутыйОстатокДт
             |ИЗ
             | Документ.Остатки КАК Остатки
             | ЛЕВОЕ СОЕДИНЕНИЕ РегистрБухгалтерии.Типовой.ОстаткиИОбороты(&ДатаНач, &ДатаКон) КАК ТиповойОстаткиИОбороты
             | ПО Остатки.Валюта = ТиповойОстаткиИОбороты.Валюта
             |ГДЕ
             | И ТиповойОстаткиИОбороты.Валюта <> &Валюта
             |
             |СГРУППИРОВАТЬ ПО
             | ТиповойОстаткиИОбороты.Валюта,
             | ТиповойОстаткиИОбороты.СуммаКонечныйОстатокДт,
             | ТиповойОстаткиИОбороты.СуммаКонечныйРазвернутыйОстатокДт

Запрос.УстановитьПараметр("СуммаКонечныйРазвернутыйОстатокДт", СумРаз);
Запрос.УстановитьПараметр("СуммаКонечныйОстатокДт",СумКон);
Запрос.УстановитьПараметр("СуммаКонечныйОстатокДт",КонСум);
Запрос.УстановитьПараметр("СуммаКонечныйОстатокДт",СумСум);

        Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
ОбластьМакета.Параметры.ВидВалСтр = Выборка.Валюта;
ОбластьМакета.Параметры.СумРаз    = Выборка.СумРаз;
ОбластьМакета.Параметры.СумКон    = Выборка.СумКон;
ОбластьМакета.Параметры.КонСум   = Выборка.КонСум;
ТабДокумент.Вывести(ОбластьМакета);
КонецЦикла;

Требуется вывести итого (СумСум), но уже в отдельную область макета. Делаю следующее:

ОбластьМакета = Макет.ПолучитьОбласть("Группа2_Ито");	
ОбластьМакета.Параметры.ПерваяСумма = Выборка.СумСум;
ОбластьМакета.Параметры.ВтораяСумма = Выборка.СумСум;
ТабДокумент.Вывести(ОбластьМакета);

       В разделе "Итого" выводится только последнее значение, умноженное на 3. Поскольку имеется цикл, хотелось бы, чтобы сумма выводилась общая, а не только операции с последним значением. Буду благодарен за любую помощь!


Оффлайн

  • *
  • Сообщений: 34
  • РЕПУТАЦИЯ: 2
  • КПД: 6%
  • Регистрация: 2014-10-01
  • Сайт: 
  • Профессия: Ученик 1С
ОбластьМакета.Параметры.ПерваяСумма = Выборка.СумСум;
ОбластьМакета.Параметры.ВтораяСумма = Выборка.СумСум;

Рейтинг@Mail.ru


Пардон, чтобы не ввести в заблуждение, читайте только первую строчку: ОбластьМакета.Параметры.ПерваяСумма = Выборка.СумСум;

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
В цикле обхода выборки считайте параллельно итоговую сумму в отдельную переменную, а по окончании цикла выводите в соответствующий параметр...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн freez1301

  • ***
  • Сообщений: 130
  • РЕПУТАЦИЯ: 8
  • КПД: 6%
  • Регистрация: 2014-04-25
  • Сайт: 
  • Профессия: Ученик 1С
Выборка.Итог("СумСум");

Оффлайн

  • *
  • Сообщений: 34
  • РЕПУТАЦИЯ: 2
  • КПД: 6%
  • Регистрация: 2014-10-01
  • Сайт: 
  • Профессия: Ученик 1С
В цикле обхода выборки считайте параллельно итоговую сумму в отдельную переменную, а по окончании цикла выводите в соответствующий параметр...

А можно поподробнее, пожалуйста. Лучше на моем примере, если можно.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
...
Выборка = Запрос.Выполнить().Выбрать();
ИтогСумСум = 0;
    Пока Выборка.Следующий() Цикл
    ОбластьМакета.Параметры.ВидВалСтр = Выборка.Валюта;
    ОбластьМакета.Параметры.СумРаз    = Выборка.СумРаз;
    ОбластьМакета.Параметры.СумКон    = Выборка.СумКон;
    ОбластьМакета.Параметры.КонСум      = Выборка.КонСум;
    ТабДокумент.Вывести(ОбластьМакета);
ИтогСумСум = ИтогСумСум + 0;
    КонецЦикла;

ОбластьИтог. Параметры.ИтогСумСум = ИтогСумСум;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн

  • *
  • Сообщений: 34
  • РЕПУТАЦИЯ: 2
  • КПД: 6%
  • Регистрация: 2014-10-01
  • Сайт: 
  • Профессия: Ученик 1С
...
Выборка = Запрос.Выполнить().Выбрать();
ИтогСумСум = 0;
    Пока Выборка.Следующий() Цикл
    ОбластьМакета.Параметры.ВидВалСтр = Выборка.Валюта;
    ОбластьМакета.Параметры.СумРаз    = Выборка.СумРаз;
    ОбластьМакета.Параметры.СумКон    = Выборка.СумКон;
    ОбластьМакета.Параметры.КонСум      = Выборка.КонСум;
    ТабДокумент.Вывести(ОбластьМакета);
ИтогСумСум = ИтогСумСум + 0;
    КонецЦикла;

ОбластьИтог. Параметры.ИтогСумСум = ИтогСумСум;


Спасибо большое! Сделал, но из-за моей криворукости итог не вывелся. В чем может быть причина (помимо кривых рук):

Запрос.Текст="ВЫБРАТЬ РАЗЛИЧНЫЕ
                 |    СУММА (ЕСТЬNULL(Типовой.СуммаК, 0)) КАК СумКон,
                 |    ЕСТЬNULL(ТиповойОстаткиИОбороты.СуммаКонечныйРазвернутыйОстатокДт, 0) КАК СумРаз,
                 |    ЕСТЬNULL(ТиповойОстаткиИОбороты.СуммаКонечныйОстатокДт, 0) КАК КонСум,
                 |    СУММА(ЕСТЬNULL(ТиповойОстаткиИОбороты.СуммаКонечныйОстатокДт, 0)) КАК СумСум,
                 |    СУММА(ЕСТЬNULL(Типовой.Сумма, 0)) КАК ИтогСумСум,
                 |    ТиповойОстаткиИОбороты.Валюта КАК Валюта,
                 |    ТиповойОстаткиИОбороты.СуммаКонечныйОстатокДт КАК СуммаКонечныйОстатокДт,
                 |    ТиповойОстаткиИОбороты.СуммаКонечныйРазвернутыйОстатокДт КАК СуммаКонечныйРазвернутыйОстатокДт
                 |ИЗ
                 |    Документ.Остатки КАК Остатки
                 |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрБухгалтерии.Типовой.ОстаткиИОбороты(&ДатаНач, &ДатаКон) КАК ТиповойОстаткиИОбороты
                 |        ПО Остатки.Валюта = ТиповойОстаткиИОбороты.Валюта
                 |ГДЕ
                 |    И ТиповойОстаткиИОбороты.Валюта <> &Валюта
                 |
                 |СГРУППИРОВАТЬ ПО
                 |    ТиповойОстаткиИОбороты.Валюта,
                 |    ТиповойОстаткиИОбороты.СуммаКонечныйОстатокДт,
                 |    ТиповойОстаткиИОбороты.СуммаКонечныйРазвернутыйОстатокДт

    Запрос.УстановитьПараметр("СуммаКонечныйРазвернутыйОстатокДт", СумРаз);
    Запрос.УстановитьПараметр("СуммаКонечныйОстатокДт",СумКон);
    Запрос.УстановитьПараметр("СуммаКонечныйОстатокДт",КонСум);
    Запрос.УстановитьПараметр("СуммаКонечныйОстатокДт",СумСум);


    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
ИтогСумСум = 0;
    ОбластьМакета.Параметры.ВидВалСтр = Выборка.Валюта;
    ОбластьМакета.Параметры.СумРаз    = Выборка.СумРаз;
    ОбластьМакета.Параметры.СумКон    = Выборка.СумКон;
    ОбластьМакета.Параметры.КонСум      = Выборка.КонСум;
    ТабДокумент.Вывести(ОбластьМакета);
ИтогСумСум = ИтогСумСум + 0;
    КонецЦикла;


    ОбластьМакета = Макет.ПолучитьОбласть("Группа3_Ито");
    ОбластьМакета.Параметры. ИтогСумСум = Выборка.ИтогСумСум;
    ТабДокумент.Вывести(ОбластьМакета);


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
сперва я немного наврал, потом - ВЫ.

ИтогСумСум = ИтогСумСум + Выборка.СумСум;
...
ОбластьМакета.Параметры. ИтогСумСум = ИтогСумСум;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн

  • *
  • Сообщений: 34
  • РЕПУТАЦИЯ: 2
  • КПД: 6%
  • Регистрация: 2014-10-01
  • Сайт: 
  • Профессия: Ученик 1С
сперва я немного наврал, потом - ВЫ.

ИтогСумСум = ИтогСумСум + Выборка.СумСум;
...
ОбластьМакета.Параметры. ИтогСумСум = ИтогСумСум;

Все равно не подводит итог - только последнее число выводится, я в замешательстве :dfbsdfbsdf:

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
приведите текст запроса (и весь остальной код) на текущий момент...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги: итоги Запрос 
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 12189
Последний ответ 14 Июн 2012, 17:44
от Alex1111
Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9159
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Вывод комментария в документ "Расходная накладная" из документа "Заказ покупателя"

Автор ОльгаПлРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 204
Последний ответ 07 Окт 2017, 19:03
от Norfolk
"ПОДОБНО" в условие связи запроса

Автор Станиславъ ЗверевъРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 3231
Последний ответ 11 Май 2016, 15:29
от LexaK
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 723
Последний ответ 15 Июн 2017, 07:53
от mvk843

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 202
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal