Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 05:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с обработчиком ожидания  (Прочитано 3107 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн RUFFRYDA

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 1
  • КПД: 25%
  • Регистрация: 2014-08-29
  • Сайт: 
  • Профессия: Ученик 1С
Столкнулся с такой проблемой при использовании обработчика ожидания:
Таймер - реквизит, число, имеет на форме поле индикатора
Мессаж - реквизит, строка, имеет на форме поле надписи, только чтение.

При обработки кода обработчика ожидания (в данном случае каждую секунду) сбрасывается ввод информации в поля ввода реквизитов на форме, причем в различных ситуациях (зависит от событий обработчика ожидания) по-разному.
Например: если в обработчике ожидания будет присутствовать изменение заголовка какого-то поля реквизита [Элементы.Реквизит1.Заголовок = "asd" + Время(Таймер)], то выбрать элемент в всплывающем принажатии на КнопкуВыбора списке будет возможно только если между открытием списка и кликом на элемент не будет выполнен этот обработчик ожидания. Проблему решил тем, что заменил изменения заголовка в обработчике ожиданий на изменение значения (дополнительного) реквизита, но теперь появилась другая проблема, описаная ниже.

Еще пример: в обработчике изменяется лишь значение одного реквизита формы типа число ---> выбрать элемент для поля реквизита типа Справочник.Ссылка.<ИмяСправочника> при помощи КнопкиВыбора в сплывающем списке теперь можно, но при заполнении этого поля вручную, каждую секунду (интервал обработчика ожидания) значение сбрасывается.
Эту проблему решить не смог, пришел в тупик.

Кто-то может подтвердить, что это баг 1С или дать информацию по этому поводу? Прикладываю код формы:

&НаКлиенте
Процедура ПриОткрытии(Отказ)
Таймер = 120;
Мессаж = "Время на вход: " + Время(Таймер);
ПодключитьОбработчикОжидания("МинусСекунда", 1, 0);
КонецПроцедуры

&НаКлиенте
Процедура МинусСекунда()
Если (Таймер > 0) Тогда
Таймер = Таймер - 1;
Мессаж = "Время на вход: " + Время(Таймер);
//Элементы.Таймер.Заголовок = "Время на вход: " + Время(Таймер);
Иначе
Элементы.Вход.Доступность = 0;
Элементы.ЛогинФормы.Доступность = 0;
Элементы.ПарольФормы.Доступность = 0;
ОтключитьОбработчикОжидания("МинусСекунда");
Мессаж = "Время для логина вышло, преезапустите 1С: Предприятие";
КонецЕсли;
КонецПроцедуры

// число -> время
&НаКлиенте
Функция Время(Значение)
Если Значение < 60 Тогда
  Возврат Строка(Значение) + " сек.";
  ИначеЕсли Значение >= 60 и Значение < 60*60 Тогда
Возврат Строка(Цел(Значение/60)) + " мин. " + Строка(Значение-Цел(Значение/60)*60) + " сек.";
ИначеЕсли Значение >= 60*60 и Значение < 60*60*24 Тогда
    Возврат Строка(Цел(Значение/(60*60))) + " час. "
    +  Строка(Цел((Значение - (Цел(Значение/(60*60))*60*60))/60)) + " мин. "
    + Строка(Значение-Цел(Значение/60)*60) + " сек.";
КонецЕсли;
КонецФункции

Просьба не критиковать прикладную часть концепции и т.д. все, что я хочу извлечь из этой ситуации - опыт и понятие взаимодействия различных событий и объектов в 1С.


Оффлайн RUFFRYDA

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 1
  • КПД: 25%
  • Регистрация: 2014-08-29
  • Сайт: 
  • Профессия: Ученик 1С
Выяснил и решил проблему сам ~_~
Решается изменением значения "ОбновлениеТекстаРедактирования", которое при значении "Авто" творит ад, на "Не использовать"


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1177
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4700
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2431
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3323
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3582
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 223
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal