Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 11:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Пересчет цены или количества при изменении суммы  (Прочитано 3277 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MissisAngelina

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-10
  • Сайт: 
  • Профессия: Программист 1С
Доброго времени суток!

Необходимо реализовать пересчет цены или количества при изменении суммы (сам вариант пересчета - количества или цены, нужно определить с помощью константы).

&НаКлиенте
Процедура СписокНоменклатурыСуммаПриИзменении(Элемент)
   ВариантПересчетаСуммыПриИзменении(Элемент);   
КонецПроцедуры

&НаКлиенте
Процедура ВариантПересчетаСуммыПриИзменении(Элемент)
     ТекСтрока = Элементы.СписокНоменклатуры.ТекущиеДанные;
     ВариантПересчетаСуммыПриИзмененииНаСервере(ТекСтрока.Количество, ТекСтрока.Цена, ТекСтрока.Сумма);
     РасчетСуммыДокумента();
КонецПроцедуры

&НаСервере
Процедура ВариантПересчетаСуммыПриИзмененииНаСервере(Количество, Цена, Сумма)
   Пересчет = Константы.ВариантПересчетаСуммы.Получить();
   Если Пересчет = Перечисления.ВариантыПересчетаСуммы.Цена Тогда
      Цена = Сумма/Количество;
   Иначе
      Количество = Сумма/Цена;
   КонецЕсли;   
КонецПроцедуры


Но данная процедура пересчитывает только цену, даже если указан вариант пересчета количество. Где ошибка?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
зачем рассчитывать на сервере?
у вас есть все данные для расчета на клиенте!
единственная задача - получить вариант пересчета.
не берусь 100%но утверждать что значение константы нельзя получить на стороне клиента...
но даже если так, то можно завести реквизит формы этого же типа и положить в него значение константы в ПриСозданииНаСервере().

а так, все вроде правильно, смущает только вот это
...
РасчетСуммыДокумента();
...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Автозаполнение поля табличной части документа при изменении другого поля табличной части документа

Автор dimanpspРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 17
Просмотров: 3996
Последний ответ 02 Июн 2015, 15:53
от dimanpsp
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9338
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Вид цены "Произвольная" по умолчанию

Автор БонифацийРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 815
Последний ответ 25 Июн 2017, 19:52
от Otus
Не можем перенести цены из док-та "Оприходование тов."

Автор РиабамРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2122
Последний ответ 04 Май 2011, 21:49
от Eugeneer
Уменьшение закупочной цены-уменьшение прибыли на часть товара

Автор AinaРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3549
Последний ответ 13 Дек 2012, 18:46
от Aina

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 899
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal