Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 08:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не проводятся документы при программном заполнении  (Прочитано 1701 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн boldinov

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-12
  • Сайт: 
  • Профессия: Программист 8.1
При проведении программно сохраненного документа вылетает ошибка Значение поля Скад не может быть пустым.
Хотя в самом документе поле отображается заполненным. Аналогично по другим полям документа

 &НаСервере
Функция ПолучитьПоНаименованию(ТипСпр,Наим)
Возврат(Справочники[ТипСпр].НайтиПоНаименованию(Наим,Ложь));
КонецФункции

РеквизитыДокумента.Вставить("Склад",ПолучитьПоНаименованию("Склады",Rs.Fields("sclad").Value));


Оффлайн boldinov

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-12
  • Сайт: 
  • Профессия: Программист 8.1
&НаСервере
Функция ЗаполнитьДок(ВидДока,Данные,НазвТЧ="",Табл=Неопределено)
    Док1 = Новый ("ДокументМенеджер."+ВидДока);
   
    Док = Док1.СоздатьДокумент();
    Знчн = Неопределено;
    Для каждого Реквизит из Данные Цикл
        НазвРекв = Реквизит.Ключ;
        Знчн = Реквизит.Значение;
        Попытка
            Док[НазвРекв] = Знчн;
        Исключение
            Сообщить("Ключ " + НазвРекв + " не найден");
        КонецПопытки;
    КонецЦикла;
    //Док.Ответственный = ПараметрыСеанса.ТекущийПользователь;
    Если НазвТЧ = "" Тогда
        Возврат(Док);
    ИначеЕсли Табл = Неопределено Тогда
        Возврат(Док);
    КонецЕсли;
   
    ТабДок = Док[НазвТЧ];
    ТабДок.Загрузить(Табл);
      Док.Записать(РежимЗаписиДокумента.Запись);
    Возврат(Док);
   
КонецФункции

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
по приведенному коду мало что можно понять что не так...

ставьте точку останова на строку с записью и смотрите переменную - объект документа...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн roman_se.kz

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 3
  • КПД: 11%
  • Регистрация: 2014-08-19
  • Сайт: 
  • Профессия: Программист 1С
Док.Записать(РежимЗаписиДокумента.Запись)

А разве не нужно еще сделать

Док.Записать(РежимЗаписиДокумента.Проведение)
?

Оффлайн boldinov

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-12
  • Сайт: 
  • Профессия: Программист 8.1
Отладчик доходит до этого места
Процедура АвтономнаяРаботаПроверитьВозможностьЗаписиОбщихДанныхНаборЗаписей(Источник, Отказ, Замещение) Экспорт

ПередЗаписьюОбщихДанных(Источник, Отказ);

КонецПроцедуры
Дальше во внутрь не идет. На самом деле в документе приходная накладная склад есть. Если вручную поменять склад документ проводится

Добавлено: 28 Сен 2014, 11:38

Док.Записать(РежимЗаписиДокумента.Запись)

А разве не нужно еще сделать

Док.Записать(РежимЗаписиДокумента.Проведение)
?
Пытается сразу провести и выдает туже ошибку
Добавлено: 28 Сен 2014, 11:43

Дата             Номер       Проведен   Склад.Наименование   Склад.Код   Склад.Ссылка
01.09.2014 0:00:00   Кр-0901105415   Да   Центральный               1            Центральный
01.09.2014 0:00:00   Кр-0901105751   Нет   Центральный               1            Центральный
01.09.2014 0:00:00   Кр-0901145030   Нет   Центральный               1        Центральный
01.09.2014 0:00:00   Кр-0901161222   Нет   Центральный               1       Центральный

первый документ склад изменил вручную
Добавлено: 28 Сен 2014, 14:37

Нашел в табличной части склад нужно заполнить

Последний раз редактировалось: boldinov; 28 Сен 2014, 14:37. Причина: Объединение сообщений

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
скорее всего есть еще склад в табличной части к/й остается незаполненным


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 151
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal