Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 00:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение поля табличной части документа из реквизита справочника  (Прочитано 2772 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kolya123

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-25
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, есть справочник Расценка с реквизитом Стоимость и есть документ Реализация с товарной частью Заказ, в которой присутствует поле Стоимость, вопрос - как автоматически заполнить поле Стоимость из реквизита справочника. Знаю, что вопрос глупый, но я новичок в этом деле и сам разобраться не могу))
 
Вот, что я написал -
&НаКлиенте
Процедура ФильмСрокПриИзменении(Элемент)
 Элементы.Заказ.ТекущиеДанные.Стоимость =
КонецПроцедуры


Оффлайн shepsan

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 2
  • КПД: 40%
  • Регистрация: 2014-09-27
  • Сайт: 
  • Профессия: Программист 1С
как вариант
&НаКлиенте
Процедура ФильмСрокПриИзменении(Элемент)
 ТД=Элементы.Заказ.ТекущиеДанные;
ТД.Стоимость=ПолучитьСтоимость(<ссылка на элемент справочника, по которому надо получить стоимость>);
КонецПроцедуры

НаСервереБезКонтекста
Функция ПолучитьСтоимость(ссылка)
    возврат ссылка.Стоимость;
КонецФункции

Оффлайн Kolya123

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-25
  • Сайт: 
  • Профессия: Ученик 1С
Процедура ФильмСрокПриИзменении(Элемент)
ТД=Элементы.Заказ.ТекущиеДанные;
ТД.Стоимость=ПолучитьСтоимость(Справочники.Расценка.ПустаяСсылка());   
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьСтоимость(Справочники.Расценка.ПустаяСсылка())
    возврат Справочники.Расценка.ПустаяСсылка().Стоимость;
КонецФункции

{Документ.Реализация.Форма.ФормаДокумента.Форма(14,38)}: Ожидается символ ')'
Функция ПолучитьСтоимость(Справочники<<?>>.Расценка.ПустаяСсылка()) (Проверка: Тонкий клиент)

Что не так?

Оффлайн shepsan

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 2
  • КПД: 40%
  • Регистрация: 2014-09-27
  • Сайт: 
  • Профессия: Программист 1С
Процедура ФильмСрокПриИзменении(Элемент)
ТД=Элементы.Заказ.ТекущиеДанные;
ТД.Стоимость=ПолучитьСтоимость(Справочники.Расценка.ПустаяСсылка());   
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьСтоимость(Справочники.Расценка.ПустаяСсылка())
    возврат Справочники.Расценка.ПустаяСсылка().Стоимость;
КонецФункции

{Документ.Реализация.Форма.ФормаДокумента.Форма(14,38)}: Ожидается символ ')'
Функция ПолучитьСтоимость(Справочники<<?>>.Расценка.ПустаяСсылка()) (Проверка: Тонкий клиент)

Что не так?

Ссылку надо брать из текущего значения, предположу что это реквизит у вас ФильмСрок, тогда:
Процедура ФильмСрокПриИзменении(Элемент)
ТД=Элементы.Заказ.ТекущиеДанные;
ТД.Стоимость=ПолучитьСтоимость(ТД.ФильмСрок);   
КонецПроцедуры

Здесь менять ничего не нужно:
&НаСервереБезКонтекста
Функция ПолучитьСтоимость(ссылка)
    возврат Сссылка.Стоимость;
КонецФункции

Оффлайн Kolya123

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-25
  • Сайт: 
  • Профессия: Ученик 1С
Не работает, я не много не понял - ТД.Стоимость=ПолучитьСтоимость(ТД.ФильмСрок); 
Зачем мы берем в виде ссылки другое поле Товарной части документа, если нужна ссылка на реквизит элемента?

Оффлайн shepsan

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 2
  • КПД: 40%
  • Регистрация: 2014-09-27
  • Сайт: 
  • Профессия: Программист 1С
т.к. это и есть ссылка на справочник
а вообще, не видя хотя бы скринов лучше не подскажу. В общем смысл такой как описал, нужна ссылка на элемент справочника, которую надо получить из реквизитов документа, т.к. наверняка фильмСрок это реквизит ссылочного типа на справочник. Но для точности нужно смотреть.

Оффлайн Kolya123

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-25
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн shepsan

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 2
  • КПД: 40%
  • Регистрация: 2014-09-27
  • Сайт: 
  • Профессия: Программист 1С
Посмотрите в отладчике какое значение принимает ТД.Фильм. Или давайте подключусь. В личку.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Kolya123, на будущее, не надо дублировать темы. Просто можно попросить перенести в нужный раздел. Перенесенную из раздела 7.7 удалил.

Оффлайн Kolya123

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-25
  • Сайт: 
  • Профессия: Ученик 1С


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4486
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7760
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4792
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7350
Последний ответ 03 Фев 2012, 17:27
от Dinah
Не заполняется поле "Цена" при формировании документа "Пересчет товаров"

Автор InnakechaРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 1093
Последний ответ 29 Дек 2016, 09:54
от Innakecha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 195
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal