Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 00:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение табличного документа  (Прочитано 1701 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gregory78

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-14
  • Сайт: 
  • Профессия: Ученик 1С
 Здравствуйте!
Имеется отчет без СКД с макетом - табличным документом и процедурой в модуле формы.
В макете содержится таблица, ячейки которой соответствуют дням месяца.
Вопрос: как сделать, чтобы при обходе результата запроса в каждую ячейку таблицы добавлялось
по несколько символьных отметок (знаков +), соответствующих выходам сотрудника на этот день.
То есть, число выходов за день может варьироваться от одного до четырех.
По логике, это должно работать примерно так (частично опишу словами):

Если День(Выборка.Дата) = 1 Тогда
//Добавить в ячейку 1 символ "+";
КонецЕсли;

-и так на 31 ячейку. Сколько выходов в день, столько плюсиков в каждой ячейке таблицы.
Есть соображения?


Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
У вас где-нибудь зафиксировано количество выходов на каждый день?
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. Запросом получать количество выходом (1-4)
2. В выражении представления вызываем функцию из общего модуля, в которой из числа получаем строку с плюсами
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Gregory78

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-14
  • Сайт: 
  • Профессия: Ученик 1С
У вас где-нибудь зафиксировано количество выходов на каждый день?

Само количество не зафиксировано, есть только последовательные записи о дате, проведенном мероприятии, фамилии сотрудника в периодическом регистре сведений, откуда и берутся данные запросом в отчет.
Добавлено: 25 Сен 2014, 16:29

1. Запросом получать количество выходом (1-4)
2. В выражении представления вызываем функцию из общего модуля, в которой из числа получаем строку с плюсами

Так... В общих чертах идею уловил, но можно объяснить подробнее?

Последний раз редактировалось: Gregory78; 25 Сен 2014, 16:29. Причина: Объединение сообщений

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Само количество не зафиксировано, есть только последовательные записи о дате, проведенном мероприятии, фамилии сотрудника в периодическом регистре сведений, откуда и берутся данные запросом в отчет.

1) Вам нужно вычислить количество мероприятий на каждый день.
2) Внутри цикла по дням, добавить цикл по количеству выходов в этот день, и в цикле к переменной типа Строка прибавлять соответствующее количество плюсов. Примерно так:

Для каждого Стр из ТЗДни Цикл
Область = Макет.ПолучитьОбласть("ВашаОбласть");
Выходы = "";
пп = 0;
Пока НЕ пп = Стр.КоличествоВыходов Цикл
Выходы = Выходы + "+";
пп = пп + 1;
КонецЦикла;
Область.Параметры.КолвоВыходов = Выходы;
ТабличныйДокумент.Вывести(Область);
КонецЦикла;
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн Gregory78

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-14
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо, попробую. Как что, отпишусь)
Добавлено: 26 Сен 2014, 13:48

Так, количество выходов за день получил, значки "нарисовал". Надо теперь в теле цикла заполнить значком параметр в таблице, и при этом каждый раз попасть в новую ячейку, с цифрой, соответствующей дню месяца (см.вложенный рисунок). Вот с этим пока что не разберусь...

Последний раз редактировалось: Gregory78; 26 Сен 2014, 13:48. Причина: Объединение сообщений

Оффлайн Gregory78

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-14
  • Сайт: 
  • Профессия: Ученик 1С
Так... Разобрался, все рисуется там где надо. Спасибо всем, и методу Параметры.Установить() :D


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4478
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7747
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4786
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8524
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7344
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 179
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal