Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 16:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: В толстом клиенте не видит обработчик событий  (Прочитано 6112 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн boldinov

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-12
  • Сайт: 
  • Профессия: Программист 8.1
Ут 11.1 внешняя обработка заполнения документа ввод остатков не видит обработчики событий.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
вид клиента - не при чем...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн boldinov

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-12
  • Сайт: 
  • Профессия: Программист 8.1
Подскажите что причем? Как сервер настроить чтобы видел обработчики?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Начнем с того... обработчики КАКИХ событий?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн boldinov

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-12
  • Сайт: 
  • Профессия: Программист 8.1
Подписка ЗаполнитьРеквизитыОбъекта событие ОбработкаЗаполнения. Подозреваю что все другие события на документы тоже не видит.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
по-подробнее опишите, что у вас происходит...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн mku-rino

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 2
  • КПД: 29%
  • Регистрация: 2014-09-23
  • Сайт: 
Подписки корректно отрабатывают. Проверь еще раз настройки самой подписки, а именно Источник.

Оффлайн boldinov

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-12
  • Сайт: 
  • Профессия: Программист 8.1
При попытки записать документ вылетает с ошибкой
&НаСервере
Функция ЗаполнитьДок(ВидДока,Данные,НазвТЧ="",Табл=Неопределено,i)
Док1 = Новый ("ДокументМенеджер."+ВидДока);
Док = Док1.СоздатьДокумент();
Знчн = Неопределено;
Для каждого Реквизит из Данные Цикл
НазвРекв = Реквизит.Ключ;
Знчн = Реквизит.Значение;
Попытка
Док[НазвРекв] = Знчн;
Исключение
Сообщить("Ключ " + НазвРекв + " не найден");
КонецПопытки;
КонецЦикла;
Док.Ответственный = ПараметрыСеанса.ТекущийПользователь;
Если НазвТЧ = "" Тогда
Возврат(Док);
ИначеЕсли Табл = Неопределено Тогда
Возврат(Док);
КонецЕсли;

ТабДок = Док[НазвТЧ];
ТабДок.Загрузить(Табл);
  попытка
Док.Записать(РежимЗаписиДокумента.Запись);
Исключение
КонецПопытки;
Возврат(Док);

КонецФункции
Выдается ошибка

Оффлайн mku-rino

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 2
  • КПД: 29%
  • Регистрация: 2014-09-23
  • Сайт: 
Значит некорректно указан Обработчик в подписке.

Оффлайн boldinov

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-12
  • Сайт: 
  • Профессия: Программист 8.1
Подписки корректно отрабатывают. Проверь еще раз настройки самой подписки, а именно Источник.
А что там проверять? В источнике документ есть, который обрабатывается, а именно Ввод остатков. Вот если его убрать
будут ошибки на другие подписки. Отсюда сделал вывод что Клиент не видит обработчики
Добавлено: 24 Сен 2014, 09:53

Значит некорректно указан Обработчик в подписке.
Да что тут может быть некорректно?!
http://savepic.ru/5947208.jpg


Теги:
 

е видит поле в структуре (1С 8.2). Поле объекта не обнаружено (Курс).

Автор AlieramadaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2928
Последний ответ 05 Фев 2014, 08:50
от wise
Обработка "Регистрация счетов-фактур на аванс" не видит суммы зачета авансов.

Автор omahiРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2404
Последний ответ 21 Апр 2015, 21:21
от omahi
В ЗУП не видит отпуск по уходу за реберном и ставит явку в табеле

Автор NastaxsРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 4719
Последний ответ 19 Мар 2014, 06:11
от SoloSpirit
Перенесено: 1С Документооборот: пользователь не видит файл, прикрепленный к задаче

Автор cska-fanat-kzРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1582
Последний ответ 28 Апр 2014, 16:58
от cska-fanat-kz
Табель учета рабочего времени не видит отпуск в Камине

Автор ktyfРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1534
Последний ответ 15 Июл 2014, 12:43
от ktyf

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal