Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Янв 2018, 08:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: НЕ могу понять HELP  (Прочитано 3055 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Artem48

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Не могу решить В Методичке (Практикум) вообще не понимаю .

Допустим пользователь начинает выписывать Приходный кассовый ордер для конкретного контрагента. Апрограмма сразу подсказывает:  сколько этот контрагент нам должен . Поэтому: При выборе контрагента в документе ""ПКО"" нужно создать процедуру, которая проверит задолжность данной организации перед нами. и в случае, если та- положительная , пропишет эту задолженость в поле "СУММА"


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Re: НЕ могу понять HELP
« Ответ #1: 22 Сен 2014, 16:03 »
Так что вам надо? Что бы за вас все решили? так это вам в раздел фриланс!
Помогли, отблагодари!

Оффлайн Artem48

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Re: НЕ могу понять HELP
« Ответ #2: 22 Сен 2014, 16:06 »
чтобы обяснили как сделать.
Добавлено: 22 Сен 2014, 16:14

Не могу решить В Методичке (Практикум) вообще не понимаю .

Допустим пользователь начинает выписывать Приходный кассовый ордер для конкретного контрагента. Апрограмма сразу подсказывает:  сколько этот контрагент нам должен . Поэтому: При выборе контрагента в документе ""ПКО"" нужно создать процедуру, которая проверит задолжность данной организации перед нами. и в случае, если та- положительная , пропишет эту задолженость в поле "СУММА"


в форме документа ПКО захожу в модуль и прописываю

&НаКлиенте
Процедура КонтрАгентПриИзменении(Элемент)
   Объект.Сумма = ПолучитьСуммуДолга(Объект.Контрагент)
КонецПроцедуры


&Насервере

Функция ПолучитьСуммуДолга(Контрагент)
Запрос = Новый запрос;
Запрос.Текст = "ВЫБРАТЬ СуммаОстаток из РегистрНакопления.Задолженности.СуммаОстаток ГДЕ Контрагент = &Контрагент";
Запрос.УстановитьПараметр("Контрагент", Контрагент);
Выборка = Запрос.Выполнить.Выбрать();
Если Выборка.Следующий() Тогда
Возврат Выборка.СуммаОстаток;
КонецЕсли;
Возврат 0;
КонецФункции


что не так?

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Re: НЕ могу понять HELP
« Ответ #3: 22 Сен 2014, 16:21 »
Добавьте в запрос условия, что сумма больше 0. Тогда вы будете получать только задолженности. Уберите передачу контрагента в функцию.
Помогли, отблагодари!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: НЕ могу понять HELP
« Ответ #4: 23 Сен 2014, 07:37 »
из РегистрНакопления.Задолженности.СуммаОстаток

это что за таблица такая?
должна быть виртуальная таблица остатков...
хоть конструктором запросов научитесь пользоваться...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Artem48

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Re: НЕ могу понять HELP
« Ответ #5: 23 Сен 2014, 07:42 »
из РегистрНакопления.Задолженности.СуммаОстаток

это что за таблица такая?
должна быть виртуальная таблица остатков...
хоть конструктором запросов научитесь пользоваться...

так помоги . что за таблица виртуальная?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: НЕ могу понять HELP
« Ответ #6: 23 Сен 2014, 07:49 »
В очередной раз рискну привести код из "образной" базы.
Так сказать все имена и фамилии изменены...

Запрос = Новый Запрос;
Запрос.Текст =
   "ВЫБРАТЬ
   |   ДенежныеСредстваОстатки.СуммаОстаток
   |ИЗ
   |   РегистрНакопления.ДенежныеСредства.Остатки(&Дата, Касса = &Касса) КАК ДенежныеСредстваОстатки";
   Запрос.УстановитьПараметр("Дата", Дата);
        Запрос.УстановитьПараметр("Касса", Касса);
   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   Если ВыборкаДетальныеЗаписи.Следующий() Тогда
       Возврат ВыборкаДетальныеЗаписи.СуммаОстаток;
   Иначе   
       Возврат 0;
   КонецЕсли;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Artem48

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Re: НЕ могу понять HELP
« Ответ #7: 23 Сен 2014, 07:54 »
В очередной раз рискну привести код из "образной" базы.
Так сказать все имена и фамилии изменены...

Запрос = Новый Запрос;
Запрос.Текст =
   "ВЫБРАТЬ
   |   ДенежныеСредстваОстатки.СуммаОстаток
   |ИЗ
   |   РегистрНакопления.ДенежныеСредства.Остатки(&Дата, Касса = &Касса) КАК ДенежныеСредстваОстатки";
   Запрос.УстановитьПараметр("Дата", Дата);
        Запрос.УстановитьПараметр("Касса", Касса);
   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   Если ВыборкаДетальныеЗаписи.Следующий() Тогда
       Возврат ВыборкаДетальныеЗаписи.СуммаОстаток;
   Иначе   
       Возврат 0;
   КонецЕсли;



я правильно понял в модуле объекта это прописывается?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: НЕ могу понять HELP
« Ответ #8: 23 Сен 2014, 07:57 »
Это прописывается внутри вашей функции ПолучитьСуммуДолга()

и директива перед ней должна быть &НаСервереБезКонтекста
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Artem48

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Re: НЕ могу понять HELP
« Ответ #9: 23 Сен 2014, 08:42 »
В очередной раз рискну привести код из "образной" базы.
Так сказать все имена и фамилии изменены...

Запрос = Новый Запрос;
Запрос.Текст =
   "ВЫБРАТЬ
   |   ДенежныеСредстваОстатки.СуммаОстаток
   |ИЗ
   |   РегистрНакопления.ДенежныеСредства.Остатки(&Дата, Касса = &Касса) КАК ДенежныеСредстваОстатки";
   Запрос.УстановитьПараметр("Дата", Дата);
        Запрос.УстановитьПараметр("Касса", Касса);
   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   Если ВыборкаДетальныеЗаписи.Следующий() Тогда
       Возврат ВыборкаДетальныеЗаписи.СуммаОстаток;
   Иначе   
       Возврат 0;
   КонецЕсли;



я правильно понял в модуле объекта это прописывается?



а вообще я это в конструкторе запросов должен был создать?


Теги:
 

не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4129
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
не могу заполнить поле "Соглашение"

Автор aprnРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3260
Последний ответ 05 Май 2011, 18:17
от Maxim
Не могу найти в 1С8.3 справочник "Организации"

Автор ГюзельРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 14114
Последний ответ 17 Сен 2014, 11:18
от Гюзель
Не могу найти "Удаление помеченных объектов"

Автор LeviathanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 5681
Последний ответ 14 Янв 2016, 06:03
от cska-fanat-kz
Если у счёта есть признак учёта "Количество", то я могу писать Двж.КоличествоДт?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 5577
Последний ответ 25 Апр 2012, 10:39
от Vit1501

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
98 Сообщений
AIFrame
77 Сообщений
alex0402
32 Сообщений
kiksi
24 Сообщений
pavl_vs
23 Сообщений
andron81_81
18 Сообщений
alexandr_ll
17 Сообщений
Norfolk
15 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений
Staler
12 Сообщений

* Кто онлайн

  • Точка Гостей: 465
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal