Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Июн 2018, 02:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: НЕ могу понять HELP  (Прочитано 3835 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Artem48

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Не могу решить В Методичке (Практикум) вообще не понимаю .

Допустим пользователь начинает выписывать Приходный кассовый ордер для конкретного контрагента. Апрограмма сразу подсказывает:  сколько этот контрагент нам должен . Поэтому: При выборе контрагента в документе ""ПКО"" нужно создать процедуру, которая проверит задолжность данной организации перед нами. и в случае, если та- положительная , пропишет эту задолженость в поле "СУММА"


Оффлайн Yura063

  • *****
  • Сообщений: 1050
  • РЕПУТАЦИЯ: 137
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: 
  • Профессия: Программист 1С
Re: НЕ могу понять HELP
« Ответ #1: 22 Сен 2014, 16:03 »
Так что вам надо? Что бы за вас все решили? так это вам в раздел фриланс!
Помогли, отблагодари!

Оффлайн Artem48

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Re: НЕ могу понять HELP
« Ответ #2: 22 Сен 2014, 16:06 »
чтобы обяснили как сделать.
Добавлено: 22 Сен 2014, 16:14

Не могу решить В Методичке (Практикум) вообще не понимаю .

Допустим пользователь начинает выписывать Приходный кассовый ордер для конкретного контрагента. Апрограмма сразу подсказывает:  сколько этот контрагент нам должен . Поэтому: При выборе контрагента в документе ""ПКО"" нужно создать процедуру, которая проверит задолжность данной организации перед нами. и в случае, если та- положительная , пропишет эту задолженость в поле "СУММА"


в форме документа ПКО захожу в модуль и прописываю

&НаКлиенте
Процедура КонтрАгентПриИзменении(Элемент)
   Объект.Сумма = ПолучитьСуммуДолга(Объект.Контрагент)
КонецПроцедуры


&Насервере

Функция ПолучитьСуммуДолга(Контрагент)
Запрос = Новый запрос;
Запрос.Текст = "ВЫБРАТЬ СуммаОстаток из РегистрНакопления.Задолженности.СуммаОстаток ГДЕ Контрагент = &Контрагент";
Запрос.УстановитьПараметр("Контрагент", Контрагент);
Выборка = Запрос.Выполнить.Выбрать();
Если Выборка.Следующий() Тогда
Возврат Выборка.СуммаОстаток;
КонецЕсли;
Возврат 0;
КонецФункции


что не так?

Оффлайн Yura063

  • *****
  • Сообщений: 1050
  • РЕПУТАЦИЯ: 137
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: 
  • Профессия: Программист 1С
Re: НЕ могу понять HELP
« Ответ #3: 22 Сен 2014, 16:21 »
Добавьте в запрос условия, что сумма больше 0. Тогда вы будете получать только задолженности. Уберите передачу контрагента в функцию.
Помогли, отблагодари!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: НЕ могу понять HELP
« Ответ #4: 23 Сен 2014, 07:37 »
из РегистрНакопления.Задолженности.СуммаОстаток

это что за таблица такая?
должна быть виртуальная таблица остатков...
хоть конструктором запросов научитесь пользоваться...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Artem48

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Re: НЕ могу понять HELP
« Ответ #5: 23 Сен 2014, 07:42 »
из РегистрНакопления.Задолженности.СуммаОстаток

это что за таблица такая?
должна быть виртуальная таблица остатков...
хоть конструктором запросов научитесь пользоваться...

так помоги . что за таблица виртуальная?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: НЕ могу понять HELP
« Ответ #6: 23 Сен 2014, 07:49 »
В очередной раз рискну привести код из "образной" базы.
Так сказать все имена и фамилии изменены...

Запрос = Новый Запрос;
Запрос.Текст =
   "ВЫБРАТЬ
   |   ДенежныеСредстваОстатки.СуммаОстаток
   |ИЗ
   |   РегистрНакопления.ДенежныеСредства.Остатки(&Дата, Касса = &Касса) КАК ДенежныеСредстваОстатки";
   Запрос.УстановитьПараметр("Дата", Дата);
        Запрос.УстановитьПараметр("Касса", Касса);
   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   Если ВыборкаДетальныеЗаписи.Следующий() Тогда
       Возврат ВыборкаДетальныеЗаписи.СуммаОстаток;
   Иначе   
       Возврат 0;
   КонецЕсли;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Artem48

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Re: НЕ могу понять HELP
« Ответ #7: 23 Сен 2014, 07:54 »
В очередной раз рискну привести код из "образной" базы.
Так сказать все имена и фамилии изменены...

Запрос = Новый Запрос;
Запрос.Текст =
   "ВЫБРАТЬ
   |   ДенежныеСредстваОстатки.СуммаОстаток
   |ИЗ
   |   РегистрНакопления.ДенежныеСредства.Остатки(&Дата, Касса = &Касса) КАК ДенежныеСредстваОстатки";
   Запрос.УстановитьПараметр("Дата", Дата);
        Запрос.УстановитьПараметр("Касса", Касса);
   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   Если ВыборкаДетальныеЗаписи.Следующий() Тогда
       Возврат ВыборкаДетальныеЗаписи.СуммаОстаток;
   Иначе   
       Возврат 0;
   КонецЕсли;



я правильно понял в модуле объекта это прописывается?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: НЕ могу понять HELP
« Ответ #8: 23 Сен 2014, 07:57 »
Это прописывается внутри вашей функции ПолучитьСуммуДолга()

и директива перед ней должна быть &НаСервереБезКонтекста
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Artem48

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-22
  • Сайт: 
  • Профессия: Ученик 1С
Re: НЕ могу понять HELP
« Ответ #9: 23 Сен 2014, 08:42 »
В очередной раз рискну привести код из "образной" базы.
Так сказать все имена и фамилии изменены...

Запрос = Новый Запрос;
Запрос.Текст =
   "ВЫБРАТЬ
   |   ДенежныеСредстваОстатки.СуммаОстаток
   |ИЗ
   |   РегистрНакопления.ДенежныеСредства.Остатки(&Дата, Касса = &Касса) КАК ДенежныеСредстваОстатки";
   Запрос.УстановитьПараметр("Дата", Дата);
        Запрос.УстановитьПараметр("Касса", Касса);
   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   Если ВыборкаДетальныеЗаписи.Следующий() Тогда
       Возврат ВыборкаДетальныеЗаписи.СуммаОстаток;
   Иначе   
       Возврат 0;
   КонецЕсли;



я правильно понял в модуле объекта это прописывается?



а вообще я это в конструкторе запросов должен был создать?


Теги:
 

не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4893
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
не могу заполнить поле "Соглашение"

Автор aprnРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3515
Последний ответ 05 Май 2011, 18:17
от Maxim
Не могу найти в 1С8.3 справочник "Организации"

Автор ГюзельРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 16072
Последний ответ 17 Сен 2014, 11:18
от Гюзель
Если я напишу свою конфигурацию в учебной версии 1с предприятие, то я могу запустить эту базу только 1с предприятие ?

Автор Пётр ЗаболоцкийРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 107
Последний ответ 20 Июн 2018, 22:19
от BuhRust
Не могу найти "Удаление помеченных объектов"

Автор LeviathanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 6994
Последний ответ 14 Янв 2016, 06:03
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

AIFrame AIFrame
125 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
123 Сообщений
alexandr_ll
61 Сообщений
pavl_vs
47 Сообщений
alex0402
28 Сообщений
buketov.av buketov.av
24 Сообщений
magnifico61
21 Сообщений
wise wise
20 Сообщений
ilyay ilyay
15 Сообщений
trialex3
15 Сообщений

* Кто онлайн

  • Точка Гостей: 239
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal