Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 18:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получить имя формы  (Прочитано 2320 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nuraez

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-15
  • Сайт: 
  • Профессия: Программист 1С
Добрый день!  Как получить имя формы списка документов или имя самого документа. в функцию передаеться только ЭтаФорма.


Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Ну так и пиши
ЭтаФорма.ИмяФормы
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн nuraez

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-15
  • Сайт: 
  • Профессия: Программист 1С
Ну так и пиши
ЭтаФорма.ИмяФормы
Я так пробовала но при открытии формв срабатывает ошибка Поле объекта не обнаружено.

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Забыл сказать, что этот метод работает только
&НаСервере
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн nuraez

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-15
  • Сайт: 
  • Профессия: Программист 1С
И как быть в такой ситуации?

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Хотя нет, вру, на клиенте работает тоже...
Можете написать версию платформы и скинуть процедуру/функцию в которой вы хотите получить имя формы..
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн nuraez

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-15
  • Сайт: 
  • Профессия: Программист 1С
Функция дкСписокПередОткрытием(ЭтаФорма, Отказ, СтандартнаяОбработка) Экспорт

// Может быть отраслевое переопределение функции модуля...
Результат = орФормаПередОткрытием(ЭтаФорма, Отказ, СтандартнаяОбработка);
Если Результат <> Неопределено Тогда
Возврат Результат;

Иначе
Результат = Истина;
КонецЕсли;

Попытка ПраваПользователя = ЭтаФорма.ЭтотОбъект.Права; Исключение ПраваПользователя = НЕОПРЕДЕЛЕНО; КонецПопытки;
Попытка
ОтношениеКРегламентированномуУчету = обПраво("ОтношениеКРегламентированномуУчету",ПраваПользователя,,ЭтаФорма.Отбор.Ссылка.Значение);
Если ОтношениеКРегламентированномуУчету = Перечисления.ОтношениеКРегламентированномуУчету.ПросмотрТолькоРегламентированныхДокументов Тогда
ЭтаФорма.ДокументСписок.Отбор.РегламентированныйУчет.Значение = Истина;
ЭтаФорма.ДокументСписок.Отбор.РегламентированныйУчет.Использование = Истина;
ЭтаФорма.ЭлементыФормы.список.НастройкаОтбора.РегламентированныйУчет.Доступность = Ложь;
ИначеЕсли ОтношениеКРегламентированномуУчету = Перечисления.ОтношениеКРегламентированномуУчету.ПросмотрТолькоНеРегламентированныхДокументов Тогда
ЭтаФорма.ДокументСписок.Отбор.РегламентированныйУчет.Значение = Ложь;
ЭтаФорма.ДокументСписок.Отбор.РегламентированныйУчет.Использование = Истина;
ЭтаФорма.ЭлементыФормы.список.НастройкаОтбора.РегламентированныйУчет.Доступность = Ложь;
КонецЕсли;
Исключение
КонецПопытки;
           
//Аня проверка по регистру сведений Расширение прав доступа
глПрава=обПолучитьПраваИНастройкиПользователя("");
[size=24pt] Если ОбПраво("Ограничить операции с " +  ЭтаФорма.ИмяФормы)= Истина Тогда[/size][size=14pt][/size]

Запрос =  Новый Запрос();
Запрос = "ВЫБРАТЬ
         | РасширениеПравДоступа.Пользователь,
         | РасширениеПравДоступа.Право,
         | РасширениеПравДоступа.Объект,
         | РасширениеПравДоступа.Значение
         |ИЗ
         | РегистрСведений.РасширениеПравДоступа КАК РасширениеПравДоступа
         |ГДЕ
         | РасширениеПравДоступа.Пользователь = &Пользователь
         | И РасширениеПравДоступа.Право = &Право
         | И РасширениеПравДоступа.Объект = &Объект
         | И РасширениеПравДоступа.Значение = &Значение";


Если ПараметрыСеанса.Пользователь.ШаблонПрав= НЕОПРЕДЕЛЕНО
тогда
   Пользователь =  ПараметрыСеанса.Пользователь ;
     иначе
   Пользователь = ПараметрыСеанса.Пользователь.ШаблонПрав;
КонецЕсли;
Право =  глПрава.Получить("Ограничить операции с" + ЭтаФорма);
Запрос.УстановитьПараметр("Пользователь",Пользователь);
Запрос.УстановитьПараметр("Право",Право);
Запрос.УстановитьПараметр("Объект","Просмотр");
Запрос.установитьПараметр("Значение", "Истина");
РезультатЗапроса= Запрос.Выполнить();
   Если РезультатЗапроса.Пустой() тогда
  результат = Ложь;
   КонецЕсли;
   КонецЕсли;
   //////////////////////////////////////////////////////////////////
// Стандартная обработка
удФормаПередОткрытием(ЭтаФорма, Отказ, СтандартнаяОбработка);
//заполним доп. свойства формы документов
удЗаполнитьДополнительныеДействияДокументов(ЭтаФорма);

Возврат Результат;

КонецФункции // дкСписокПередОткрытием()

Версия 8.1

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Скажу честно, в 8.1 не работал... Попробуйте найти этот метод в синтаксис-помощнике.
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн nuraez

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-09-15
  • Сайт: 
  • Профессия: Программист 1С
почему то в этой функции уже есть ЭтаФорма.ЭтотОбъект.Права, а когда я это же самое прописываю выдает ошибку. почему так?


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 301
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4828
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3421
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5008
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 593
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 269
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal