Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 11:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя обработка для загрузки данных в ТЧ  (Прочитано 2533 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DmitriyF

  • *****
  • Сообщений: 729
  • РЕПУТАЦИЯ: 48
  • КПД: 7%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
Здравствуйте.
Есть обработка на УФ для УТ11.1 в которой есть форма с ТЧ и в ней один реквизит Ссылка на заказы клиентам. При нажатии на кнопку в форме документа открывается форма в которой выбираем нужные нам заказы, далее по товарам в этих заказах формируется ТЗ, которую нужно вставить в ТЧ документа.
Вот код:

Функция СведенияОВнешнейОбработке() Экспорт
   ПараметрыРегистрации = Новый Структура;
   МассивНазначений = Новый Массив;
   МассивНазначений.Добавить("Документ.ЗаказКлиента");
   
   ПараметрыРегистрации.Вставить("Вид", "ЗаполнениеОбъекта");
   ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
   ПараметрыРегистрации.Вставить("Наименование", "Заполнить из заказа");
   ПараметрыРегистрации.Вставить("Версия", "1.1");
   ПараметрыРегистрации.Вставить("БезопасныйРежим", ложь);
   ПараметрыРегистрации.Вставить("Информация", "Добавление позиций из заказа.");
   
   ТаблицаКоманд = ПолучитьТаблицуКоманд();
   
   ДобавитьКоманду(ТаблицаКоманд,
   "Заполнить по заказу",
   "Заполнить по заказу",
   "ОткрытиеФормы",
   Истина);
   
   ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
   
   Возврат ПараметрыРегистрации;
   
КонецФункции

Функция ПолучитьТаблицуКоманд()
   Команды = Новый ТаблицаЗначений;
   Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
   Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
   Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
   Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
   Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
   Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
   
   НоваяКоманда = ТаблицаКоманд.Добавить();
   НоваяКоманда.Представление = Представление;
   НоваяКоманда.Идентификатор = Идентификатор;
   НоваяКоманда.Использование = Использование;
   НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
   НоваяКоманда.Модификатор = Модификатор;
   
КонецПроцедуры

&НаСервере
Функция ЗаполнитьТабличнуюЧасть(ДанныеЗаполнения) Экспорт
   
Как можно в этом месте обратиться к Документу в который нам нужно все загрузить?????????

КонецФункции


Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Как-то так...
&НаСервере
Функция ЗаполнитьТабличнуюЧасть(ДанныеЗаполнения) Экспорт

НовыйДокумент = Документы.ТвойДокумент.СоздатьДокумент();
Для каждого Стр из ДанныеЗаполнения Цикл
НоваяСтрока = НовыйДокумент.ТЧ.Добавить();
НоваяСтрока.Реквизит1 = Стр.Данные1;
НоваяСтрока.Реквизит2 = Стр.Данные3;
НоваяСтрока.Реквизит3 = Стр.Данные3;
КонецЦикла;
НовыйДокумент.Записать(РежимЗаписиДокумента.Проведение);

КонецФункции
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн DmitriyF

  • *****
  • Сообщений: 729
  • РЕПУТАЦИЯ: 48
  • КПД: 7%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
Как-то так...
&НаСервере
Функция ЗаполнитьТабличнуюЧасть(ДанныеЗаполнения) Экспорт

НовыйДокумент = Документы.ТвойДокумент.СоздатьДокумент();
Для каждого Стр из ДанныеЗаполнения Цикл
НоваяСтрока = НовыйДокумент.ТЧ.Добавить();
НоваяСтрока.Реквизит1 = Стр.Данные1;
НоваяСтрока.Реквизит2 = Стр.Данные3;
НоваяСтрока.Реквизит3 = Стр.Данные3;
КонецЦикла;
НовыйДокумент.Записать(РежимЗаписиДокумента.Проведение);

КонецФункции
Это ты имеешь ввиду если создается новый. А я имел ввиду, что я создал документ и из него выбираю заполнить.

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Значит у тебя уже есть ссылка на нужный документ, который нужно заполнить?
Тогда просто получити объект, измени его и запиши!
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн DmitriyF

  • *****
  • Сообщений: 729
  • РЕПУТАЦИЯ: 48
  • КПД: 7%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
Значит у тебя уже есть ссылка на нужный документ, который нужно заполнить?
Тогда просто получити объект, измени его и запиши!
Так вот я  и не могу понять как получить ссылку на объект.

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
&НаКлиенте
Процедура ПриОткрытии(Отказ)
        Попытка
Документ = ЭтаФорма.ВладелецФормы.Объект.Ссылка;
        Исключение
        КонецПопытки;
КонецПроцедуры

Оффлайн DmitriyF

  • *****
  • Сообщений: 729
  • РЕПУТАЦИЯ: 48
  • КПД: 7%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
&НаКлиенте
Процедура ПриОткрытии(Отказ)
        Попытка
Документ = ЭтаФорма.ВладелецФормы.Объект.Ссылка;
        Исключение
        КонецПопытки;
КонецПроцедуры
Получил я ссылку на объект, но изза чего я не могу ПолучитьОбъект() из нее делаю все на сервере?

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
объект еще не записан, поэтому ДанныеФормыВЗначение(<Объект>, <Тип>), только зачем вам нужен объект, если можно заполнить так
НоваяСтрока = Документ["ТабЧасть"].Добавить();


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7445
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3887
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2119
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7351
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6961
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 823
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal