Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Янв 2018, 20:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1c 8.2: выборка с условием  (Прочитано 1514 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jhd235

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-25
  • Сайт: 
  • Профессия: Программист 1С
помогите с условной выборкой, что не так?

&НаСервере
Процедура GetDescr()
Description = ЭтаФорма.Объект.Description;
//Сообщить("Description");
Сообщить("НаСервере "+Description);
Nationality = "%lian%";
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Nationality", Nationality);
Запрос.Текст = "ВЫБРАТЬ
                      | Сотрудники.Nationality.Ссылка КАК Nationality
                      |ИЗ
                      | Справочник.Employees КАК Сотрудники
                      |ГДЕ
                      | Nationality ПОДОБНО  &Nationality";

РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выбрать();
ЕСЛИ Выборка.Количество() = 0 ТОГДА Сообщить("Нулевой результат");
КонецЕсли;
Пока Выборка.Следующий() Цикл
Сообщить(Выборка.Nationality);
КонецЦикла;
//Сообщить(Результат.Description);
//Выборка
//Возврат Description;
//Возврат РезультатЗапроса;
//Возврат Выборка;
КонецПроцедуры
&НаКлиенте
Процедура DescriptionПриИзменении(Элемент)
//Сообщить(Description);
//Description = GetDescr();
GetDescr();
КонецПроцедуры


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
 Сотрудники.Nationality.Ссылка КАК Nationality
НА
 Сотрудники.Nationality.Наименование (ну ил как там, чтоб строка была) КАК Nationality
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн viktor_vv

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-11
  • Сайт: 
Сотрудники.Nationality.Ссылка КАК Nationality
НА
 Сотрудники.Nationality.Наименование (ну ил как там, чтоб строка была) КАК Nationality
И в условии тоже самое сделать. Еще лучше левым соединением прилепить в явном виде справочник nationality и из него выгребать и по нему условие строить.


Теги:
 

Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1663
Последний ответ 25 Май 2016, 19:38
от marshalbratsk
выборка счетов из плана счетов

Автор markgenuineРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3480
Последний ответ 22 Ноя 2012, 12:13
от markgenuine
Выборка - "не может использоваться в данных формы"

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1951
Последний ответ 20 Фев 2015, 09:15
от ferrari314
Выборка данных из табличной части справочника в табличную часть документа

Автор GerryРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 653
Последний ответ 01 Июн 2016, 17:57
от Rasty
Выборка и выгрузка всех документов из одной базы в другую - 1С

Автор Святослав БалашовРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 628
Последний ответ 02 Дек 2016, 21:38
от Святослав Балашов

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
108 Сообщений
AIFrame
100 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
18 Сообщений
andron81_81
16 Сообщений
Artibon
15 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений

* Кто онлайн

  • Точка Гостей: 391
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal