Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 18:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как программно задать реквизиты у предопределенного элемента справочника  (Прочитано 2376 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн G13ma

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-28
  • Сайт: 
  • Профессия: Разработчик 1С
Добрый день.
Никак не получается программно задать реквизиты у предопределенного элемента справочника.
Пробовал искать ни где конкретной инфы нет. Написано что в Конфигураторе задаются только Родитель,Имя,Наименование, и код остальные реквизиты необходимо заполнять программно из процедуры ПриНачалеРаботыСистемы.

Пробовал из обработки
Процедура КнопкаВыполнитьНажатие(Кнопка)
   Справочники.МойСправочник.ПредопределенныйЭлемент.Реквизит = "12354";
КонецПроцедуры

Пробовал из модуля приложения
Процедура ПриНачалеРаботыСистемы()
    Сообщить("Старт");
    Справочники.МойСправочник.ПредопределенныйЭлемент.Реквизит = "12354";
КонецПроцедуры

Во всех случаях пишет "{МодульОбычногоПриложения(3)}: Поле объекта недоступно для записи (Реквизит)
Основной режим запуска обычно приложение
Платформа 8.2


Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Ну тебе же прямо говорят, что "Поле объекта недоступно для записи".
Чтобы он стал доступен для записи, нужно получить объект! А чтобы получить объект, нужно получить сначала ссылку на него.
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Ну тебе же прямо говорят, что "Поле объекта недоступно для записи".
Чтобы он стал доступен для записи, нужно получить объект! А чтобы получить объект, нужно получить сначала ссылку на него.

Чем тебе вот это не ссылка? :bleh:

Справочники.МойСправочник.ПредопределенныйЭлемент

Оффлайн G13ma

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-28
  • Сайт: 
  • Профессия: Разработчик 1С
Спасибо, сообразил


Процедура КнопкаВыполнитьНажатие(Кнопка)
спр =     Справочники.МойСправочник.ПредопределенныйЭлемент.ПолучитьОбъект();
Спр.Реквизит = "1234";
Спр.Записать();
КонецПроцедуры


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6500
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4202
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 639
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2040
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 271
Последний ответ 12 Окт 2017, 14:02
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 240
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal