Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Июн 2018, 23:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проверка проведения документа  (Прочитано 3426 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Andrey5

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-08
  • Сайт: 
  • Профессия: Ученик 1С
При проведении документа проверять что водитель выбранный в «Рейсе» в дату документа присутствует только в одном документе, где одна поездка в день.

Вообщем сравнивает дату сам с собой, как исправить скажите пожалуйста?

Процедура ПроверкаПроведенияДокументаОбработкаПроведения(Источник, Отказ, РежимПроведения) Экспорт
   
   Запрос = Новый Запрос;
   Запрос.УстановитьПараметр("НачалоГода", Источник.Дата);
    Запрос.УстановитьПараметр("КонецГода", Источник.Дата);
   Запрос.УстановитьПараметр("Ссылка", Источник.Ссылка);
   Запрос.УстановитьПараметр("Водитель", Источник.Рейс.Водитель);
   Запрос.Текст = 
                       "ВЫБРАТЬ
                       |   РеализацияТоваровУслуг.Дата КАК Дата
                       |ИЗ
                       |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
                       |ГДЕ
                       |   РеализацияТоваровУслуг.Рейс.Водитель = &Водитель
                       |   И РеализацияТоваровУслуг.Ссылка <> &Ссылка
                       |   И РеализацияТоваровУслуг.Дата МЕЖДУ &НачалоГода И &КонецГода
                       |   И РеализацияТоваровУслуг.Проведен = ИСТИНА";
                   
      Результат = Запрос.Выполнить().Выбрать();
Пока Результат.Следующий() Цикл
      Сообщить ("Водитель выезжает");
      Отказ = Истина;
   //Иначе
   //   Отказ = Ложь;
                                     
    КонецЦикла;
      
КонецПроцедуры


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
При проведении смотреть есть ли документы по этому водителю кроме текущего, в чем проблема то? Просто период указать в день документа, используя НачалоДня и КонецДня

Оффлайн Andrey5

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-08
  • Сайт: 
  • Профессия: Ученик 1С
Теперь проводит документ, но надо чтобы водитель присутствовал только в одной дате, т.е с одинаковыми датами не разрешал проводить документ, как исправить скажите пожалуйста?

Процедура ПроверкаПроведенияДокументаОбработкаПроведения(Источник, Отказ, РежимПроведения) Экспорт
   
   Запрос = Новый Запрос;
   Запрос.УстановитьПараметр("НачалоГода", НачалоДня(Источник.Дата));
 Запрос.УстановитьПараметр("КонецГода", КонецДня(Источник.Дата));
   Запрос.УстановитьПараметр("Ссылка", Источник.Ссылка);
   Запрос.УстановитьПараметр("Водитель", Источник.Рейс.Водитель);
   Запрос.Текст = 
                       "ВЫБРАТЬ
                       |   РеализацияТоваровУслуг.Ссылка
                       |ИЗ
                       |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
                       |ГДЕ
                       |   РеализацияТоваровУслуг.Рейс.Водитель = &Водитель
                       |   И РеализацияТоваровУслуг.Ссылка <> &Ссылка
                       |   И РеализацияТоваровУслуг.Дата МЕЖДУ &НачалоГода И &КонецГода
                       |   И РеализацияТоваровУслуг.Проведен = ИСТИНА";
                   
      Результат = Запрос.Выполнить().Выбрать();
      //Если Результат.Следующий() Тогда
Если Результат.Количество() <> 0  тогда
      Сообщить ("Водитель выезжает");  //были рейсы с другим водителем
      Отказ = Истина;
   
//КонецЕсли;
КонецЕсли;
   // КонецЦикла;
      
КонецПроцедуры

Оффлайн TreeDogNight

  • ***
  • Сообщений: 204
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Запрос = Новый Запрос;
Запрос.Текст = 
"ВЫБРАТЬ
|   РеализацияТоваровУслуг.Ссылка
|ИЗ
|   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
|ГДЕ
|   РеализацияТоваровУслуг.Рейс.Водитель = &Водитель
|   И РеализацияТоваровУслуг.Ссылка <> &Ссылка
|   И РеализацияТоваровУслуг.Дата = &Дата
|   И РеализацияТоваровУслуг.Проведен = ИСТИНА";

Запрос.УстановитьПараметр("Дата" , Источник.Дата);
Запрос.УстановитьПараметр("Ссылка" , Источник.Ссылка);
Запрос.УстановитьПараметр("Водитель" , Источник.Рейс.Водитель);
Результат = Запрос.Выполнить().Выбрать();

Если Результат.Количество() > 0  тогда
Сообщить ("Водитель выезжает");  //были рейсы с другим водителем
Отказ = Истина;
КонецЕсли;

Проверка должна идти по конкретной секудне или по конкретному дню?
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4886
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 17365
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4810
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1256
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8308
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
AIFrame AIFrame
124 Сообщений
alexandr_ll
58 Сообщений
pavl_vs
48 Сообщений
alex0402
47 Сообщений
buketov.av buketov.av
43 Сообщений
ilyay ilyay
36 Сообщений
trialex3
24 Сообщений
magnifico61
21 Сообщений
wise wise
15 Сообщений

* Кто онлайн

  • Точка Гостей: 241
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal