Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 18:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печать и подписи на документах  (Прочитано 9902 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн pole

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-19
  • Сайт: 
  • Профессия: ГлавБух
Добрый день всем. Подскажите пож-та как вставить печать компании и подписи в счет и акт? чтобы постоянно не сканировать, а напрямую из 1с отправлять на электронный адрес клиентам с печью и подписями?


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
в макет табличного документа можно вставить картинку,
сканируете документ, акуратненько вырезаете печать с подписью, вставляете в макет,
при печати получаете и выводите данную область макета в табличный документ.

если несколько подписантов, то под каждого заводите свою область с подписью и печатью,
при выводе документа анализируете фамилию подписывающего и выодите "его" область с его подписью.

при определенных настройках печть табличного документа можно сохранять в файд ПДФ,
его и отправлять по почте.
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Igor100500

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
в макет табличного документа можно вставить картинку,
сканируете документ, акуратненько вырезаете печать с подписью, вставляете в макет,
при печати получаете и выводите данную область макета в табличный документ.

если несколько подписантов, то под каждого заводите свою область с подписью и печатью,
при выводе документа анализируете фамилию подписывающего и выодите "его" область с его подписью.

при определенных настройках печть табличного документа можно сохранять в файд ПДФ,
его и отправлять по почте.

Вот у меня ситуация такая:
1. при нажатии на кнопку печать - формируются счета, акты, претензии. (есть запрос, который подставляет печать и подпись в зависимости от выбранной организации). Все выводит, печатает.
2. Реализовываю возможность отправлять эти документы по эл. почте:
а. Сначала эти документы сохраняются в формате пдф, но они без печатей и подписей(Что нужно дописать, чтобы они сохранялись с ними?)
б. Ну и отправка без проблем работает.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Сначала эти документы сохраняются в формате пдф, но они без печатей и подписей(Что нужно дописать, чтобы они сохранялись с ними?)
т.е. табличный документ на экран выводится с печатями, а в пдф сохраняется без них?

Оффлайн Igor100500

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Сначала эти документы сохраняются в формате пдф, но они без печатей и подписей(Что нужно дописать, чтобы они сохранялись с ними?)
т.е. табличный документ на экран выводится с печатями, а в пдф сохраняется без них?
Да

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
а сохраняете как табличный документ в пдф?

Оффлайн Igor100500

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
а сохраняете как табличный документ в пдф?
Да.
вот код
Процедура СоздатьФайл()

// Вставить содержимое обработчика.
Для каждого й из Объект.Документы Цикл

Если Не ЗначениеЗаполнено(й.ЭлектроннаяПочтаКонтрагента) Тогда

Продолжить;

КонецЕсли;

МассивНакладных = Новый Массив;
МассивНакладных.Добавить(й.Документ);
ОбъектыПечати = Новый СписокЗначений;

ТабДок = ПечатьАктов(МассивНакладных, ОбъектыПечати, ИСТИНА, Истина);

ИмяФайла = "/home/ExchangeLocal/Акт выполненных работ.PDF";
ТабДок.Записать(ИмяФайла, ТипФайлаТабличногоДокумента.PDF);

Если ЗначениеЗаполнено(й.Счет) Тогда
МассивНакладных = Новый Массив;
МассивНакладных.Добавить(й.Счет);
ТабСчет = ПечатьСчетов(МассивНакладных, ОбъектыПечати);

ИмяФайла1 = "/home/ExchangeLocal/Счет на оплату.PDF";
ТабСчет.Записать(ИмяФайла1, ТипФайлаТабличногоДокумента.PDF);
ИначеЕсли ЗначениеЗаполнено(й.СчетФактура) Тогда
МассивНакладных = Новый Массив;
МассивНакладных.Добавить(й.СчетФактура);
ТабСчет = ПечатьСчетовФактур(МассивНакладных, ОбъектыПечати);

ИмяФайла2 = "/home/ExchangeLocal/Счет-фактура.PDF";
ТабСчет.Записать(ИмяФайла2, ТипФайлаТабличногоДокумента.PDF);
КонецЕсли;

Если ЗначениеЗаполнено(й.Претензия) Тогда
МассивНакладных = Новый Массив;
МассивНакладных.Добавить(й.Претензия);
ТабПретензия = ПечатьПретензий(МассивНакладных, ОбъектыПечати);

ИмяФайла3 = "/home/ExchangeLocal/Претензия.PDF";
ТабПретензия.Записать(ИмяФайла3, ТипФайлаТабличногоДокумента.PDF);
КонецЕсли;


КонецЦикла;

УстановитьСоединение(ИмяФайла,ИмяФайла1,ИмяФайла2,ИмяФайла3);


КонецПроцедуры

//Отправкапоимейлу
Процедура УстановитьСоединение(ИмяФайла,ИмяФайла1,ИмяФайла2,ИмяФайла3)   
    Профиль = Новый ИнтернетПочтовыйПрофиль;
    Профиль.АдресСервераSMTP = "smtp.mail.ru";
    Профиль.АдресСервераPOP3 = "pop.mail.ru";
    Профиль.ПортPOP3 = 995;
    Профиль.ПортSMTP = 465;
    Профиль.Пользователь = "123@mail.ru";
    Профиль.Пароль = "123456";
    Профиль.ПользовательSMTP = "123@mail.ru";
    Профиль.ПарольSMTP = "123456";
    Профиль.АутентификацияSMTP = СпособSMTPАутентификации.Login;
Профиль.ИспользоватьSSLPOP3 = Истина;
Профиль.ИспользоватьSSLSMTP = Истина;   
    Почта = Новый ИнтернетПочта;
   
   // Создадим почтовое сообщение
   Для каждого й из объект.Документы Цикл
    Письмо = Новый ИнтернетПочтовоеСообщение;

    Текст = Письмо.Вложения.Добавить(ИмяФайла);
Текст = Письмо.Вложения.Добавить(ИмяФайла1);
Попытка
Исключение Текст = Письмо.Вложения.Добавить(ИмяФайла2);
КонецПопытки;
Текст = Письмо.Вложения.Добавить(ИмяФайла3);

//    Текст.ИмяФайла = ТипФайлаТабличногоДокумента.PDF;
//Письмо.Тема = "Тест";
Письмо.Тема = й.Документ;
    Письмо.Отправитель = "123@mail.ru";
    Письмо.ИмяОтправителя = объект.Организация;
Письмо.Получатели.Добавить(й.ЭлектроннаяПочтаКонтрагента);
   
//Письмо.Получатели.Добавить("123@list.ru");
   
    Попытка
        Почта.Подключиться(Профиль);
        Сообщить("Подключенено");
        Почта.Послать(Письмо);
        Сообщить("Письма отправлены");
    Исключение
        Сообщить("Не удалось подключиться к серверу");
        Сообщить(ОписаниеОшибки());
    КонецПопытки;
   
    Почта.Отключиться();
    Сообщить("Соединение завершено");
КонецЦикла;
КонецПроцедуры

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Попробуйте через временный файл может быть. Не видя базы, сложно скзазать
ВремФайл = ПолучитьИмяВременногоФайла("pdf");
ТабДокумент.Записать(ВремФайл, ТипФайлаТабличногоДокумента.PDF);

Оффлайн Igor100500

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Попробуйте через временный файл может быть. Не видя базы, сложно скзазать
ВремФайл = ПолучитьИмяВременногоФайла("pdf");
ТабДокумент.Записать(ВремФайл, ТипФайлаТабличногоДокумента.PDF);
Не, не катит, разницы нет.

Онлайн Kironten

  • *****
  • Сообщений: 900
  • РЕПУТАЦИЯ: 185
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
А точно вы именно с печатями табдок записываете?
Проверьте на всякий случай:
ТабДок = ПечатьАктов(МассивНакладных, ОбъектыПечати, ИСТИНА, Истина);
ТабДок.Показать();


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 457
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal