Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: поставить галочку при открытии документа  (Прочитано 1582 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
 день добрый.Конфа УПП 13. нахожу документ по штрихкоду. и если документ определенного вида нужно чтобы в нем проставилась галочка.
Процедура ДействияФормыНайтиПоШтрихКоду(Кнопка)
Результат = РаботаСТорговымОборудованием.ВвестиШтрихкод();
готрез= лев(Результат,СтрДлина(Результат)-1);
Если Не ПустаяСтрока(Результат) Тогда

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ШтрихкодыДокументов.Документ
|ИЗ
| Справочник.ШтрихкодыДокументов КАК ШтрихкодыДокументов
|ГДЕ
| ШтрихкодыДокументов.Код = &Штрихкод" ;

Запрос.УстановитьПараметр("Штрихкод", готрез);

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Штрихкод=ВыборкаДетальныеЗаписи.Документ;
КонецЦикла;
   ОткрытьЗначение(Штрихкод);
Если ТипЗнч(Штрихкод)=Тип("ДокументСсылка.ГлобусРасчетЗаказаПокупателя") Тогда
штрихкод.ПриложениеПодписано=Истина;
КонецЕсли;
   
    КонецЕсли;
                 
КонецПроцедуры

В итоге пишет вот что
{ЖурналДокументов.ОбщийСписокДокументов.Форма.ФормаСписка.Форма(27)}: Поле объекта недоступно для записи (ПриложениеПодписано)
            штрихкод.ПриложениеПодписано=Истина;


Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
В свойствах элемента формы не включено свойство "ТолькоПросмотр"?
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
В свойствах элемента формы не включено свойство "ТолькоПросмотр"?
Исправился)))
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Штрихкод=ВыборкаДетальныеЗаписи.Документ;
    Если ТипЗнч(Штрихкод)=Тип("ДокументСсылка.ГлобусРасчетЗаказаПокупателя") Тогда
     ШТ=ВыборкаДетальныеЗаписи.документ.ПолучитьОбъект();
     ШТ.ПриложениеПодписано=Истина;
     ШТ.Записать(РежимЗаписиДокумента.Запись);
  КонецЕсли;   
КонецЦикла;
ОткрытьЗначение(Штрихкод);   


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15903
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4195
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 617
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7734
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 343
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal