Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сделать недоступным пометку удаления документа  (Прочитано 2545 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн stranger12

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-14
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Чуток с горем по полам разобрались. Нельзя отменять редактирование, проводить, И косяк такой, документы проведенные он ставит на удаление, а не проведенные документы он не ставит на удаление,ВОт код как делал.
 Если РежимЗаписи=РежимЗаписиДокумента.Проведение И Не ПараметрыСеанса.глПользователь.ПравоУтверждатьЗаявкиТМЦ И НЕ ПометкаУдаления Тогда
        Предупреждение("Пользователь без права утверждения заявок ТМЦ не может  проводить заявки!");
        РежимЗаписи=РежимЗаписиДокумента.ОтменаПроведения;
        Возврат;
    КонецЕсли;
   
    Если РежимЗаписи=РежимЗаписиДокумента.ОтменаПроведения И Не ПараметрыСеанса.глПользователь.ПравоУтверждатьЗаявкиТМЦ И НЕ ПометкаУдаления Тогда
        Предупреждение("Пользователь без права утверждения заявок ТМЦ не может отменять проведения заявки!");
        РежимЗаписи=РежимЗаписиДокумента.Проведение;
        Возврат;
    КонецЕсли;
   
    Если РежимЗаписи=РежимЗаписиДокумента.Запись И ?(ПометкаУдаления,ПометкаУдаления,НЕ ПометкаУдаления) И Не ПараметрыСеанса.глПользователь.ПравоУтверждатьЗаявкиТМЦ Тогда
        ТекстПредупреждения=?(ПометкаУдаления,"Пользователь без права утверждения заявок ТМЦ не может помечать на удаления документ!","Пользователь без права утверждения заявок ТМЦ не может убирать пометку на удаления документа!");
        Предупреждение(ТекстПредупреждения);
        ПометкаУдаления=НЕ ПометкаУдаления;
        Возврат;
Помогите разобраться, совсем недавно стал 1с заниматься


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
?(ПометкаУдаления,ПометкаУдаления,НЕ ПометкаУдаления)
просто праздник какой-то!!! :ooifh:
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн stranger12

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-14
  • Сайт: 
  • Профессия: Ученик 1С
покажите как нужно  тогда, В долгу не останусь)

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
из вашего описанию не понятно что надо-то?
какие действия с документом вы хотите делать и при каких услвиях?
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн stranger12

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-14
  • Сайт: 
  • Профессия: Ученик 1С
В документе стоит галочка запрет редактирования, Вот если пользователю нельзя редактировать, то он ничего не может сделать с документом,
Но не могу нормально сделать, что бы в форме списка, нельзя было провести документ ,отменить проведение и пометить на удаление.
Знаю,что можно сделать правами, но правами не нужно

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
если только в одном документе надо сделать это ограничение
то в модуле документа, в событии
Будем считать что галочка запрет редактирования - ЗапретРедактирования

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

//***** Проверка условия Если стоит ЗапретРедактирования и нет ПравоУтверждатьЗаявкиТМЦ 
//то документ ни как нельзя записать, проверка в самом начале процедуры
Если Ссылка.ЗапретРедактирования и Не ПараметрыСеанса.глПользователь.ПравоУтверждатьЗаявкиТМЦ  Тогда
Отказ=Ложь;
Возврат;
КонецЕсли;

... //здесь остальной код

КонецПроцедуры //ПередЗаписью()

т.е. открыть документ и поправить его может любой, но сохранить его можно будет если нет галочки или есть ПравоУтверждатьЗаявкиТМЦ. 
что бы не могли редактировать, в модуле формы при открытии надо вставить это условие и открывать форму только на просмотр.

попробуйте должно сработать


Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15903
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4195
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 617
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7734
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 354
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal