Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 03:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запись в регистр сведений информации из txt файла  (Прочитано 1971 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн retker

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-09
  • Сайт: 
  • Профессия: Ученик 1С
Доброго дня подскажите, а то не совсем понял. У меня стоит задача прочитать текстовые файлы в каталоге и записывать определенные строчки (пока что первые 4) в регистр сведений.
Пример текстового файла:
Е009
IvanovRR
110814_173916_698
Active window: Инструменты и справка по AutoIt - Windows Internet Explorer

В регистр сведений должно попасть так:
Е009 - измерение
IvanovRR - измерение
110814_173916_698 - реквизит
Active window: Инструменты и справка по AutoIt - Windows Internet Explorer -реквизит

Вот код:
Процедура Загрузить(Команда)
    МассивФаилов = НайтиФайлы("C:\spy\unsorted\IakovlevEE\", "*.txt");
    Текст = Новый ТекстовыйДокумент;
    Для Каждого Фаил из МассивФаилов Цикл
        Текст.Прочитать(Фаил.ПолноеИмя);
        Для НомерСтроки = 1 по 5 Цикл
            Стр = Текст.ПолучитьСтроку(НомерСтроки);
            Сообщить(Стр);
      Если НомерСтроки = 1 Тогда
         //записываем в регистр
      КонецЕсли;

      Если НомерСтроки = 2 Тогда
         //записываем в регистр
      КонецЕсли;
      //....         
        КонецЦикла;
    КонецЦикла;
КонецПроцедуры

Подскажите как правильно прописать запись в регистр?


Оффлайн freez1301

  • ***
  • Сообщений: 130
  • РЕПУТАЦИЯ: 8
  • КПД: 6%
  • Регистрация: 2014-04-25
  • Сайт: 
  • Профессия: Ученик 1С
рег = РегистрыСведений.НазваниеРегистра.СоздатьМенеджерЗаписи();
дальше присваиваете что надо и записываете

Оффлайн retker

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-09
  • Сайт: 
  • Профессия: Ученик 1С
рег = РегистрыСведений.НазваниеРегистра.СоздатьМенеджерЗаписи();
дальше присваиваете что надо и записываете
Спасибо понял. А еще подскажите как можно получить количество записей в регистре сведения?

Оффлайн DmitriyF

  • *****
  • Сообщений: 730
  • РЕПУТАЦИЯ: 48
  • КПД: 7%
  • Регистрация: 2013-03-18
  • Сайт: 
  • Профессия: Разработчик 1С
рег = РегистрыСведений.НазваниеРегистра.СоздатьМенеджерЗаписи();
дальше присваиваете что надо и записываете
Спасибо понял. А еще подскажите как можно получить количество записей в регистре сведения?
Так не пробовали какойтотамрегистр.количество()

Оффлайн retker

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-09
  • Сайт: 
  • Профессия: Ученик 1С
Так не пробовали какойтотамрегистр.количество()
Пробовал, писал РегистрыСведений.МойРегистр... А далее в выпадающем меню по Ctrl+_ фунции КоличествоСтрок нету. Поэтому и спросил.

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
попробуйте через запрос

выбрать количество(1) как Количество из РегистрСведений.НазваниеРегистра
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн retker

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-12-09
  • Сайт: 
  • Профессия: Ученик 1С
рег = РегистрыСведений.НазваниеРегистра.СоздатьМенеджерЗаписи();
дальше присваиваете что надо и записываете

Процедура КнопкаВыполнитьНажатие(Кнопка)
индекс = 1;
Попытка
    МассивФаилов = НайтиФайлы("C:\spy\unsorted\Evgen\", "*.txt");
Исключение
Сообщить("Фаилов нет!");
КонецПопытки;
    Текст = Новый ТекстовыйДокумент;

//Получить последнюю строку регистра ее номер, пока не реализованна поэтому чищу реестр перед каждым заполнением

Для Каждого Фаил из МассивФаилов Цикл
    Текст.Прочитать(Фаил.ПолноеИмя);

Для НомСтр = 2 по 4 Цикл
    Стр = Текст.ПолучитьСтроку(НомСтр);

Если НомСтр = 2 Тогда
Компьютер = Стр;
КонецЕсли;

Если НомСтр = 3 Тогда
Пользователь = Стр;
КонецЕсли;

Если НомСтр = 4 Тогда
ДатаФаила = Стр;
КонецЕсли;
КонецЦикла;

Для НомСтр = 5 по Текст.КоличествоСтрок() Цикл
Стр = Текст.ПолучитьСтроку(НомСтр);
СтрРег = РегистрыСведений.ПосещениеСайтов.СоздатьМенеджерЗаписи();

СтрРег.Строчка = индекс;
СтрРег.Компьютер = Компьютер;
СтрРег.Пользователь = Пользователь;
СтрРег.ДатаВремя = ДатаФаила;
СтрРег.АктивноеОкно = Стр;

СтрРег.Записать();
индекс = индекс + 1; КонецЦикла;
     КонецЦикла;
КонецПроцедуры

Заполняется в регистр все кроме полей Компьютер и Пользователь, они в регистре являются измерениям, ссылающиеся на соответствующие справочники. Строчка тоже измерение, но это число, оно заполняется. Подскажите как надо присваивать значения.

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Раз измерения ссылочного типа, то и записывать в них надо естесственно ссылки.
КомпьютерСсылка = Справочники.Компьютеры.НайтиПоНаименованию(Компьютер);
ПользовательСсылка = Справочники.Пользователи.НайтиПоНаименованию(Пользователь);
 СтрРег.Компьютер        = КомпьютерСсылка;
 СтрРег.Пользователь     = ПользовательСсылка;
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.


Теги: txt 
 

Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4851
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7752
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9366
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
В чем отличие регистра сведений от регистра накопления?

Автор Dmitry QweРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 514
Последний ответ 11 Сен 2017, 10:50
от ilyay
Регистры накопления, Регистры сведений, Документы, Проведение

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 8144
Последний ответ 17 Янв 2014, 21:52
от kot_oo

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 123
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal