Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 04:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема при выводе на печать внешнего отчета  (Прочитано 4930 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DelphiN91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день!

Прошу помощи с проблемой при выводе на печать и просмотре бланка внешнего отчета. Проблема в следующем: делаю внешний отчет на основе "Справки о дебиторах" в "Регламентированных отчетах" типовой конфы "Бухгалтерия предприятия 2.0". Нужно было убрать ненужные столбцы и добавить строку "ИТОГО". При формировании отчета все проходит без ошибок, но при просмотре бланка или выводе его на печать строка "ИТОГО" многократно копируется (я так понял, чтобы заполнить область до низа печатной страницы).
Подозреваю, что где-то в коде модуля выбирается строка следующая после последней строки исходной таблицы (как на скриншоте - 25 строка таблицы) и клонируется чтобы заполнить место до низа страницы. Подозреваю, что где-то в этом коде нужно поставить "+1", чтобы выбиралась строка следующая после строки "ИТОГО". Но где поставить эту "+1" понять не могу.
Подскажите пожалуйста! Какой нужно код - предоставлю.


Оффлайн freez1301

  • ***
  • Сообщений: 130
  • РЕПУТАЦИЯ: 8
  • КПД: 6%
  • Регистрация: 2014-04-25
  • Сайт: 
  • Профессия: Ученик 1С
у вас в макете параметр Итого (или как-то так) есть. И вот при формировании табличного док-та этот параметр выводится в цикле.
просто уберите из цикла его

Оффлайн DelphiN91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Подсчет суммы ИТОГО введен в цикл в процедуре ЗаполнитьАвто(). Вывод значения в отчет вынесен за цикл.

Цитировать
{...}

СуммаОтчета = 0;

{...}

мФормаОтчета.Области["П010000101004" + СтрСтр].Значение = ИтоговаяСумма;

СуммаОтчета = СуммаОтчета + ИтоговаяСумма;

КонецЦикла;

мФормаОтчета.Области["СуммаОтчета"].Значение = СуммаОтчета;

{...}

КонецПроцедуры


Оффлайн DelphiN91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Проблему решил. Убрал строку, которую добавлял в таблицу руками и добавил в код модуля автоматическое заполнение ИТОГО в конце таблицы.
Цитировать
   мФормаОтчета.Области["П010000101001" + СтрСтр].Значение = ТекПозиция;
   мФормаОтчета.Области["П010000101002" + СтрСтр].Значение = "ИТОГО:";
   мФормаОтчета.Области["П010000101003" + СтрСтр].Значение = СуммаОтчета;

Возник другой вопрос.
В случае, когда отчет не умещается на одну страницу, при разбиении на страницы, на каждой странице выводится шапка и подвал. Мне необходимо сделать чтобы на первой странице не выводился подвал, на промежуточных страницах (в случае, когда страниц больше двух) не выводились ни шапка, ни подвал, и на последней странице не выводилась шапка. Подскажите, в сторону каких функций/процедур мне посмотреть?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Мне необходимо сделать чтобы на первой странице не выводился подвал, на промежуточных страницах (в случае, когда страниц больше двух) не выводились ни шапка, ни подвал, и на последней странице не выводилась шапка. Подскажите, в сторону каких функций/процедур мне посмотреть?

1. Выводите шапку
2. В цикле выводите строки
3. Выводите подвал

в результате выполнятся все Ваши условия...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн DelphiN91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Я не пишу отдельный отчет, я, фактически, редактирую регламентированный отчет, выдраный из типовой конфы. Все функции/процедуры вывода на печать там уже есть, их мне и надо подправить. Но я никак не додумаюсь в какой конкретно процедуре мне копаться, все слишком непрозрачно. Либо сформированный табличный документ передается на разбиение и печать куда-то еще, в какие-то процедуры, не прописанные в модуле.

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Скинь сюда все процедуры, связанные с печатью. Посмотрим что надо исправить..
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн DelphiN91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Понять бы еще какие вообще процедуры за это отвечают...

Цитата: Процедура Печать
// Процедура управляет выводом отчета на печать.
//
// Параметры:
//  ВидПечати - строка, задающая способ печати:
//              "ПоказатьБланк" - непосредственный вывод на печать;
//              "ПечататьСразу" - с предварительным просмотром.
//
Процедура Печать(ВидПечати, ЧтоИскать = Неопределено) Экспорт

   Если ЧтоИскать = Неопределено Тогда
      Отказ = Ложь;
      РегламентированнаяОтчетность.ПередПечатьюРегламентированногоОтчета(ЭтаФорма, Отказ);
      Если Отказ Тогда
         Возврат;
      КонецЕсли;
   КонецЕсли;

   Если ЧтоИскать = Неопределено И НЕ РегламентированнаяОтчетность.ПринтерДоступен() Тогда
      Предупреждение("Перед формированием печатных форм необходимо определить в системе принтер и
                  |задать его в качестве используемого по умолчанию!");
      Возврат;
   КонецЕсли;
   
   Если ЧтоИскать <> Неопределено Тогда
      СтруктураПоиска = Новый Структура("ИмяТабличногоПоля, НаименованиеЛиста, ЧтоИскать", "ПолеТабличногоДокументаФормаОтчета", "Перечень предприятий-кредиторов", ЧтоИскать);
      РегламентированнаяОтчетность.роНайтиЗначение(ЭтаФорма, СтруктураПоиска);
      Возврат;
   КонецЕсли;
   
   мПечатныеФормы.Очистить();
   
   СтруктураПараметров = Новый Структура;
   СтруктураПараметров.Очистить();
   СтруктураПараметров.Вставить("НаименованиеЛиста",  "Перечень предприятий-кредиторов");
   СтруктураПараметров.Вставить("ОриентацияЛиста",    ОриентацияСтраницы.Портрет);
   СтруктураПараметров.Вставить("ИмяТабличногоПоля",  "ПолеТабличногоДокументаФормаОтчета");
   Структурапараметров.Вставить("ИмяОбластиТаблПоля", "");
   СтруктураПараметров.Вставить("ВидПечати",          ВидПечати);

   РегламентированнаяОтчетность.ВывестиНаПечатьЛистОбщая(ЭтаФорма, СтруктураПараметров);
   
   РегламентированнаяОтчетность.ПроставитьНомераЛистов(ЭтаФорма, ВидПечати, Ложь);

КонецПроцедуры // Печать()

Собственно, ничего больше непосредственно по печати в коде нет.
Есть подозрение, что строка
Цитировать
РегламентированнаяОтчетность.ВывестиНаПечатьЛистОбщая(ЭтаФорма, СтруктураПараметров);
как раз и отвечает за передачу сформированного табличного документа куда-то наружу для предварительного просмотра и вывода на печать.

Оффлайн TreeDogNight

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Хм... Можешь ещё выложить сюда скриншот самого макета.
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

Оффлайн DelphiN91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Этот?


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1175
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4689
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2418
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3319
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3572
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 202
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal