Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 22:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получить реквизит элемента  (Прочитано 1151 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tornado

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-05
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.
   Есть две справочника Клиенты и Контрагенты. Один из реквизита Справочника "Клиенты" "ГдеРаботает" задано тип СправочникСсылка.Контрагенты.
   Есть документ Наряд. В документе выбираем Клиента и следующая поля "Место работы" должно получит данные из реквизита Справочник Клиенты.

Создал процедуру ПриИзменение. Через Запрос получил нужные данные на переменную СТР, но не знаю как присвоит к элементу документа "Место работы" Подскажите пожалуйста!
--------------------------------------
&НаКлиенте
Процедура КлиентПриИзменении(Элемент)
   НайтиМестоРаботы();
КонецПроцедуры

&НаСервере
Процедура НайтиМестоРаботы()
            
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   Справочник.Клиенты.Наименование,
      |   Справочник.Клиенты.ГдеРаботает
      |ИЗ
      |   Справочник.Клиенты"
;
   РезультатЗапроса = Запрос.Выполнить();
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      СТР = ВыборкаДетальныеЗаписи.ГдеРаботает;
   КонецЦикла;

                   
КонецПроцедуры




Оффлайн tornado

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-05
  • Сайт: 
  • Профессия: Ученик 1С
Если
Объект.Ссылка.Фирма = ВыборкаДетальныеЗаписи.ГдеРаботает
То выдает ошибку "Поле объекта недоступно для записи (Фирма)"
                   

Оффлайн Zlobnyi_Troll

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-01
  • Сайт: 
  • Профессия: Программист 1С
А просто "Объект.Фирма = ВыборкаДетальныеЗаписи.ГдеРаботает;" не работает? :)

Чем ссылка от объекта, кстати, отличается, читали? :)

И почему в запросе выбираются все элементы справочника "Клиенты"?

Оффлайн tornado

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-05
  • Сайт: 
  • Профессия: Ученик 1С
А просто "Объект.Фирма = ВыборкаДетальныеЗаписи.ГдеРаботает;" не работает? :)

Чем ссылка от объекта, кстати, отличается, читали? :)

И почему в запросе выбираются все элементы справочника "Клиенты"?


В запросе я просто взял две элемента. А вообще если заработает, мне нужно несколько элемента получить и присвоит. Подскажите если знаете, что надо исправить.


Теги:
 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 4136
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1076
Последний ответ 02 Дек 2016, 12:58
от Jalib
Получить полный HTTP код с сервера, Именно полный!

Автор Shining ninjaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2147
Последний ответ 12 Авг 2011, 15:23
от Shining ninja
Как получить значения элементов формы "ПриИзменении"?

Автор OptyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 7935
Последний ответ 07 Май 2015, 14:38
от Opty
Как получить цену товара контрагента и количество реализованного товара

Автор kbukaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1619
Последний ответ 08 Сен 2015, 15:46
от Klyacksa

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 316
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal