Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 06:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Цвет текста в динамическом списке  (Прочитано 5447 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nekromant

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 4
  • КПД: 13%
  • Регистрация: 2014-07-03
  • Сайт: 
  • Профессия: Программист 1С
Динамический список раб.стола, хочу выделять дату по условию в цикле:
ЦветПредНет = Новый Цвет(0,0,0);
ЦветПред = Новый Цвет(0,128,0);
Пока Выборка.Следующий()Цикл;
Если Формат(Выборка.СрокИсполнения,"ДФ=dd.MM.yyyy") = Формат(ТекущаяДата()+86400,"ДФ=dd.MM.yyyy") Тогда
Элементы.СрокИсполнения.ЦветТекста= ЦветПред;
Иначе
Элементы.СрокИсполнения.ЦветТекста= ЦветПредНет;
КонецЕсли;
КонецЦикла;
Цвет с учетом условия нифига не сохраняется, красится в цвет последней строки в цикле, а именно в черный Цвет(0,0,0)[​IMG]
Если условие порезать:
Если Формат(Выборка.СрокИсполнения,"ДФ=dd.MM.yyyy") = Формат(ТекущаяДата()+86400,"ДФ=dd.MM.yyyy") Тогда 
Элементы.СрокИсполнения.ЦветТекста= ЦветПред;
КонецЕсли;
Тогда все остальные строки по циклу красятся в зеленый Цвет(0,128,0)
Подскажите чего не так??


Оффлайн LexaK

  • *****
  • Сообщений: 1295
  • РЕПУТАЦИЯ: 356
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
в конфигураторе в свойствах списка в настройках на закладке условное оформление, настраиваете условия раскраски чего и как хотите, все применительно к одной(каждой) строки, ни чего ни в каком цикле перебирать не надо.
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Nekromant

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 4
  • КПД: 13%
  • Регистрация: 2014-07-03
  • Сайт: 
  • Профессия: Программист 1С
в конфигураторе в свойствах списка в настройках на закладке условное оформление, настраиваете условия раскраски чего и как хотите, все применительно к одной(каждой) строки, ни чего ни в каком цикле перебирать не надо.
знаю,не подходит....
настройками условия мне не обозначить период (сутки) и формат не задать, по этому и программно.

Оффлайн LexaK

  • *****
  • Сообщений: 1295
  • РЕПУТАЦИЯ: 356
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
в настройках есть сравнение с
Начало вчарашнего дня(недели,месяца,года)
Начало сегодняшнего дня(недели,месяца,года)
Начало завтрашнего дня(недели,месяца,года)
и т.д.
с датами можно построить любые условия.

похоже
наверно лучше отбор задавать на форме в конфигурации, а не на списке (почемуто нестройки на списке, сделанные в конфигураторе, не применяется при запуске приложения, зато помнит настройки представления сделанные во время сеанса пользователями)
Добавлено: 01 Авг 2014, 10:49

Цитировать
наверно лучше отбор задавать на форме в конфигурации, а не на списке (почемуто нестройки на списке, сделанные в конфигураторе, не применяется при запуске приложения
выяснилось глюк платформы 8.2
в 8.3 настройки условного оформления списка нормально применяются
Помогло? - Нажми СПАСИБО!!!
                       :)

Последний раз редактировалось: LexaK; 01 Авг 2014, 10:49. Причина: Объединение сообщений

Оффлайн Nekromant

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 4
  • КПД: 13%
  • Регистрация: 2014-07-03
  • Сайт: 
  • Профессия: Программист 1С
Спасибо, я в итоге решил ограничить себя в пределе дня и не париться больше.....
поставил датаИсполнения больше началоТекДня и датаИсполнения меньше НачалоЗавтрДня :xfbnsdfb:


Теги:
 

Перенесено: Сбросить пользователей в "списке активных пользователей" 1С 8.1

Автор KlyacksaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2909
Последний ответ 12 Май 2011, 21:37
от Klyacksa
Общая Сумма Документов в Списке Документов

Автор Andrey777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 780
Последний ответ 13 Дек 2016, 15:27
от ilyay
Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5466
Последний ответ 24 Ноя 2015, 15:38
от welldone
ЗУП 3.1(базовая). В списке выбора вида тарифа нет "Организации, уплачивающие ЕНВД"

Автор FilidorРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 420
Последний ответ 01 Дек 2017, 08:31
от alex0402
Новая колонка в списке "Реализация товаров и услуг" УТ 10.3

Автор ctxaРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 186
Последний ответ 07 Апр 2018, 22:13
от alex0402

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
155 Сообщений
oleg-x
68 Сообщений
alex0402
64 Сообщений
AIFrame AIFrame
59 Сообщений
wise wise
39 Сообщений
buketov.av buketov.av
36 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений
trialex3
25 Сообщений

* Кто онлайн

  • Точка Гостей: 296
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal