Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Добавить кнопку фильтр на форму (Функция Найти по-умолчанию)  (Прочитано 3206 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн АморальныйТипДанных

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-24
  • Сайт: 
  • Профессия: Ученик 1С
Есть документы Счета на оплату покупателем. Щелкаем мышкой по ячейке Контрагент с нужным контрагентом, далее нажимаем - Найти - Найти.
В результате получаем все счета на оплату покупателем с выбранным контрагентом, а мне нужно, чтобы выбирался контрагент и один раз нажималась кнопка найти.
Кнопка должна быть или на панели или в контекстном меню, которая будет выполнять Найти без дополнительных настроек (чтобы два раза не нажимать Найти).

P.S. Работаю только в GUI. Можно ли это реализовать там?

1с 8.3. Бухгалтерия 3.0


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
сделать можно, но зачем?
это стандартный механизм поиска во всех (или почти) списках документов!

Бухгалтерия у вас находится на поддержке, что бы там что-то править (дорабатывать) надо снимать с поддержки, как тогда будете обновлять бухгалтерию?
Даже если сделаете доработку и сможете обновить конфигурацию базы, то ваши доработки после обновления могут пропасть.

И стоит ли ради всего этого заморачиваться из-за двух нажатий на кнопку Найти?
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн АморальныйТипДанных

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-24
  • Сайт: 
  • Профессия: Ученик 1С
Цитата: LexaK
сделать можно, но зачем?
Ну да я согласен, но в любом случае надо.
Цитата: LexaK
Бухгалтерия у вас находится на поддержке, что бы там что-то править (дорабатывать) надо снимать с поддержки, как тогда будете обновлять бухгалтерию?
Даже если сделаете доработку и сможете обновить конфигурацию базы, то ваши доработки после обновления могут пропасть.
А как тогда делать что-то подобное (отсебятину), чтобы она не пропадала после обновления?

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
Ну да я согласен, но в любом случае надо.

ну если очень надо

1.снимате форму списка с поддержки
2.в конструкторе формы списка добавляете команду Фильтр
3.размещеаете эту команду в Комндной панели
4.вставляете в модуль формы, следующие процедуры.

процедуры

&НаКлиенте
Процедура Фильтр(Команда)
   лкСтрока = Элементы.Список.ТекущиеДанные;
   Если лкСтрока = Неопределено Тогда
      Возврат;
   КонецЕсли;
   лкЭлемент = Элементы.Список.ТекущийЭлемент;
   лкИмяПоля = лкЭлемент.Имя;
   лкЗначениеПоля = лкСтрока[лкИмяПоля];
   УстановитьОтбор(лкИмяПоля, лкЗначениеПоля);
КонецПроцедуры

&НаСервере
Процедура УстановитьОтбор(ИмяПоля, ЗначениеПоля)
//самый простой вариант, по идее здесь нужна проверка   
   лкОтбор = ЭтаФорма.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
   лкОтбор.ЛевоеЗначение    = Новый ПолеКомпоновкиДанных(ИмяПоля);
   лкОтбор.ВидСравнения     = ВидСравненияКомпоновкиДанных.Равно;
   лкОтбор.Использование    = Истина;
   //лкОтбор.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;
   лкОтбор.ПравоеЗначение   = ЗначениеПоля;
КонецПроцедуры

как вклиниться в стандартную настройку фильтра, не нашел. видимо какими-то внутренниими методами 1С может отфильтровать данные списка на самой форме не обращаясь к серверу.
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 226
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal