Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Ноя 2018, 13:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1С + Basic (COM)  (Прочитано 1735 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн YuraAAA

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-10
  • Сайт: 
1С + Basic (COM)
« Первое сообщение: 10 Июл 2010, 19:20 »
Добрый вечер. Возникла проблема.
Я написал программу на Visual Basic , для работы с 1С, соединяются через COM. И всё бы ничего, вот только не могу вызывать процедуры и функции из глобального модуля. В 1C 7.7 была команда ExecuteBatch , но в 1С 8,1 ничего такого нету. Как можно вызвать процедуру глобального модуля через COM?
К примеру, функция:

Функция ПолучитьСписокРолей() Экспорт
   Массив = Новый Массив;
   Для Каждого ТекСтрока ИЗ Метаданные.Роли Цикл
      Если НЕ ПравоДоступа("Администрирование", Метаданные, ТекСтрока) И НЕ ТекСтрока.Имя = "TabSecurity" Тогда
         Массив.Добавить(ТекСтрока.Имя);
      КонецЕсли;
   КонецЦикла;
   Возврат Массив;
КонецФункции


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
77 Сообщений
AIFrame AIFrame
59 Сообщений
wise wise
49 Сообщений
alex0402
43 Сообщений
alexandr_ll
39 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
37 Сообщений
BuhRust
26 Сообщений
andron81_81
24 Сообщений
byte777
22 Сообщений
LexaK
22 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal