Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 03:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Тестовое задание  (Прочитано 1037 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн solideogloria

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Только Богу слава!
  • Регистрация: 2014-07-29
  • Сайт: 
Добрый день, дорогие друзья!
Получил вот такое тестовое задание на дом по вакансии "консультант-программист 1С в службу поддержки".
Не прошу решения.
Очень нуждаюсь в вашей подсказке - возможно ли отчет построить с помощью СКД? Если да, то хотябы наводку, как?(задание во вложении)

На данный момент нашел выход только через написание кода(ито скорее всего, он не универсальный):

&НаСервере
Процедура ОтчетНаСервере()

Таблица = Новый ТаблицаЗначений;
Таблица.Колонки.Добавить("ДатаФактическогоПлатежа");
Таблица.Колонки.Добавить("СуммаФактическогоПлатежа");
Таблица.Колонки.Добавить("ДатаПоПлану");
Таблица.Колонки.Добавить("СуммаПоПлану");


ВыборкаФакт = ПолучитьВыборкуФактОплаты(Период.ДатаОкончания, Период.ДатаНачала, Объект.Контрагент);

ВыборкаПлан = ПолучитьВыборкуПланОплаты(Период.ДатаОкончания, Период.ДатаНачала, Объект.Контрагент);

Если ВыборкаФакт.Количество() = 0 ИЛИ ВыборкаПлан.Количество() = 0 Тогда
Возврат;
КонецЕсли;

Пока ВыборкаФакт.Следующий() Цикл
СледующаяЗапись = Истина;
Если Факт = Неопределено Тогда
Факт = ВыборкаФакт.Сумма;
ИначеЕсли Факт = 0 Тогда
СледующаяЗапись = Ложь;
Факт = ВыборкаФакт.Сумма;
КонецЕсли;

Если Не СледующаяЗапись Тогда
Если План = Неопределено ИЛИ План = 0 Тогда
План = ВыборкаПлан.Сумма;
ИначеЕсли План < 0 Тогда
План = -План;
КонецЕсли;

ЗаписьСтроки(Таблица.Добавить(), ВыборкаФакт.Период, ВыборкаПлан.Период, Факт, План);

Остаток = План;
План = ?(Факт>=План,0,Факт-План);
Факт = ?(Факт>=Остаток,Факт-Остаток,0);
СледующаяЗапись = Истина;
КонецЕсли;

Если СледующаяЗапись Тогда
Пока ВыборкаПлан.Следующий() Цикл

Если План = Неопределено ИЛИ План = 0 Тогда
План = ВыборкаПлан.Сумма;
ИначеЕсли План < 0 Тогда
План = -План;
КонецЕсли;

ЗаписьСтроки(Таблица.Добавить(), ВыборкаФакт.Период, ВыборкаПлан.Период, Факт, План);

Остаток = План;
План = ?(Факт>=План,0,Факт-План);
Факт = ?(Факт>=Остаток,Факт-Остаток,0);
Если Факт=0 Тогда
Прервать;
КонецЕсли;
КонецЦикла;
Если Факт <> 0 Тогда
ЗаписьСтроки(Таблица.Добавить(), ВыборкаФакт.Период, Неопределено, Факт, Факт+1, "Факт");
КонецЕсли;
КонецЕсли;

КонецЦикла;
Если План <> 0 Тогда
ЗаписьСтроки(Таблица.Добавить(), Неопределено, ВыборкаПлан.Период, План+1, План, "План");
КонецЕсли;

Документы.ПланПлатежейПоставщикам.ПолучитьФорму("ФормаОтчет",Новый Структура("ПланФактОплаты", Таблица));


КонецПроцедуры


Последний раз редактировалось: MuI_I_Ika; 29 Июл 2014, 11:39


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Тестовое задание
« Ответ #1: 29 Июл 2014, 11:44 »
Ну по идее здесь только программированием вопрос и решается.

Создать документ и отчет.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Тестовое задание
« Ответ #2: 29 Июл 2014, 12:12 »
Хотя отчет можно было бы и на СКД сделать.

Оффлайн solideogloria

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Только Богу слава!
  • Регистрация: 2014-07-29
  • Сайт: 
Re: Тестовое задание
« Ответ #3: 29 Июл 2014, 13:18 »
Хотя отчет можно было бы и на СКД сделать.

Сложность состоит в том, что при построении запроса в СКД, строки должны формироваться, учитывая даты и суммы предыдущих строк, причем с условием(если я верно понимаю). Не могу понять, как это можно сделать.


 

Вопрос по УНФ (форма "Задание на работу")

Автор tantonyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 343
Последний ответ 22 Июн 2017, 18:22
от tantony
Задание типа файла при сохранении таб.документа "Сохранить копию" во внешний фа

Автор Marta_LiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4311
Последний ответ 22 Дек 2011, 15:34
от sergeevds
Как понять почему перестало работать регламентное задание - "отправка отчетов"?

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2177
Последний ответ 26 Июл 2014, 16:00
от virtus
Не могу отладить фоновое задание база sql платформа 1с 8.3.10.2650

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 203
Последний ответ 09 Ноя 2017, 10:06
от ZSS
Обмен данными УТ 11.0 - Розница 1.0 не срабатывает регламентное задание в УТ

Автор zamaelРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3659
Последний ответ 27 Май 2011, 08:42
от zamael

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 173
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal