Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 20:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Документ Реализация прописать контроль кол-ва дней отсрочки покупателя  (Прочитано 1303 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dacent

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-28
  • Сайт: 
  • Профессия: Программист 7.7
Добрый день.
1-С Предприятие 7.7 для SQL (7.70.027)
Комплексная конфигурация
"Бухгалтерия+Торговля+Склад+Зарплата+Кадры
редакция 4.5 (7.70.460)

Подскажите пожайлуста как правильно прописать в модуле документа реализации контроль кол-ва дней отсрочки контрагента, чтоб накладная не проводилась если есть просроченный долг по кол-ву дней отсрочки.

//******************************************************************************
// КонтрольДатыОплаты()
//
// Параметры:
//  Нет
//
// Возвращаемое значение:
//  В случае, если дата оплаты корректна возвращается пустая строка,
//  в противном случае - соответствующий текст предупреждения.
//
// Описание:
//  Проверяет соответствует ли дата оплаты документа глубине кредита, заданного
//  для данного договора. Вызывается из модулей документов реализации.

Функция КонтрольДатыОплаты ()
Если ДатаОплаты < ДатаДок Тогда
    Возврат "Дата оплаты меньше даты документа!";
КонецЕсли;     
Если Договор.НеКонтролироватьКредит = 0 Тогда
Если ДатаОплаты > глБанковскаяДата(ДатаДок, Договор.ГлубинаКредита) Тогда
    Возврат "Дата оплаты превышает глубину кредита!";
Иначе
Возврат "";
КонецЕсли;
КонецЕсли;
КонецФункции // глКонтрольДатыОплаты()

Последний раз редактировалось: MuI_I_Ika; 28 Июл 2014, 23:24


Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Подскажите пожайлуста как правильно прописать в модуле документа реализации контроль кол-ва дней

Правильно такие вещи писать не в модуле проведения, а в модуле формы, дабы не увеличивать время транзакции.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 335
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal