Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 14:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: алгоритм нумерации  (Прочитано 1185 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ovvner

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-25
  • Сайт: 
есть такая задача:
необходимо чтобы нумерация документов велась по алгоритму мм-дд/000
мм-дд - должно привязываться к дате выписки документа, а
000 - должно обнуляться каждые сутки
пример:
вчера (24 июля) - 07-24/001, 07-24/002, и т.д.
сегодня (25 июля) - 07-25/001, 07-25/002, и т.д.
завтра (26 июля) - 07-26/001, 07-26/002, и т.д.


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
да вроде все просто

в модуле документа пишите

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

Если ПустаяСтрока(Номер) Тогда
    Номер = ПолучитьНомер();
КонецЕсли;

...

КонецПроцедуры // ПередЗаписью

Функция ПолучитьНомер()
    Возврат Формат(дата,"ДФ=MM-dd") + "/" + СледующийНомер;
КонецФункции

СледующийНомер - сами расчитайте!

Добавлено: 25 Июл 2014, 17:07

это при условии, что вы не будете менять дату документа,
а если будете менять дату документа, то программу надо чуть-чуть переделать!!!
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Часть четвертая: переход на «1С» версии «3.0». Где в программе находятся «Параметры учета»? Алгоритм настройки кадрового учета в новой версии программы «1С»

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 3957
Последний ответ 20 Мар 2015, 12:58
от 1cwiki
Табличная часть через "Произвольный алгоритм" в Универс. подб. и обр. объектов

Автор Mixailo333Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9214
Последний ответ 14 Май 2013, 22:48
от Dethmontt
Розница,не могу придумать алгоритм Новичек), треб помощь в понимании логики проц

Автор tradРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 60
Просмотров: 17000
Последний ответ 30 Ноя 2010, 08:31
от trad
Переход на программу «ЗУП 3.0»: алгоритм подготовки и настройки переноса информации с «1С ЗУП» редакции «2.5»

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 3763
Последний ответ 10 Мар 2015, 16:37
от 1cwiki
Алгоритм загрузки изображений из excel по ссылке URL в реквизит основное изображение

Автор nikioioioРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 989
Последний ответ 23 Мар 2016, 05:43
от nikioioio

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal