Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 03:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Список  (Прочитано 1215 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lampa

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-21
  • Сайт: 
  • Профессия: Ученик 1С
Список
« Первое сообщение: 24 Июл 2014, 15:41 »
Подскажите, пожалуйста, у меня есть таблица в которой отображается список номенклатуры. Хочу что бы при открытии этого списка открывалась определённая группа номенклатуры и показывала только ту номенклатуру, которая в этой группе. пишу запрос:

ВЫБРАТЬ
   Номенклатура.Ссылка
ИЗ
   Справочник.Номенклатура КАК Номенклатура
ГДЕ
   Номенклатура.Ссылка В ИЕРАРХИИ (&Гай)
   И НЕ Номенклатура.ЭтоГруппа

ГАЙ = Справочники.Номенклатура.НайтиПоНаименованию("Гай").Ссылка;   
   ИерархияНоменклатуры.Параметры.УстановитьЗначениеПараметра("Гай", ГАЙ);

Всё красиво при нажатии определённой кнопки, запрос отрабатывает и выводит нужную номенклатуру из группы.

Вопрос  - как вывести номенклатуру из другой группы, для другой кнопки, что бы не дублировать запрос? Мне сказали, что можно сделать список значений, но как его сделать?
Извините, я только учусь.



Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Список
« Ответ #1: 24 Июл 2014, 15:45 »
Уточните...

для одной кнопки (группы) сделали, теперь надо сделать то же, только для другой кнопки (группы)?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн lampa

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-21
  • Сайт: 
  • Профессия: Ученик 1С
Re: Список
« Ответ #2: 24 Июл 2014, 15:49 »
Уточните...

для одной кнопки (группы) сделали, теперь надо сделать то же, только для другой кнопки (группы)?

Да, у меня есть много кнопочек и каждая кнопка должна открывать определённую номенклатурную группу из справочника.
По одной группе я сделал запрос, но понял, что придется так копировать и создавать очень много запросов и мне сказали воспользоваться списком значений, но я не понимаю как это сделать.
Добавлено: 24 Июл 2014, 15:57

У меня создан динамический список номенклатуры, в который я поместил этот запрос. У меня ут 8.3 11 =(

Оффлайн freez1301

  • ***
  • Сообщений: 130
  • РЕПУТАЦИЯ: 8
  • КПД: 6%
  • Регистрация: 2014-04-25
  • Сайт: 
  • Профессия: Ученик 1С
Re: Список
« Ответ #3: 24 Июл 2014, 16:26 »
сделайте функцию и вызывайте ее при нажатии на кнопки. При это в качестве параметра функции - передавайте Вашу группу

Оффлайн lampa

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-21
  • Сайт: 
  • Профессия: Ученик 1С
Re: Список
« Ответ #4: 24 Июл 2014, 16:29 »
сделайте функцию и вызывайте ее при нажатии на кнопки. При это в качестве параметра функции - передавайте Вашу группу

Это как? у меня в параметре запроса уже стоит параметр, что нужно выбрать "ГАЙ"

Оффлайн freez1301

  • ***
  • Сообщений: 130
  • РЕПУТАЦИЯ: 8
  • КПД: 6%
  • Регистрация: 2014-04-25
  • Сайт: 
  • Профессия: Ученик 1С
Re: Список
« Ответ #5: 24 Июл 2014, 16:34 »
Процедура НажатиеКнопки1 (Элемент)
Функция ОткрытиеГруппы("Гай1");
КонецПроцедуры

Процедура НажатиеКнопки2 (Элемент)
Функция ОткрытиеГруппы("Гай2");
КонецПроцедуры

Функция ОткрытиеГруппы(Группа)
ВЫБРАТЬ
   Номенклатура.Ссылка
ИЗ
   Справочник.Номенклатура КАК Номенклатура
ГДЕ
   Номенклатура.Ссылка В ИЕРАРХИИ (&Гай)
   И НЕ Номенклатура.ЭтоГруппа
Если Группа = "Гай1" Тогда
ГАЙ = Справочники.Номенклатура.НайтиПоНаименованию("Гай1");
Иначе
ГАЙ = Справочники.Номенклатура.НайтиПоНаименованию("Гай2");
КонецИначе; 
   ИерархияНоменклатуры.Параметры.УстановитьЗначениеПараметра("Гай", ГАЙ);
КонецФункции

как то так

Оффлайн lampa

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-21
  • Сайт: 
  • Профессия: Ученик 1С
Re: Список
« Ответ #6: 24 Июл 2014, 16:46 »
Процедура НажатиеКнопки1 (Элемент)
Функция ОткрытиеГруппы("Гай1");
КонецПроцедуры

Процедура НажатиеКнопки2 (Элемент)
Функция ОткрытиеГруппы("Гай2");
КонецПроцедуры

Функция ОткрытиеГруппы(Группа)
ВЫБРАТЬ
   Номенклатура.Ссылка
ИЗ
   Справочник.Номенклатура КАК Номенклатура
ГДЕ
   Номенклатура.Ссылка В ИЕРАРХИИ (&Гай)
   И НЕ Номенклатура.ЭтоГруппа
Если Группа = "Гай1" Тогда
ГАЙ = Справочники.Номенклатура.НайтиПоНаименованию("Гай1");
Иначе
ГАЙ = Справочники.Номенклатура.НайтиПоНаименованию("Гай2");
КонецИначе; 
   ИерархияНоменклатуры.Параметры.УстановитьЗначениеПараметра("Гай", ГАЙ);
КонецФункции

как то так

Это получается нужно в этой функции сразу занести все группы, которые мне нужны?

Оффлайн freez1301

  • ***
  • Сообщений: 130
  • РЕПУТАЦИЯ: 8
  • КПД: 6%
  • Регистрация: 2014-04-25
  • Сайт: 
  • Профессия: Ученик 1С
Re: Список
« Ответ #7: 24 Июл 2014, 16:50 »
да, получается так. Просто у тебя будет:

Если .... Тогда
...
ИначеЕсли .... Тогда
....
ИначеЕсли ... Тогда
...
Иначе
...
КонецЕсли;

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Список
« Ответ #8: 25 Июл 2014, 11:41 »
Процедура НажатиеКнопки1 (Элемент)
Функция ОткрытиеГруппы("Гай1");
КонецПроцедуры

Процедура НажатиеКнопки2 (Элемент)
Функция ОткрытиеГруппы("Гай2");
КонецПроцедуры

Функция ОткрытиеГруппы(Группа)
ВЫБРАТЬ
   Номенклатура.Ссылка
ИЗ
   Справочник.Номенклатура КАК Номенклатура
ГДЕ
   Номенклатура.Ссылка В ИЕРАРХИИ (&Гай)
   И НЕ Номенклатура.ЭтоГруппа
Если Группа = "Гай1" Тогда
ГАЙ = Справочники.Номенклатура.НайтиПоНаименованию("Гай1");
Иначе
ГАЙ = Справочники.Номенклатура.НайтиПоНаименованию("Гай2");
КонецИначе; 
   ИерархияНоменклатуры.Параметры.УстановитьЗначениеПараметра("Гай", ГАЙ);
КонецФункции

как то так

Зачем нужен "Если..." когда можно просто

Функция ОткрытиеГруппы(Группа)
...   
    ГАЙ = Справочники.Номенклатура.НайтиПоНаименованию(Группа);
    ИерархияНоменклатуры.Параметры.УстановитьЗначениеПараметра("Гай", ГАЙ);
...
КонецФункции

и кто так функцию вызывает?
Процедура НажатиеКнопки1 (Элемент)
Функция ОткрытиеГруппы("Гай1");
КонецПроцедуры

и не функция это а процедура
Процедура НажатиеКнопки1 (Элемент)
    ОткрытиеГруппы("Гай1");
КонецПроцедуры
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Что такое "Список Значений", "Таблица значений" и "Дерево Значений"?

Автор JahongirРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6782
Последний ответ 23 Дек 2011, 16:43
от sergeevds
Массив, Таблица значений и Список значений

Автор Константин163Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 5869
Последний ответ 25 Мар 2015, 16:02
от cska-fanat-kz
Дин.список отбор данных - не работает код при тех же данных

Автор Аля ТинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 102
Последний ответ 13 Дек 2017, 09:15
от Аля Тина
Как из справочника вытащить список одной группы справочника и вставить его в поле документа для выбора одного элемента из полученного списка?

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1682
Последний ответ 21 Сен 2016, 08:16
от GadLex
Отчет "Штатно-должностной список"

Автор SashenkaРаздел Закрытые темы

Ответов: 0
Просмотров: 2205
Последний ответ 08 Апр 2010, 03:00
от Sashenka

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 174
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal